English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 07 October 2013, 15:56   #161
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
JFI...
Bergen Party Demo by Cartel

A500 OCS/ECS ... this could be broken version!? ... As one from Link runs just fine on WinUAE! ... But only testing on a real A500 could solve dilemma, right!
Attached Thumbnails
Click image for larger version

Name:	Cartel-BergenPartyDemo_001.png
Views:	96
Size:	9.8 KB
ID:	37081  
amilo3438 is offline  
AdSense AdSense  
Old 07 October 2013, 22:50   #162
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Equipose by Complex

A500 OCS 0.5mb+0.5mb ... after pic.1 is shown demo continue ... what is OK

A500 ECS Agnus 0.5mb+0.5mb ... it stops on pic.2, music continue to play?! (acc. to link the demo is from 1993)


EDIT: Found something interesting ...

Above DMS version behave same as ADF from link and have start screen same as shown on pic.3 ...

But on above 1st link is shown a different start screen, see also on pic.4 ?! ... has anyone ever found this V2.0 version?


EDIT2: Interesting, it works on A1200 configuration ... also, press the fire button to access the extra bonus works in all configs (even on ECS stop screen).
Attached Thumbnails
Click image for larger version

Name:	COMPLEX-Equipose_005.png
Views:	105
Size:	33.7 KB
ID:	37087   Click image for larger version

Name:	COMPLEX-Equipose_004.png
Views:	106
Size:	15.7 KB
ID:	37088   Click image for larger version

Name:	COMPLEX-Equipose_006.png
Views:	94
Size:	6.6 KB
ID:	37089   Click image for larger version

Name:	9582a.png
Views:	96
Size:	4.8 KB
ID:	37090  

Last edited by amilo3438; 07 October 2013 at 23:47.
amilo3438 is offline  
Old 08 October 2013, 17:49   #163
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Another Small Intro by Royal Amiga Force

First AMOS Production by Phenomena Fr

Could not find right configuration to run these demos?!
amilo3438 is offline  
Old 08 October 2013, 17:59   #164
StingRay
move.l #$c0ff33,throat

StingRay's Avatar
 
Join Date: Dec 2005
Location: Berlin/Joymoney
Posts: 5,489
At least the Royal Amiga Force intro requires external libraries (mathffp.library f.e.) and will just quit if these are not found.
StingRay is offline  
Old 08 October 2013, 17:59   #165
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
Another Small Intro by Royal Amiga Force

First AMOS Production by Phenomena Fr

Could not find right configuration to run these demos?!
AMOS = crystall ball says it requires some WB disk libs and stuff. Boot from WB disk.

EDIT: few seconds too late..
Toni Wilen is online now  
Old 08 October 2013, 18:26   #166
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
ABurger Hill by D-Tect & Coma & ADF

A500 OCS/ECS ... is this a joke!?

EDIT: Does the same happens on a real A500?!
Yes and yes.

Quote:
Originally Posted by amilo3438 View Post
JFI...
Bergen Party Demo by Cartel

A500 OCS/ECS ... this could be broken version!? ... As one from Link runs just fine on WinUAE! ... But only testing on a real A500 could solve dilemma, right!
Different file lengths, different contents. But anyway, A500 confirmed.
Toni Wilen is online now  
Old 08 October 2013, 18:55   #167
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Thanks both ...

What about Animotion by Phenomena problem ... in addition, scrolling text seams to be Ok on beta 8 (official ver. 21.09.2013) ... see on pic.1

----------------------------------------------------------------------------------------------------------
EDIT: Just for info... by accident found that the top pixels of scrolling text has been moved:

to left on beta 8 (test ver. 05.10.2013) ... see on pic.2

to right on beta 8 (test ver. 08.10.2013) ... see on pic.3

Maybe that finding could be of use for fixing other existing similar problems mentioned in 1st post on this topic!
----------------------------------------------------------------------------------------------------------

EDIT2:
What about Equipose by Complex problem ... does it stop also on a real A500 ECS?! ... Has somebody found V2 version of it?
Attached Thumbnails
Click image for larger version

Name:	PHENOMENA-Animotion_003.png
Views:	96
Size:	16.5 KB
ID:	37117   Click image for larger version

Name:	PHENOMENA-Animotion_004.png
Views:	96
Size:	16.1 KB
ID:	37118   Click image for larger version

Name:	PHENOMENA-Animotion_005.png
Views:	94
Size:	16.1 KB
ID:	37119  

Last edited by amilo3438; 08 October 2013 at 22:25.
amilo3438 is offline  
Old 08 October 2013, 23:52   #168
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Faketro (Intro) by Scoopex

A500 OCS/ECS ... Vertical scrolling text periodically jumping?! (not shown pic.1)


VektoriJa Viuhahdus (Intro) by Complex & Scoopex

A500 OCS/ECS ... problem shown on pic.2 ?!
Attached Thumbnails
Click image for larger version

Name:	SCOOPEX-Gathering91_001.png
Views:	95
Size:	3.3 KB
ID:	37120   Click image for larger version

Name:	SCOOPEX&COMPLEX-Filled_002.png
Views:	112
Size:	6.8 KB
ID:	37121  

Last edited by amilo3438; 09 October 2013 at 01:05.
amilo3438 is offline  
Old 09 October 2013, 08:10   #169
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
VektoriJa Viuhahdus (Intro) by Complex & Scoopex

A500 OCS/ECS ... problem shown on pic.2 ?!
Problem is not a problem. It is supposed to leak like that
Toni Wilen is online now  
Old 09 October 2013, 20:53   #170
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Geil Intro (Intro) by Alpha Flight

A500 OCS/ECS ... strange sprite garbage appears!

EDIT: Seems was working fine in beta 7 ... so it starts be broken in current beta 8.

p.s. So, it is not supposed to behave like that, right?


EDIT: Seams to be now fixed in beta 8 test ver. 10.10.2013!
Attached Thumbnails
Click image for larger version

Name:	AFL-Geil_001.png
Views:	92
Size:	10.7 KB
ID:	37125   Click image for larger version

Name:	AFL-Geil_002.png
Views:	90
Size:	14.2 KB
ID:	37126   Click image for larger version

Name:	AFL-Geil_003.png
Views:	98
Size:	16.5 KB
ID:	37127  

Last edited by amilo3438; 11 October 2013 at 10:49.
amilo3438 is offline  
Old 09 October 2013, 23:30   #171
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Compass 1 (Diskmagazine) by Alcatraz

A500 OCS/ECS ... strange, this is not a scrolling text issue ... it is static text issue!
Attached Thumbnails
Click image for larger version

Name:	ALCATRAZ-Compass01_001.png
Views:	88
Size:	21.7 KB
ID:	37130   Click image for larger version

Name:	ALCATRAZ-Compass01_003.png
Views:	86
Size:	19.9 KB
ID:	37131  
amilo3438 is offline  
Old 10 October 2013, 16:43   #172
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
Faketro (Intro) by Scoopex

A500 OCS/ECS ... Vertical scrolling text periodically jumping?! (not shown pic.1)
A500 confirmed. (Why? I have no idea)

Quote:
What about Equipose by Complex problem ... does it stop also on a real A500 ECS?! ... Has somebody found V2 version of it?
It is a bug in demo that accidentally works on real hardware. (reads from non-existing custom registers. This will be fully implemented someday)

Quote:
Originally Posted by amilo3438 View Post
Compass 1 (Diskmagazine) by Alcatraz

A500 OCS/ECS ... strange, this is not a scrolling text issue ... it is static text issue!
Same problem. Scrolling has nothing to do with it.
Toni Wilen is online now  
Old 10 October 2013, 19:06   #173
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
What about Animotion by Phenomena problem ... in addition, scrolling text seams to be Ok on beta 8 (official ver. 21.09.2013) ... see on pic.1
It isn't really ok yet even if it may appear to be ok. It is only ok when _every_ listed demo with same problem works

Gap in background color bar seems to be ham mode-related emulation bug (ham switched off in left border but it still stays active until next line) EDIT: this is now fixed. (and it was not ham staying active too long but color change at the end of scanline "leaking" due to ham requiring scanline drawing twice and it didn't reset colors, I think this was working in some old versions)

Last edited by Toni Wilen; 10 October 2013 at 21:40.
Toni Wilen is online now  
Old 11 October 2013, 17:23   #174
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Just for info...

Madness 2 - The Search For Sanity by Anarchy

A500 OCS/ECS ... somewhere between pic.2 and pic.3 - 4MAT 3d object top part is not filled! (It happens fast so its difficult to take a screenshot!)

EDIT: Finally managed to take screenshots using Pause-Break key (WinUAE pause-key) ... see on pic.4 & pic.5
----------------------------------------------------------------------------------------------------------------------------
Note: I noticed when press Pause-Break key, then F12, take a picture, returning back to emu and again press Pause-Break key to
continue emu, I have got left part of screen not updating anymore! Only right part of screen continue to update ... wired!?
----------------------------------------------------------------------------------------------------------------------------
Attached Thumbnails
Click image for larger version

Name:	Anarchy-MadnessII_001.png
Views:	90
Size:	7.5 KB
ID:	37164   Click image for larger version

Name:	Anarchy-MadnessII_002.png
Views:	89
Size:	5.9 KB
ID:	37165   Click image for larger version

Name:	Anarchy-MadnessII_003.png
Views:	83
Size:	7.1 KB
ID:	37166   Click image for larger version

Name:	Anarchy-MadnessII_004.png
Views:	86
Size:	6.5 KB
ID:	37167   Click image for larger version

Name:	Anarchy-MadnessII_005.png
Views:	82
Size:	5.5 KB
ID:	37168  


Last edited by amilo3438; 11 October 2013 at 17:59. Reason: removed PrtScr with Pause-Break key!
amilo3438 is offline  
Old 11 October 2013, 18:17   #175
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Master Of Magic Demo by Anarchy

A500 OCS/ECS ... some glitches on screen! (pic.1 OCS, pic.2 ECS Agnus)

p.s. It seems also as "blue-part" of screen on ECS has been moved a little to right side in comparison to OCS screen?!


EDIT:
Hammer's Mini Intro by Anarchy

A500 OCS ... same here but only on OCS (pic.3)!
Attached Thumbnails
Click image for larger version

Name:	ANARCHY-MasterOfMagic_005.png
Views:	80
Size:	7.2 KB
ID:	37171   Click image for larger version

Name:	ANARCHY-MasterOfMagic_006.png
Views:	78
Size:	7.2 KB
ID:	37172   Click image for larger version

Name:	Anarchy-HammersIntro_002.png
Views:	76
Size:	13.2 KB
ID:	37175  

Last edited by amilo3438; 11 October 2013 at 22:40.
amilo3438 is offline  
Old 11 October 2013, 21:01   #176
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
FYI...
Deja Vu by Anarchy

A500 OCS/ECS ... worked fine with b8, but with the 2013-10-10 winuae.exe there's an error on the sphere part! (as shown on pictures below)
Attached Thumbnails
Click image for larger version

Name:	_Anarchy-DejaVu_001.png
Views:	85
Size:	10.5 KB
ID:	37173   Click image for larger version

Name:	_Anarchy-DejaVu_002.png
Views:	84
Size:	8.8 KB
ID:	37174  
amilo3438 is offline  
Old 12 October 2013, 16:49   #177
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
Was known before this thread
Toni Wilen is online now  
Old 12 October 2013, 17:52   #178
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Quote:
Originally Posted by Toni Wilen View Post
Was known before this thread
Yea, I know ... I found it while testing Anarchy demos/intros so decided to mention it here again just for the info/record.

But to me it looks more like the demo problem then an emu problem.
Are you sure it doesnt happens on a real A500?!
amilo3438 is offline  
Old 12 October 2013, 18:42   #179
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
A500 confirmed (OCS), ECS = very corrupted display because it triggers chipset bug (bitplane DMA can end too late on ECS and AGA causing DMA cycle conflict), this does not happen in emulation (effect looks like some kind of line delay scrambling..) but I added log warning.

Quote:
Hammer's Mini Intro by Anarchy

A500 OCS ... same here but only on OCS (pic.3)!
I think this depends on memory configuration and more, could be some kind of sprite emulation problem too. This is not good test case.

Quote:
Originally Posted by amilo3438 View Post
FYI...
Deja Vu by Anarchy

A500 OCS/ECS ... worked fine with b8, but with the 2013-10-10 winuae.exe there's an error on the sphere part! (as shown on pictures below)
I can't duplicate it working using b8 or any other version..

Quote:
Originally Posted by amilo3438 View Post
Yea, I know ... I found it while testing Anarchy demos/intros so decided to mention it here again just for the info/record.

But to me it looks more like the demo problem then an emu problem.
Are you sure it doesnt happens on a real A500?!
Yes, it is A500 confirmed. This kind of "effect" is very common when "something" takes too long or is too quick and program requires very good timing and is "racing the beam". (Similar to Deja Vu above). If for example bitplane clearing is too fast, it may clear scanlines that are not yet output = cleared empty data is visible at the bottom part of display, not old and correct data.
Toni Wilen is online now  
Old 12 October 2013, 20:36   #180
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
Fixed.
Toni Wilen is online now  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problematic GVP A530 Turbo Mogsy support.Hardware 22 13 November 2012 19:12
Problematic thread? prowler project.EAB 5 28 October 2011 00:06
Problematic Holiday Lemmings 94 demo disk MethodGit support.Games 19 08 November 2010 03:56
Problematic slaves list keropi project.Killergorilla's WHD packs 44 28 November 2008 12:46
Looking for two demos... eternalcrusader request.Demos 3 01 August 2006 08:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:28.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.26005 seconds with 12 queries