English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 19 June 2014, 21:34   #641
SaphirJD
Registered User
SaphirJD's Avatar
 
Join Date: Jun 2012
Location: Austria
Posts: 66
ok But i have now found out the problem was in my case something different, seems my amiga forever rom file was damaged/have restored the backup files again, and now the demo works
SaphirJD is offline  
AdSense AdSense  
Old 19 June 2014, 21:47   #642
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by SaphirJD View Post
ok But i have now found out the problem was in my case something different, seems my amiga forever rom file was damaged/have restored the backup files again, and now the demo works
But in that case any other demo or game would have also failed to load, perhaps nothing would have loaded.. Always do confirmation test with other known good program or without any disks inserted before blaming some specific program to prevent confusion.
Toni Wilen is online now  
Old 20 June 2014, 14:57   #643
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Une Petite Demo (Intro) by Nori & Smt -> http://janeway.exotica.org.uk/release.php?id=72011

WinUAE2810, A500 (most common) OCS/ECS -> some glitches, see on pic. (on above link looks a little different ?!)

EDIT: And also pic.2 !!! (if wait a few seconds more)

EDIT2: Pic.2 problem starts to happen from 2710beta5 !!!

p.s.
Btw, the demo was released just a day after WinUAE2810, so there's no reason to pout because theoretically it was impossible to check it before.
Attached Thumbnails
Click image for larger version

Name:	UnePetiteDemo_001.png
Views:	147
Size:	9.3 KB
ID:	40313   Click image for larger version

Name:	UnePetiteDemo_004.png
Views:	143
Size:	13.9 KB
ID:	40314  

Last edited by amilo3438; 21 June 2014 at 14:12.
amilo3438 is offline  
Old 20 June 2014, 17:11   #644
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Bleu de Prusse (Intro) by Nori & Maxsoft -> http://janeway.exotica.org.uk/release.php?id=66044

WinUAE2810, A500 (most common) -> gray bar blinks, see pic. (evident also in FullTV filter)

p.s. Seems it doesnt happen with ECS Agnus !!!

p.s.2 It starts to happen also from 2710beta5 !!!
Attached Thumbnails
Click image for larger version

Name:	Nori-BleuDePrusse.png
Views:	165
Size:	39.0 KB
ID:	40315  

Last edited by amilo3438; 21 June 2014 at 12:30.
amilo3438 is offline  
Old 22 June 2014, 12:04   #645
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
Une Petite Demo (Intro) by Nori & Smt -> http://janeway.exotica.org.uk/release.php?id=72011
Quote:
Originally Posted by amilo3438 View Post
Bleu de Prusse (Intro) by Nori & Maxsoft -> http://janeway.exotica.org.uk/release.php?id=66044
100% real A500 match for both. Nothing is wrong.

EDIT: Tested using both OCS and ECS Agnus and OCS-only glitches are also confirmed.

Last edited by Toni Wilen; 22 June 2014 at 12:51.
Toni Wilen is online now  
Old 26 June 2014, 21:57   #646
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Ultimate Intro (Intro) by JVC -> http://janeway.exotica.org.uk/release.php?id=72106 (p.s. New, latest adds!)

A500 (most common) -> some glitches !

--------------------------------------------------------------------------------------------
Intro 93 (Intro) by The Zynaps -> http://janeway.exotica.org.uk/release.php?id=72119

A500 (most common) -> JFI ... the screen may looks strange (pic.2), but actually quite good when the emulator is running. It is impossible to take a picture of how it looks right, it needs to run and see.
Attached Thumbnails
Click image for larger version

Name:	JVC-Intro_001.png
Views:	120
Size:	13.7 KB
ID:	40394   Click image for larger version

Name:	Zynaps-Intro93_001.png
Views:	103
Size:	4.6 KB
ID:	40401  

Last edited by amilo3438; 28 June 2014 at 10:55.
amilo3438 is offline  
Old 29 June 2014, 11:58   #647
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
Ultimate Intro (Intro) by JVC -> http://janeway.exotica.org.uk/release.php?id=72106 (p.s. New, latest adds!)
A500 (ECS) and A1000 (1.2 and 1.3) confirmed. Perhaps only works with original release disk or something..

Quote:
Intro 93 (Intro) by The Zynaps -> http://janeway.exotica.org.uk/release.php?id=72119

A500 (most common) -> JFI ... the screen may looks strange (pic.2), but actually quite good when the emulator is running. It is impossible to take a picture of how it looks right, it needs to run and see.
It uses sort of "horizontal interlace", only part of fonts are visible during single frame. (Set "fps.adj" to 1 frame/s to see how it works)
Toni Wilen is online now  
Old 01 August 2014, 15:39   #648
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Magda, Dhe Necrofil (Intro) by Elefantklubben -> http://janeway.exotica.org.uk/release.php?id=72428 (Latest Adds!)

A500 OCS/ECS (most common) -> the green scroll text going up/down but when reach upper position (some 2/3 of screen) it for a moment appears on the screen bottom ?!

(p.s. Perhaps demo code problem, but maybe it should be tested on a real A500 anyway for confirmation.)



Eat Carrots (Intro) by Elefantklubben -> http://janeway.exotica.org.uk/release.php?id=29557

A500 OCS/ECS (most common) -> scroll text speed issue ! (also listen music!)

(p.s. On QS A1200 it doesnt happen, so not sure is it made for A500 at all !) (see EDIT)

EDIT: Seems slowing down doesnt happen on A500 if NTSC is select under Chipset options ?!



Running Man (Intro) by Scoopex -> http://janeway.exotica.org.uk/release.php?id=72396

A500 OCS/ECS (most common) -> strange points around logo! (see on pic.1 & pic.2 specially)
Attached Thumbnails
Click image for larger version

Name:	Scoopex-RunningManIntroFix_001.png
Views:	115
Size:	21.4 KB
ID:	40768   Click image for larger version

Name:	Scoopex-RunningManIntroFix_002.png
Views:	109
Size:	17.8 KB
ID:	40770  

Last edited by amilo3438; 11 August 2014 at 13:16.
amilo3438 is offline  
Old 11 August 2014, 13:04   #649
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Haemorroid Target (Trackmo) by Bidon Dezign -> http://janeway.exotica.org.uk/release.php?id=24139

A500 OCS/ECS (most common) -> see pic.1 !? (seems it doesnt happen in WinUAE2700 version)

p.s. Also, on A500+/600 WinUAE QS configuration got HALT2 !? (Note: On WinUAE2700 version got pic.2 instead HALT2.)
Attached Thumbnails
Click image for larger version

Name:	BIDON_DEZIGN-HemTarg_001.png
Views:	104
Size:	19.3 KB
ID:	40939   Click image for larger version

Name:	BIDON_DEZIGN-HemTarg_002.png
Views:	103
Size:	3.9 KB
ID:	40940  

Last edited by amilo3438; 13 August 2014 at 12:56.
amilo3438 is offline  
Old 13 August 2014, 13:00   #650
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
32 Bit AGA Sprite (Intro) by Brainchild -> http://janeway.exotica.org.uk/release.php?id=72588

A500 OCS/ECS (most common) -> see pic.1 !? (and how it looks on A1200 AGA see pic.2)

p.s. Perhaps AGA demo only! (but also not w/o sprite issues)


EDIT: Seems this was my last post here! (at least I am not going to do it anymore for free)
Attached Thumbnails
Click image for larger version

Name:	BRAINCHILD-BruteForce32bitAGA_001.png
Views:	102
Size:	16.6 KB
ID:	40967   Click image for larger version

Name:	BRAINCHILD-BruteForce32bitAGA_002.png
Views:	103
Size:	17.3 KB
ID:	40968  

Last edited by amilo3438; 17 August 2014 at 22:08. Reason: p.s. and p.s.2 removed on request
amilo3438 is offline  
Old 13 August 2014, 20:22   #651
Snake79
Registered User

 
Join Date: Feb 2014
Location: Poland
Posts: 168
Quote:
Originally Posted by amilo3438 View Post
EDIT: Seems this was my last post here! (at least I am not going to do it anymore for free)
That would be great loss... You have done much work to help Toni with emulator development. I am thinking also, that proper emulation of basic Amiga configs should be main priority (A500 and A1200 especially), but if Toni decided to focus on PPC now (good luck), then we should be patient and let him to work on it till he done it (or get bored ) and then he will back to normal work on basics i hope... Hold on!
Snake79 is offline  
Old 13 August 2014, 20:45   #652
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Quote:
Originally Posted by Snake79 View Post
That would be great loss... You have done much work to help Toni with emulator development.
You have been till now the 2nd user that recognized my effort, Thanks!

Last edited by TCD; 13 August 2014 at 21:06.
amilo3438 is offline  
Old 13 August 2014, 21:54   #653
Snake79
Registered User

 
Join Date: Feb 2014
Location: Poland
Posts: 168
Quote:
Originally Posted by amilo3438 View Post
You have been till now the 2nd user that recognized my effort, Thanks!
And Thanks in return, it's all for good of Amiga community!
Snake79 is offline  
Old 13 August 2014, 22:26   #654
Leandro Jardim
Registered User
Leandro Jardim's Avatar
 
Join Date: Nov 2009
Location: Legoland
Age: 38
Posts: 1,146
Thanks amilo3438 for your efforts!
Leandro Jardim is offline  
Old 14 August 2014, 05:28   #655
ED-209
Registered User

ED-209's Avatar
 
Join Date: Mar 2012
Location: OCP
Age: 37
Posts: 960
Yes thanks amilo3438, your efforts are more than appreciated! Please don't go anywhere

I have some bugs/questions relating to 020+ CE but will wait until the PPC storm has settled
ED-209 is offline  
Old 14 August 2014, 19:51   #656
SaphirJD
Registered User
SaphirJD's Avatar
 
Join Date: Jun 2012
Location: Austria
Posts: 66
Thanks for all your effort Not anymore for free... how about if you get donations?

Last edited by SaphirJD; 14 August 2014 at 19:58.
SaphirJD is offline  
Old 14 August 2014, 22:17   #657
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Thanks guys for your support! (I wonder where you've been hiding so far!)

Do not worry, I'm not leaving anywhere. I guess we'll have to be a little patient while this euphoria with PPC emulation is not finished, and then we'll see what to do next.

Donations ... ah, no, I'd feel like a mercenary and that would be no more for fun than obligation. All I did this as a volunteer, and let it remain so.

p.s. To me, more is worth your support than any kind of donations.

Cheers!


EDIT:
Note: Some responses went out and because of certain frustration that I am no longer able to help in the development of WinUAE with PPC emulation also ... because my PC has only one CPU core (I know that I could be of help) and if because someone found offended, I can only say that I'm sorry.

Last edited by amilo3438; 14 August 2014 at 23:36.
amilo3438 is offline  
Old 14 August 2014, 23:28   #658
Snake79
Registered User

 
Join Date: Feb 2014
Location: Poland
Posts: 168
Quote:
Originally Posted by amilo3438 View Post
Thanks guys for your support! (I wonder where you've been hiding so far!)

Do not worry, I'm not leaving anywhere. I guess we'll have to be a little patient while this euphoria with PPC emulation is not finished, and then we'll see what to do next.

Donations ... ah, no, I'd feel like a mercenary and that would be no more for fun than obligation. All I did this as a volunteer, and let it remain so.

p.s. To me, more is worth your support than any kind of donations.

Cheers!
That's great news! It's not a mercenary but true knight statement and patience is a virtue We'll wait... Greetings!
Snake79 is offline  
Old 15 August 2014, 10:24   #659
Nickman1200
Registered User

 
Join Date: Jul 2014
Location: Östersund
Posts: 23
One more "Good work" from me
Nickman1200 is offline  
Old 18 August 2014, 07:27   #660
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Back to A500 from PPC..

Quote:
Originally Posted by amilo3438 View Post
Magda, Dhe Necrofil (Intro) by Elefantklubben -> http://janeway.exotica.org.uk/release.php?id=72428 (Latest Adds!)

A500 OCS/ECS (most common) -> the green scroll text going up/down but when reach upper position (some 2/3 of screen) it for a moment appears on the screen bottom ?!
A500 confirmed. (I don't understand how is this demo supposed to work without that jumpy scroller..)

Quote:
Eat Carrots (Intro) by Elefantklubben -> http://janeway.exotica.org.uk/release.php?id=29557

A500 OCS/ECS (most common) -> scroll text speed issue ! (also listen music!)
A500 confirmed. I guess it is designed for faster CPUs.. (or faster memory or at least something faster than A500)

Quote:
Running Man (Intro) by Scoopex -> http://janeway.exotica.org.uk/release.php?id=72396

A500 OCS/ECS (most common) -> strange points around logo! (see on pic.1 & pic.2 specially)
This is new undocumented feature!

Logo fade effect should fade to black, not to ugly greenish box. This is similar chipset undocumented feature/bug that SWIV uses for scoreboard graphics where invalid BPLCON2 PF2P2 value (>5) messes up bitplane color selection (without messing up bitplane/sprite priority selection).

If dual playfield and PF2P2 > 5: dual playfield planes #2 become transparent but it still hides planes #1 behind it if PF2PRI is set and plane has any non-zero pixels! It basically becomes transparent mask plane.

I don't think coder even noticed it because planes #2 palette has one palette entry that has exactly same color as background (and background is not fully black), my guess is that BPLCON2 was accidentally set to wrong value and "mask" plane was prefilled with wrong color. (Plane color value should have been 4, is 1, wrong plane filled)

Quote:
Haemorroid Target (Trackmo) by Bidon Dezign -> http://janeway.exotica.org.uk/release.php?id=24139

A500 OCS/ECS (most common) -> see pic.1 !? (seems it doesnt happen in WinUAE2700 version)

p.s. Also, on A500+/600 WinUAE QS configuration got HALT2 !? (Note: On WinUAE2700 version got pic.2 instead HALT2.)
It is correct, it was undocumented feature that was implemented in 2.8.0. It is ugly but correct.

Don't really care what happens with invalid configs.

Quote:
32 Bit AGA Sprite (Intro) by Brainchild -> http://janeway.exotica.org.uk/release.php?id=72588

A500 OCS/ECS (most common) -> see pic.1 !? (and how it looks on A1200 AGA see pic.2)
Works for me without garbage with A1200 config (correct looking sprite). A500 behavior is correct (corrupt sprite).
Toni Wilen is online now  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problematic GVP A530 Turbo Mogsy support.Hardware 22 13 November 2012 19:12
Problematic thread? prowler project.EAB 5 28 October 2011 00:06
Problematic Holiday Lemmings 94 demo disk MethodGit support.Games 19 08 November 2010 03:56
Problematic slaves list keropi project.Killergorilla's WHD packs 44 28 November 2008 12:46
Looking for two demos... eternalcrusader request.Demos 3 01 August 2006 08:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:28.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.25659 seconds with 12 queries