English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 29 March 2014, 23:09   #621
mai
Moderator
mai's Avatar
 
Join Date: Feb 2008
Location: Stendal/Germany
Age: 49
Posts: 4,566
Quote:
Originally Posted by amilo3438 View Post
There is no any screen corruption in new .ADF version:

pic.1 - old .DMS version, pic.2 - new .ADF version
of course, i meant the screenshot on Bitworld is still not exchanged:
http://kestra.exotica.org.uk/files/s...000/12473h.png
mai is online now  
AdSense AdSense  
Old 29 March 2014, 23:24   #622
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Quote:
Originally Posted by mai View Post
of course, i meant the screenshot on Bitworld is still not exchanged:
http://kestra.exotica.org.uk/files/s...000/12473h.png
Yeah, the picture there is still the same.

p.s.
Do you maybe (or anyone else) have info about other "Not 'emulation bug' Demos" from the 1st page that are now fixed/repaired ?! (please report here if found any)
amilo3438 is offline  
Old 30 March 2014, 09:51   #623
mai
Moderator
mai's Avatar
 
Join Date: Feb 2008
Location: Stendal/Germany
Age: 49
Posts: 4,566
Quote:
Originally Posted by amilo3438 View Post
Yeah, the picture there is still the same.

p.s.
Do you maybe (or anyone else) have info about other "Not 'emulation bug' Demos" from the 1st page that are now fixed/repaired ?! (please report here if found any)
There are some demos in first post, where a bad dump is reason for corruption.
Meanwhile you can take current TOSEC release as reference.
mai is online now  
Old 26 April 2014, 23:16   #624
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Note: Below demo has recently been added in Kestra BitWorld Demobase!

Roadrunner (Demo) by Copperteam -> http://janeway.exotica.org.uk/release.php?id=71362

A500 OCS (most common) -> some 3 strange dashes visible in overscan (but also not in Fullscreen(TV) if filter is enabled)


p.s. nothing important, mention it here (as well as all previous) in case if you would wanted to check it on an real Amiga!

(Probably usual overscan bug!)
Cheers
Attached Thumbnails
Click image for larger version

Name:	COPPERTEAM-Demo_001.png
Views:	191
Size:	12.0 KB
ID:	39806  

Last edited by amilo3438; 27 April 2014 at 08:52. Reason: overscreen to overscan
amilo3438 is offline  
Old 27 April 2014, 08:53   #625
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,523
Quote:
Originally Posted by amilo3438 View Post
(Probably usual overscan bug)
Yes. Demo has too small horizontal display window start value, not visible on most normal TVs.
Toni Wilen is online now  
Old 07 May 2014, 14:38   #626
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Another recently added demo -> KS1.3 adf version ...

Megademo (Demo) by Ivory -> http://janeway.exotica.org.uk/release.php?id=866

A500 OCS (most common) -> some glitches on KS1.3 adf version (see on pic.) !!! (it doesnt happen on dms version in KS1.2)

(hmm, perhaps bad/damaged KS1.3 demo version or something else ... ?!)
Attached Thumbnails
Click image for larger version

Name:	Clipboard01.png
Views:	162
Size:	27.0 KB
ID:	39915  
amilo3438 is offline  
Old 29 May 2014, 20:52   #627
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,523
Quote:
Originally Posted by amilo3438 View Post
A500 OCS (most common) -> some glitches on KS1.3 adf version (see on pic.) !!! (it doesnt happen on dms version in KS1.2)
A500 confirmed (better late than never), probably some bug, all parts are packed, even single bit disk error would break it completely.

dms version crashes on 1.3 because it patches exec with direct rom addresses.. (1.3 compatible version has totally different bootblock and loader code)

Code:
000015F6 2279 0000 0004           MOVEA.L $00000004,A1
000015FC 43e9 0238                LEA.L (A1, $0238),A1
00001600 32bc 4ef9                MOVE.W #$4ef9,(A1)
00001604 237c 00fc 12fc 0002      MOVE.L #$00fc12fc,(A1, $0002)
0000160C 2c79 0000 0004           MOVEA.L $00000004,A6
00001612 2d49 0094                MOVE.L A1,(A6, $0094)
And now some pre-emptive not 2.8.0+ bug information about Batman Vuelve / Batman Group.

Image at the very beginning of demo that shows batman for the first time has buggy cape graphics if OCS Agnus (note that it gets fixed when lightning strikes). This worked (incorrectly) without corruption in 2.7.0 and earlier. Correct behavior is broken graphics if OCS. Works if ECS.

There are also 2 other small glitches that are not emulation problems:

Following parts that have dot and line tunnels have darker area at the bottom of display.

Later part with running animal projected on a white vector cube has single frame that shows broken fill pattern on top part of cube.

A500 OCS and A500 ECS 100% confirmed.
Toni Wilen is online now  
Old 30 May 2014, 16:36   #628
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Quote:
Originally Posted by Toni Wilen View Post
And now some pre-emptive not 2.8.0+ bug information about Batman Vuelve / Batman Group.

Image at the very beginning of demo that shows batman for the first time has buggy cape graphics if OCS Agnus (note that it gets fixed when lightning strikes). This worked (incorrectly) without corruption in 2.7.0 and earlier. Correct behavior is broken graphics if OCS. Works if ECS.
Maybe pictures speaks more than words !!!

Batman Vuelve (Trackmo) by Batman Group -> http://janeway.exotica.org.uk/release.php?id=4262

On above link it said -> Released: 1995-07-23 ! (thus perhaps it is not supposed to work correctly in OCS)

But yeah, it is good to know that now it behaves correct in OCS too.

EDIT:
It looks to be fixed in test WinUAE 2710 beta4 (2014.01.25.) ...

perhaps below quote fixed it -> http://eab.abime.net/showpost.php?p=935948&postcount=40

Quote:
- OCS Agnus requires one cycle between sprite DMA and bitplane DMA, ECS Agnus can have both cycles back to back. This means OCS Agnus will only fetch first sprite word (practically making sprite useless) where ECS Agnus can fetch both.
Attached Thumbnails
Click image for larger version

Name:	BG-BatmanVuelveB_001.png
Views:	152
Size:	23.7 KB
ID:	40161   Click image for larger version

Name:	BG-BatmanVuelveB_002.png
Views:	156
Size:	26.0 KB
ID:	40162  

Last edited by amilo3438; 30 May 2014 at 17:31.
amilo3438 is offline  
Old 31 May 2014, 15:58   #629
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,523
Quote:
Originally Posted by amilo3438 View Post
perhaps below quote fixed it
Obviously Complete left side of display (building + batman) is made from multiple tall sprites.
Toni Wilen is online now  
Old 08 June 2014, 21:31   #630
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
2.8.x (new) demo glitches

A500 OCS/ECS (most common) ... Mindriot / Andromeda demo is broken (see pic.) ... (2710b4 - last version where still works ok)

Cheers
Attached Thumbnails
Click image for larger version

Name:	ANDROMEDA-Mindriot_001.png
Views:	164
Size:	9.5 KB
ID:	40234  

Last edited by amilo3438; 08 June 2014 at 21:38.
amilo3438 is offline  
Old 08 June 2014, 22:20   #631
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
A500 ECS (most common) ... Surrealism / Andromeda demo ... some glitches in marked area, see pic. below. (2710b3 - last version were it does not happen)
Attached Thumbnails
Click image for larger version

Name:	Andromeda-Surrealism_001.png
Views:	161
Size:	11.2 KB
ID:	40236  
amilo3438 is offline  
Old 09 June 2014, 18:15   #632
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,523
Should be finally really (and so on..) work correctly.. There was another undocumented side-effect that was not emulated which was the real cause for rindadink (original, not redux) extra pixel. Previous fix was simply wrong and broke other demos.
Toni Wilen is online now  
Old 10 June 2014, 18:08   #633
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
A500 (most common) ... CoderTrash / Mexx ... strange glitches on last part of demo; from generated 11 pictures only on four pictures are noticeable glitches ...
see on attached pics. below: (tested on 2710b6; didnt test older versions)

EDIT: Also, some glitch is present on 1st picture (see on pic. 6) !? (wonder how I missed it during last year's of massive testing demos )
Attached Thumbnails
Click image for larger version

Name:	Mexx-CoderTrash_007.png
Views:	104
Size:	9.3 KB
ID:	40254   Click image for larger version

Name:	Mexx-CoderTrash_008.png
Views:	108
Size:	10.0 KB
ID:	40255   Click image for larger version

Name:	Mexx-CoderTrash_009.png
Views:	105
Size:	14.7 KB
ID:	40256   Click image for larger version

Name:	Mexx-CoderTrash_010.png
Views:	105
Size:	9.3 KB
ID:	40257   Click image for larger version

Name:	Mexx-CoderTrash_011.png
Views:	99
Size:	66.8 KB
ID:	40258  

Click image for larger version

Name:	Mexx-CoderTrash_003.png
Views:	111
Size:	17.3 KB
ID:	40259  

Last edited by amilo3438; 10 June 2014 at 18:38.
amilo3438 is offline  
Old 10 June 2014, 18:56   #634
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,523
I think you are again in wrong thread because it happens with 2.7.0 too

(and where is the glitch in image 3?) EDIT: just testing and it is exactly as in your screenshot.

EDIT2: A500 test done. Identical glitches confirmed in "cyclepics" part.

EDIT: this probably belongs to your big thread.

Last edited by Toni Wilen; 10 June 2014 at 19:11.
Toni Wilen is online now  
Old 13 June 2014, 12:19   #635
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
A500 (most common) ... Straight Outta Jörlanda / Insane

Red border (pic.1) ?!
also if ECS Denise then is black (pic.2) ... is that correct ?!
Attached Thumbnails
Click image for larger version

Name:	Insane-StraightOuttaJorlanda_001.png
Views:	108
Size:	17.2 KB
ID:	40276   Click image for larger version

Name:	Insane-StraightOuttaJorlanda_002.png
Views:	111
Size:	15.9 KB
ID:	40277  
amilo3438 is offline  
Old 13 June 2014, 14:33   #636
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,523
Quote:
Originally Posted by amilo3438 View Post
A500 (most common) ... Straight Outta Jörlanda / Insane

Red border (pic.1) ?!
also if ECS Denise then is black (pic.2) ... is that correct ?!
Yes and yes.

It enables borderblank option which is ECS Denise and AGA only.

For some reason it also has obvious border color gap in first line of image (COLOR0 change too late in copperlist).
Toni Wilen is online now  
Old 13 June 2014, 18:23   #637
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Almost forgot on this ... Hifreaks / Supplex glitches again from 2710b8 (see on pic.) ... maybe not worth the trouble !

p.s. Hope, the fix will not broke something else ! (hope so, it should be really all)

Cheers
Attached Thumbnails
Click image for larger version

Name:	Clipboard01.png
Views:	109
Size:	14.8 KB
ID:	40279  

Last edited by amilo3438; 13 June 2014 at 18:52.
amilo3438 is offline  
Old 13 June 2014, 19:33   #638
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,523
Quote:
Originally Posted by amilo3438 View Post
Almost forgot on this ... Hifreaks / Supplex glitches again from 2710b8 (see on pic.) ... maybe not worth the trouble !

p.s. Hope, the fix will not broke something else ! (hope so, it should be really all)
This is more interesting because I just watched first 5 minutes of this demo 3 times on my real A500 and 2 times there was a glitch, in different places. 3rd time didn't have glitches. I previously never watched it that far because "original" emulation glitch was at the very beginning and this demo is quite boring to watch..

First time glitch appearet when "write to" text was on screen and second time it was about 1min later.

So glitches are normal and this may not be a real bug, just the usual that emulation is designed not to be random at startup to make it possible to replicate exact same behavior with matching config + exact same version. (It is not designed to stay the same between versions)

EDIT: in other words: Nothing will be done.
Toni Wilen is online now  
Old 19 June 2014, 20:22   #639
SaphirJD
Registered User
SaphirJD's Avatar
 
Join Date: Jun 2012
Location: Austria
Posts: 66
http://janeway.exotica.org.uk/release.php?id=70847

Unable to get that to run under newest Winuae versions, tried all possible A500 ECS/OCS variants, but that one does not work.
SaphirJD is offline  
Old 19 June 2014, 20:58   #640
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,523
Quote:
Originally Posted by SaphirJD View Post
http://janeway.exotica.org.uk/release.php?id=70847

Unable to get that to run under newest Winuae versions, tried all possible A500 ECS/OCS variants, but that one does not work.
Works fine with standard A500 CE config. (Make sure you wait, it may look like it exited. Just wait more..)

Also pre-emptive note: any kind of glitches you see are not emulation glitches, especially in plasma part.
Toni Wilen is online now  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problematic GVP A530 Turbo Mogsy support.Hardware 22 13 November 2012 19:12
Problematic thread? prowler project.EAB 5 28 October 2011 00:06
Problematic Holiday Lemmings 94 demo disk MethodGit support.Games 19 08 November 2010 03:56
Problematic slaves list keropi project.Killergorilla's WHD packs 44 28 November 2008 12:46
Looking for two demos... eternalcrusader request.Demos 3 01 August 2006 08:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:26.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.23988 seconds with 12 queries