English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 24 January 2014, 17:47   #561
SaphirJD
Registered User
SaphirJD's Avatar
 
Join Date: Jun 2012
Location: Austria
Posts: 66
Elektroboy Inside from Smoke... There is one specific scene near the end of the demo which is full of graphical glitches.. Source Link:

http://janeway.exotica.org.uk/releas...=11651#credits

Here the screenshot of the not working part:
Click image for larger version

Name:	smoke-elektroboy.jpg
Views:	135
Size:	151.8 KB
ID:	38735

Tested with A1200, A300, A400 quickstart and best compatibility and various Amiga Forever Amikit and Amigasys installations - everywhere the same.

Winuae Version... Latest available Beta 4.

Hope that helps

Last edited by SaphirJD; 24 January 2014 at 17:59.
SaphirJD is offline  
AdSense AdSense  
Old 24 January 2014, 17:59   #562
heavy
Registered User
 
Join Date: Jun 2007
Location: europe
Posts: 169
no aga!
Attached Thumbnails
Click image for larger version

Name:	image1.png
Views:	117
Size:	9.2 KB
ID:	38736  
heavy is offline  
Old 24 January 2014, 18:27   #563
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
@SaphirJD

Hi and thanks for reporting the problem ... but i am afraid Toni is still not interested in AGA demos.

btw. also wrong thread ... this one is open only for OCS & ECS demo problems !!!
amilo3438 is offline  
Old 24 January 2014, 18:56   #564
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
continuation from -> http://eab.abime.net/showpost.php?p=...&postcount=560

Skull - First Intro (Intro) by Traitors -> http://janeway.exotica.org.uk/release.php?id=2863

A500 /KS1.2/0.5 Chip/ ... two static pixels -> pic.1


Goodie (Crack Intro) by Quartex -> http://janeway.exotica.org.uk/release.php?id=1462

A500 /KS1.2/0.5 Chip/ ... strange behaving -> pic.2
Attached Thumbnails
Click image for larger version

Name:	Traitors-SkullIntro_001.png
Views:	105
Size:	18.1 KB
ID:	38741   Click image for larger version

Name:	Quartex-AnotherNew_002.png
Views:	107
Size:	17.8 KB
ID:	38743  

Last edited by amilo3438; 24 January 2014 at 19:34.
amilo3438 is offline  
Old 25 January 2014, 16:57   #565
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Out of topic ...

What conditions need to be fulfilled in order to be found on below list (see pic.) ?

What are the chances to see myself on the list in the next WinUAE revision ?

like: EAB user/amilo3438 - Demo compatibility testing or maybe Special thanks to EAB user amilo3438 for Demo compatibility testing

p.s.
Nothing important, just wondering.
Attached Thumbnails
Click image for larger version

Name:	Contributors.jpg
Views:	118
Size:	79.2 KB
ID:	38749  

Last edited by amilo3438; 25 January 2014 at 17:44.
amilo3438 is offline  
Old 25 January 2014, 17:33   #566
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by SaphirJD View Post
Elektroboy Inside from Smoke... There is one specific scene near the end of the demo which is full of graphical glitches..
It is AGA and even worse than "real" AGA demo, boring C2P stuff with Amiga display hardware working as a dummy display output device only and most of the effects are CPU powered. (Easy test: it usually looks like pixel soup and hardware requirements are very heavy)

Quote:
Originally Posted by amilo3438 View Post
What conditions need to be fulfilled in order to be found on below list (see pic.) ?
I don't really know, I have added maybe 3 or so lines..

Quote:
What are the chances to see myself on the list in the next WinUAE revision ?
It is not zero

Quote:
Originally Posted by amilo3438 View Post
continuation from -> http://eab.abime.net/showpost.php?p=...&postcount=560

Skull - First Intro (Intro) by Traitors -> http://janeway.exotica.org.uk/release.php?id=2863

A500 /KS1.2/0.5 Chip/ ... two static pixels -> pic.1
Fixed. OCS only. ECS has those pixels.

Quote:
Goodie (Crack Intro) by Quartex -> http://janeway.exotica.org.uk/release.php?id=1462

A500 /KS1.2/0.5 Chip/ ... strange behaving -> pic.2
It is correct, it is ugly looking lens effect.
Toni Wilen is online now  
Old 25 January 2014, 17:49   #567
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Hope you not forgot on this also -> http://eab.abime.net/showpost.php?p=...&postcount=560
amilo3438 is offline  
Old 25 January 2014, 18:02   #568
BackSpace
 
Posts: n/a
Quote:
Originally Posted by Toni Wilen View Post
Because configs are different, config and log files are always needed. (also "last beta" does not really say much..)

EDIT: good test is to save state in windowed mode, boot in fullscreen and load the state, does something change? (and vice versa)
Oops! sorry, here's the config, log and savestates files.
I've used WinUae Beta 4.

I've tried save/load the state Windowed <-> FullScreen, same result with Rink A Dink Redux.
Graphic glitch occurs again in fullscreen at demon part.

Last edited by prowler; 25 January 2014 at 21:26. Reason: Fixed quote.
 
Old 25 January 2014, 19:30   #569
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
Wanted (Crack Intro) by Vision Factory & Beyonders -> http://janeway.exotica.org.uk/release.php?id=15913

A500 (most common) ... strange dots/lines -> pic.1


Another Intro (Intro) by Savage -> http://janeway.exotica.org.uk/release.php?id=19975

A500 (most common) ... one pixel/star seems static -> pic.2


A New Modem Import - Pot of Fun (Intro) by Symbiosis -> http://janeway.exotica.org.uk/release.php?id=26672

A500 (most common) ... some glitches -> pic.3 (Note: On 0.5 chip ram it looks different !!!)
All confirmed.

Quote:
Curious (40k Intro) by Abyss -> http://janeway.exotica.org.uk/release.php?id=20768

A500 (most common) ... broken !!! (works fine in 2.7.0)
"broken" isn't very good explanation. I guess you meant it crashing in some semi random point?
Toni Wilen is online now  
Old 25 January 2014, 19:37   #570
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Quote:
Originally Posted by Toni Wilen View Post
"broken" isn't very good explanation. I guess you meant it crashing in some semi random point?
Well, the demo is very short, but ok ... blank screen and only music play after 2nd part so it doesnt run till the end as it should. (also check how it runs on 2.7.0)
amilo3438 is offline  
Old 25 January 2014, 20:05   #571
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Quote:
Originally Posted by Toni Wilen View Post
It is not zero
Thanks, I was just wondering if there is someone who appreciates and recognizes the effort.
amilo3438 is offline  
Old 26 January 2014, 02:46   #572
SaphirJD
Registered User
SaphirJD's Avatar
 
Join Date: Jun 2012
Location: Austria
Posts: 66
Quote:
Originally Posted by Toni Wilen View Post
It is AGA and even worse than "real" AGA demo, boring C2P stuff with Amiga display hardware working as a dummy display output device only and most of the effects are CPU powered. (Easy test: it usually looks like pixel soup and hardware requirements are very heavy)
Sorry to have posted in the wrong thread Anyway, it's amazing how large the number of Amiga demos is wich are running without problems (yes, AGA demos too )

Guess the more time is passing, the more aga demos are also automatically running without the need for demo bug origin research work

And now i better search some classic demos with errors so that i can poste something useful in this thread for once too
SaphirJD is offline  
Old 26 January 2014, 16:18   #573
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
Well, the demo is very short, but ok ... blank screen and only music play after 2nd part so it doesnt run till the end as it should. (also check how it runs on 2.7.0)
I asked because you also missed that if you reset repeatedly, it will crash in first part

Works again but this is will surely break again in future (unless everything is 100% cycle-exact), it is very "works only accidentally" demo..

vblank interrupt runs demo's "sequencer", when it is time to switch parts, it sets variable that tells what code to run next in main loop, also when it exists, it sets another variable that says "vblank done".

Second part has following main loop:

loop:
test mousebutton
if press -> exit
check if demo part number is non-zero
if yes -> exit
check if vblank done is set
if not -> loop

clear vblank done
<run part code>
clear demo part number change variable

jump loop

Can you see the problem?

If vblank interrupt runs (when it is time to switch parts) between "check if demo part number is non-zero" code and "check if vblank done is set" (quite probable because test loop is very small), it will run old code instead of exiting and then clears the change variable and demo gets stuck in current part..
Toni Wilen is online now  
Old 26 January 2014, 22:27   #574
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Out of topic...

Today I spent a pleasant afternoon with my real Amiga 500 ... really has already been passed a long time since the last time she worked. I can not even remember when it was last time, and the main reason for this was of course WinUAE. I'm glad to see that everything was still working and guess what: in the end after I finished, I felt the need to start WinUAE on my PC-Laptop and wondered, will I ever have the need to run a real Amiga again ... to me WinUAE is still much better solution to satisfy all my Amiga needs.
amilo3438 is offline  
Old 29 January 2014, 10:22   #575
TCD
Global Moderator

TCD's Avatar
 
Join Date: Sep 2006
Location: Germany
Age: 39
Posts: 24,032
Off-topic comments removed. Next time take it to PM (if that's really needed...). Thanks in advance.
TCD is offline  
Old 29 January 2014, 16:31   #576
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Ok, back on topic ...

Better Dead Than Alien (Crack Intro) by Bamiga Sector One & The Kent Team & Inertia -> http://janeway.exotica.org.uk/release.php?id=23254

A500 KS1.2, 0.5 Chip ... 3 static pixels -> pic.1

p.s.
Also noticed on latest test winuae.zip (2014-01-26) if start with QS A500 1.2 512 chip configuration, sometimes no WB hand is shown ... only white screen.
Weird, it happen a few times while testing the demo, but for some reason couldnt repeat it again. Yeah, probably I did something wrong.


Major Motion (Crack Intro) by Bamiga Sector One & Quoram -> http://janeway.exotica.org.uk/release.php?id=24186

A500 KS1.2, 0.5 Chip ... 1 static pixels (in overscan) -> pic.2


Mercenary: Escape from Targ and The Second City (Crack Intro) by Bamiga Sector One & The Kent Team -> http://janeway.exotica.org.uk/release.php?id=22457

A500 KS1.2, 0.5 Chip ... the 1st line looks strange -> pic.3
Attached Thumbnails
Click image for larger version

Name:	BS1&TKT&INT-CrBetterDeadThan_001.png
Views:	91
Size:	18.7 KB
ID:	38837   Click image for larger version

Name:	BS1&Quoram-CrMajorMotion_001.png
Views:	83
Size:	12.3 KB
ID:	38838   Click image for larger version

Name:	BS1&TKT-CrMercenary_001.png
Views:	83
Size:	23.5 KB
ID:	38839  

Last edited by amilo3438; 29 January 2014 at 17:11.
amilo3438 is offline  
Old 29 January 2014, 17:38   #577
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
Ok, back on topic ...

Better Dead Than Alien (Crack Intro) by Bamiga Sector One & The Kent Team & Inertia -> http://janeway.exotica.org.uk/release.php?id=23254

A500 KS1.2, 0.5 Chip ... 3 static pixels -> pic.1
3 pixels if OCS, 4 pixels if ECS A500 (ECS) and A1000 confirmed, pixel positions match UAE 100%.

Quote:
p.s.
Also noticed on latest test winuae.zip (2014-01-26) if start with QS A500 1.2 512 chip configuration, sometimes no WB hand is shown ... only white screen.
Weird, it happen a few times while testing the demo, but for some reason couldnt repeat it again. Yeah, probably I did something wrong.
Possibly fixed now.

Quote:
Major Motion (Crack Intro) by Bamiga Sector One & Quoram -> http://janeway.exotica.org.uk/release.php?id=24186

A500 KS1.2, 0.5 Chip ... 1 static pixels (in overscan) -> pic.2
A500 and A1000 confirmed. If coder had seen that pixel, he would also have fixed those copper bar bugs in right border. I am also quite sure that "f" in left border is another demo overscan bug.

Quote:
Mercenary: Escape from Targ and The Second City (Crack Intro) by Bamiga Sector One & The Kent Team -> http://janeway.exotica.org.uk/release.php?id=22457

A500 KS1.2, 0.5 Chip ... the 1st line looks strange -> pic.3
A500 and A1000 confirmed.
Toni Wilen is online now  
Old 29 January 2014, 18:46   #578
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Doc Disk 3 Intro (Intro) by Byte Busters -> http://janeway.exotica.org.uk/release.php?id=21778

A500 (most common) ... some glitches -> pic.1


My Dog Ben (Intro) by Dual Format -> http://janeway.exotica.org.uk/release.php?id=25006

A500 (most common) ... glitches -> pic.2


Catch 'Em - final (Crack Intro) by Delight -> http://janeway.exotica.org.uk/release.php?id=18908

A500 (most common) ... buggy copper conflict with blitter channel D -> pic.3

p.s. Winuae.log doesnt report it if model set to A500+ !!!


48 Hours Production (Demo) by Flashing Bytes -> http://janeway.exotica.org.uk/release.php?id=69991

A500 (OCS, ECS) ... something strange is happening on 1st part ... also seems vector leaking on 2nd part !!!
Attached Thumbnails
Click image for larger version

Name:	BB-DocDisk3-070191_001.png
Views:	96
Size:	9.2 KB
ID:	38840   Click image for larger version

Name:	MyDogBen_001.png
Views:	89
Size:	21.9 KB
ID:	38842   Click image for larger version

Name:	Clipboard01.png
Views:	78
Size:	17.7 KB
ID:	38845  

Last edited by amilo3438; 30 January 2014 at 16:50.
amilo3438 is offline  
Old 30 January 2014, 18:04   #579
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
Doc Disk 3 Intro (Intro) by Byte Busters -> http://janeway.exotica.org.uk/release.php?id=21778

A500 (most common) ... some glitches -> pic.1
Confirmed.

Quote:
My Dog Ben (Intro) by Dual Format -> http://janeway.exotica.org.uk/release.php?id=25006

A500 (most common) ... glitches -> pic.2
Confirmed, glitch is slightly different on real A500, which is normal, it is caused by writing to blitter registers while blitter is active.

Quote:
Catch 'Em - final (Crack Intro) by Delight -> http://janeway.exotica.org.uk/release.php?id=18908

A500 (most common) ... buggy copper conflict with blitter channel D -> pic.3
It is only a log message, it does not do anything (yet), it is not 100% correct.
Can't duplicate your screenshot.

Quote:
48 Hours Production (Demo) by Flashing Bytes -> http://janeway.exotica.org.uk/release.php?id=69991

A500 (OCS, ECS) ... something strange is happening on 1st part ... also seems vector leaking on 2nd part !!!
Both glitches A500 confirmed. Seems to be made for faster system than A500.
Toni Wilen is online now  
Old 30 January 2014, 19:05   #580
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Vision Thing BBS & Endor BBS (Intro) by Infect -> http://janeway.exotica.org.uk/release.php?id=10259

I have tried all WinUAE configs from A500 till A1200 and didnt managed to reach the 2nd screen with no one ... on A1200 it almost blocked all processes on my PC laptop ... so this is main reason why reporting it here. (used test winuae 2014-01-29 16:57)

EDIT: It seems this is AGA demo so found it by accident ...
If you interested found also (by accident) another AGA demo with only music playing after logo screen:
Harmagedon (Demo) by Infect -> http://janeway.exotica.org.uk/release.php?id=358 (Note: Works fine in WinUAE 2.6.1 !!!)

p.s.
I dont know, but maybe would be good that there exist an AGA problem thread also just for collecting the existing problems ... this could be used for near/far future when AGA "phase 2 of 68020 CE" development finished ... who know if there will be someone in future interested for this task ... just saying.

Last edited by amilo3438; 31 January 2014 at 20:42.
amilo3438 is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problematic GVP A530 Turbo Mogsy support.Hardware 22 13 November 2012 19:12
Problematic thread? prowler project.EAB 5 28 October 2011 00:06
Problematic Holiday Lemmings 94 demo disk MethodGit support.Games 19 08 November 2010 03:56
Problematic slaves list keropi project.Killergorilla's WHD packs 44 28 November 2008 12:46
Looking for two demos... eternalcrusader request.Demos 3 01 August 2006 08:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:28.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.29683 seconds with 12 queries