English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 10 November 2013, 18:55   #341
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
While checking some already fixed demos in new Beta12 found this:

Feel Blue (Intro) by Oblivion aka First

winuealog -> "Illegal instruction: 4afc at 00C077F6 -> 00C077F8" ... it happens on the decompression screen!
amilo3438 is offline  
AdSense AdSense  
Old 10 November 2013, 19:52   #342
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
While checking some already fixed demos in new Beta12 found this:

Feel Blue (Intro) by Oblivion aka First

winuealog -> "Illegal instruction: 4afc at 00C077F6 -> 00C077F8" ... it happens on the decompression screen!
Perfectly normal, most likely demo has CPU type detection. (Tries to execute 68010+ instruction, if exception -> it is 68000. Same as KS CPU detection.)
Toni Wilen is online now  
Old 10 November 2013, 22:45   #343
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Pizza & Coke - menu (Intro) by Arise

A500+ (Basic) ... with 68000 or 68010 got Exception 3, but with 68020 works fine.
So its probably then for 68020 or somethings is wrong?

Coop Demo (Intro) by Arise & Awake

A500+ (Basic) ... Exception 3 ?!

Last edited by amilo3438; 10 November 2013 at 23:30.
amilo3438 is offline  
Old 11 November 2013, 19:38   #344
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Xmas Demo by Beyond 2000

A500, KS1.3, OCS, 0.5mb+0.5mb ... Some blue line as shown on pic.1 ?! ... Does it happens on a real A500?

(Btw. On ECS it just stops ... on OCS (1.3, 0.5mb only) it has scrolling text garbage -> pic.2.)
Attached Thumbnails
Click image for larger version

Name:	Beyond2000-XmasDemo_003.png
Views:	125
Size:	15.1 KB
ID:	37777   Click image for larger version

Name:	Beyond2000-XmasDemo_001.png
Views:	121
Size:	12.6 KB
ID:	37778  
amilo3438 is offline  
Old 11 November 2013, 20:00   #345
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
Pizza & Coke - menu (Intro) by Arise

A500+ (Basic) ... with 68000 or 68010 got Exception 3, but with 68020 works fine.
So its probably then for 68020 or somethings is wrong?

Coop Demo (Intro) by Arise & Awake

A500+ (Basic) ... Exception 3 ?!
Why A500+? No demo is made for A500+

Quote:
Originally Posted by amilo3438 View Post
Xmas Demo by Beyond 2000

A500, KS1.3, OCS, 0.5mb+0.5mb ... Some blue line as shown on pic.1 ?! ... Does it happens on a real A500?

(Btw. On ECS it just stops ... on OCS (1.3, 0.5mb only) it has scrolling text garbage -> pic.2.)
Yes and yes. (It does not work with 0.5M, it unpacks over CLI screen which corrupts data)

Not working on ECS: demo has a bug in code that copies color values to color registers, it writes past color registers, including writing zero to BEAMCON0 (ECS register) which changes screen mode to NTSC and demo hangs because it waits for vertical line number that is PAL only..
Toni Wilen is online now  
Old 11 November 2013, 20:44   #346
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Quote:
Originally Posted by Toni Wilen View Post
Why A500+? No demo is made for A500+
Yeah, probably right, but on A500 OCS/ECS got pic. below?!

Also, it works fine only on A1200 AGA and ECS Full config. with 68020 CPU!

p.s. Above mentioned apply for "Pizza & Coke - menu (Intro) by Arise" ... as the "Coop Demo (Intro) by Arise & Awakeother" doesnt work even with 68020?!
Attached Thumbnails
Click image for larger version

Name:	Arise-Pizza&Coke-menu_001.png
Views:	114
Size:	6.2 KB
ID:	37780  

Last edited by amilo3438; 11 November 2013 at 20:54.
amilo3438 is offline  
Old 12 November 2013, 16:01   #347
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Our Newest Crack Intro (Intro) by Byte Busters

A500 OCS (pic.1), ECS (pic.2) ?!
Attached Thumbnails
Click image for larger version

Name:	BYTE_BUSTERS-CrackIntrro_003.png
Views:	135
Size:	14.9 KB
ID:	37790   Click image for larger version

Name:	BYTE_BUSTERS-CrackIntrro_004.png
Views:	128
Size:	12.9 KB
ID:	37791  
amilo3438 is offline  
Old 12 November 2013, 17:24   #348
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
Yeah, probably right, but on A500 OCS/ECS got pic. below?!

Also, it works fine only on A1200 AGA and ECS Full config. with 68020 CPU!

p.s. Above mentioned apply for "Pizza & Coke - menu (Intro) by Arise" ... as the "Coop Demo (Intro) by Arise & Awakeother" doesnt work even with 68020?!
"Coop Demo (Intro) by Arise & Awake" works fine here using normal A500 config.

"Pizza & Coke - menu (Intro) by Arise" requires 68020+. (or someone repacked it using some 68020+ only code?)

Quote:
Originally Posted by amilo3438 View Post
Our Newest Crack Intro (Intro) by Byte Busters

A500 OCS (pic.1), ECS (pic.2) ?!
Yes. Again uses ECS/AGA only display position bits. (This time not accidentally because it only works with ECS!)
Toni Wilen is online now  
Old 12 November 2013, 17:59   #349
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
The Spacecrafts (Demo) by Clones

The glitches on lower left corner (pic.1) happens only on OCS?! (on ECS looks fine)

Quote:
Originally Posted by Toni Wilen View Post
"Coop Demo (Intro) by Arise & Awake" works fine here using normal A500 config.
It works now fine here too! (probably did something wrong in configs so didnt worked before)
Attached Thumbnails
Click image for larger version

Name:	CLONES-Fart_001.png
Views:	126
Size:	16.1 KB
ID:	37792  

Last edited by amilo3438; 12 November 2013 at 18:36.
amilo3438 is offline  
Old 12 November 2013, 20:24   #350
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
The Spacecrafts (Demo) by Clones

The glitches on lower left corner (pic.1) happens only on OCS?! (on ECS looks fine)
Yes, confirmed (A500 ECS vs A1000)
Toni Wilen is online now  
Old 14 November 2013, 00:22   #351
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Can I Play With Madness ? (Demo) by Defcon One

A500 OCS ... glitches (pic.1) caused by blitter issue (pic.2)! (Note: It doesnt happens on ECS!)

EDIT: Well, it happens also on ECS ... (tested in Beta12)

EDIT1: Also, in latest winuae.zip on A500 ECS scanlines3 seems it doesnt happens (pic.4)!

EDIT2: Maybe to early conclusion with EDIT1! Tested again on latest winuae.zip and got pic.4 and then pic.1, so its random!


New Demo -2nd Demo- (Demo) by Defcon One

A500 OCS 512mb ... pic.3 ?!

p.s. It looks this one doesnt have such problem! -> Official (Demo) by Defcon One


Party Time (Demo) by Defcon One

winuaelog -> "BLITTER: register modification during linedraw! 000450e6"
Attached Thumbnails
Click image for larger version

Name:	DEFCON1-CanIPlayWithMad_002.png
Views:	101
Size:	14.0 KB
ID:	37806   Click image for larger version

Name:	Clipboard01.jpg
Views:	104
Size:	39.7 KB
ID:	37807   Click image for larger version

Name:	DEFCON1-Anotherone_001.png
Views:	104
Size:	18.5 KB
ID:	37809   Click image for larger version

Name:	DEFCON1-CanIPlayWithMad_003.png
Views:	95
Size:	5.8 KB
ID:	37810  

Last edited by amilo3438; 14 November 2013 at 09:34.
amilo3438 is offline  
Old 14 November 2013, 17:10   #352
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Orchasm (Intro) by Diffusion

winuaelog -> "BLITTER: register modification during linedraw! 00011bc6" ... (pic.1)

EDIT: Its 1st case where BLITTER issue stops executing demo!

EDIT1: On A500 ECS 1mb chip there is no any BLITTER issues ... its running fine?!
Attached Thumbnails
Click image for larger version

Name:	DIFFUSION-Orcahard_001.png
Views:	101
Size:	18.7 KB
ID:	37823  

Last edited by amilo3438; 14 November 2013 at 17:52.
amilo3438 is offline  
Old 14 November 2013, 18:30   #353
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
This could be a simple demo bug, I think it is possible to exit vector part while blitter line draw is active and demo fails to wait for blitter before it starts screen clear blit. (I am not going to test this on real hardware, too boring)

Yes, it does happen.
Toni Wilen is online now  
Old 14 November 2013, 18:55   #354
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Meeting Intro (Intro) by Disknet

A500 OCS/ECS ... if inserted after WB hand -> pic.1, otherwise it runs better but not without small issues -> pic.2 !!!

p.s. Glitches on pic.2 reminds on CPU speed issue, but its different as disabling cycle-exact nothing changed, so un-checking CE didnt help?!

EDIT: Does it behave same on a real A500?! (hope this one doesnt look boring)

p.s. It behaves same but it doesnt look such bad in WinUAE 2.0.1!
Attached Thumbnails
Click image for larger version

Name:	Disknet-MeetingIntro_001.png
Views:	106
Size:	12.6 KB
ID:	37824   Click image for larger version

Name:	Disknet-MeetingIntro_004.png
Views:	104
Size:	12.2 KB
ID:	37825  

Last edited by amilo3438; 15 November 2013 at 22:56.
amilo3438 is offline  
Old 15 November 2013, 18:46   #355
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Jas' First Real Demo (Demo) by Empire

27-296 [1160 123-150]: BLITTER: channel mode changed while active (00->09) PC=000304ca
27-296 [1160 124-150]: BLITTER: D-channel without nothing to do?
27-328 [1162 075-151]: BLITTER: channel mode changed while active (00->09) PC=000302e0
27-328 [1162 076-151]: BLITTER: D-channel without nothing to do?


Full Of Enjoyment (Demo) by Endless Piracy

Small dashes (not dots) over copper bars (pic.1,2) ?!
(also lot of "BLITTER: channel mode changed while active" issues found inside of winuaelog file, but not at the moment of mentioned issue)
Attached Thumbnails
Click image for larger version

Name:	EP-Enjoyment_001.png
Views:	103
Size:	8.4 KB
ID:	37841   Click image for larger version

Name:	EP-Enjoyment_002.png
Views:	107
Size:	9.3 KB
ID:	37842  

Last edited by amilo3438; 15 November 2013 at 20:21.
amilo3438 is offline  
Old 15 November 2013, 22:32   #356
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
TV Demo (Demo) by Energy

When demo starts there is some glitches on rotating balls logo (pic.1,2) for a few seconds ?!

EDIT: Note: It doesnt happens on WinUAE 2.0.1 ... at least it doesnt look such bad.


The Energy Copydisk Intro (Intro) by Energy

Some glitches on pic.3 and pic.4 ?! ... Does it happens also on a real Amiga ?!


Transfusion (Demo) by Extacy

Something glitches on pic.5 ?! ... Does it happens also on a real Amiga ?!
Attached Thumbnails
Click image for larger version

Name:	Energy-TVIntro_001.png
Views:	86
Size:	6.3 KB
ID:	37845   Click image for larger version

Name:	Energy-TVIntro_002.png
Views:	89
Size:	8.4 KB
ID:	37846   Click image for larger version

Name:	Energy-Intro1991_003.png
Views:	85
Size:	8.4 KB
ID:	37851   Click image for larger version

Name:	Energy-Intro1991_004.png
Views:	90
Size:	7.0 KB
ID:	37852   Click image for larger version

Name:	Extacy_001.png
Views:	88
Size:	8.1 KB
ID:	37856  


Last edited by amilo3438; 16 November 2013 at 17:02.
amilo3438 is offline  
Old 16 November 2013, 17:37   #357
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Sine Intro V1.0 (Intro) by Excel

Some crackling in sound that last sec. or two on the start of the scroller ?!
(It doesnt happens if CE=OFF !!!)

EDIT: It seems this starts happen in 2.7.0 Beta 8 !!!

Last edited by amilo3438; 16 November 2013 at 23:44.
amilo3438 is offline  
Old 16 November 2013, 18:02   #358
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
No glitches on A500. Code is horribly unoptimized, there is no need to save and load all values to/from memory, 68000 has lots of registers..

Quote:
Originally Posted by amilo3438 View Post
TV Demo (Demo) by Energy

When demo starts there is some glitches on rotating balls logo (pic.1,2) for a few seconds ?!
A500 confirmed.

Quote:
The Energy Copydisk Intro (Intro) by Energy

Some glitches on pic.3 and pic.4 ?! ... Does it happens also on a real Amiga ?!
Yes

Quote:
Transfusion (Demo) by Extacy

Something glitches on pic.5 ?! ... Does it happens also on a real Amiga ?!
And yes. It is practically invisible on any normal TV.
Toni Wilen is online now  
Old 16 November 2013, 19:15   #359
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Quote:
Originally Posted by Toni Wilen View Post
No glitches on A500. Code is horribly unoptimized, there is no need to save and load all values to/from memory, 68000 has lots of registers..
Well, in my opinion, code is optimized or not = who cares.

Only what is important should be = "Does it happens on a real A500." ... right ?!

p.s. There is no excuse for "bad emulation"!

EDIT: Regarding the "bad emulation" ... it was a joke.
The current emulation is indeed not bad at all ...
Then its quite opposite, every day it becomes better and better = it becomes now very hard to find any new problem ...
So that each new problem has no need to be considered irrelevant = it could be of use to improve/optimize the emulation even a bit more if possible.

Last edited by amilo3438; 16 November 2013 at 20:17.
amilo3438 is offline  
Old 16 November 2013, 23:28   #360
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Party Demo by Ghostriders

Broken in 2.5.1 or previous (pic.1)!!! ... confirmed to work fine on 2.4.1.

p.s. Hope this one will also be not forgotten -> http://eab.abime.net/showpost.php?p=...&postcount=355


EDIT: JFI - And this one, as it looks, doesnt work in OCS/ECS but also stop to work in AGA after 2.7.0 Beta8 version:

Believe (Intro) by Gods -> http://janeway.exotica.org.uk/release.php?id=29581
Attached Thumbnails
Click image for larger version

Name:	Ghostriders-PartyDemo_001.png
Views:	94
Size:	6.8 KB
ID:	37864  

Last edited by amilo3438; 17 November 2013 at 00:47.
amilo3438 is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problematic GVP A530 Turbo Mogsy support.Hardware 22 13 November 2012 19:12
Problematic thread? prowler project.EAB 5 28 October 2011 00:06
Problematic Holiday Lemmings 94 demo disk MethodGit support.Games 19 08 November 2010 03:56
Problematic slaves list keropi project.Killergorilla's WHD packs 44 28 November 2008 12:46
Looking for two demos... eternalcrusader request.Demos 3 01 August 2006 08:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:28.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.36758 seconds with 12 queries