English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 20 October 2013, 22:45   #221
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
After six weeks of intensive WinUAE demo/intro problem searching now begin to feel a little exhausted, so maybe its time to slow down or take a break for one week or so, we'll see ... and continue maybe after 2.7.0 release.

In a mean time, of course and after, all others are also welcome here to post their demo/intro problem findings ... I will check it periodically and update the 1st page accordingly.
amilo3438 is offline  
AdSense AdSense  
Old 21 October 2013, 01:34   #222
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Digital Innovation (Trackmo) by Anarchy

A500 OCS 0.5mb+0.5mb ... weird behaving on lower 1/3 of screen?! (pic.1,2,3)

p.s. It looks to work fine in 2.6.1 (pic.4).
Attached Thumbnails
Click image for larger version

Name:	ANARCHY-DigitalInnovation_001.png
Views:	103
Size:	7.0 KB
ID:	37335   Click image for larger version

Name:	ANARCHY-DigitalInnovation_002.png
Views:	91
Size:	7.0 KB
ID:	37336   Click image for larger version

Name:	ANARCHY-DigitalInnovation_003.png
Views:	87
Size:	7.6 KB
ID:	37337   Click image for larger version

Name:	ANARCHY-DigitalInnovation_005.png
Views:	99
Size:	6.8 KB
ID:	37338  

Last edited by amilo3438; 21 October 2013 at 01:46.
amilo3438 is offline  
Old 21 October 2013, 13:24   #223
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Delirium (Demo) by Complex

Missing lower line?! Does it happens also on a real A500?
Attached Thumbnails
Click image for larger version

Name:	complex-delirium_001.png
Views:	130
Size:	81.2 KB
ID:	37340  
amilo3438 is offline  
Old 21 October 2013, 16:12   #224
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
Delirium (Demo) by Complex

Missing lower line?! Does it happens also on a real A500?
Yes.

Quote:
Originally Posted by amilo3438 View Post
Experimental test code remaining in b9. Fixed.


Quote:
Originally Posted by amilo3438 View Post
80 character mode required.

Quote:
Originally Posted by heavy View Post
about "Shed Tears"/Ozone. a slideshow in interlaced mode with scrolltext on pictures :
http://janeway.exotica.org.uk/release.php?id=5351

screenshot in 2007 :


since "remove interlace artifacts", the scroll is half good if enabled and not so good if disabled (issue depend of the demo and way used to display interlaced...)
This can't be fixed (without having real interlaced display). "remove interlace artifacts" can only work if internal bitplane contains both fields and both fields are updated at the same time (it is handled as progressive internally) and only display output is interlaced. (like WB screen)

Demos can have all kinds of copper and other tricks, usually visible display is totally different than it looks like in memory..
Toni Wilen is online now  
Old 21 October 2013, 23:57   #225
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
JFI ... After verifying todays WinUAE test version 2013-10-21 ...
all known demo/intro problems that has been fixed in latest beta versions (1st page - Already "Fixed" Demos) confirmed to work fine in this version.

EDIT: It could be maybe good candidate for 2.7.0 (in case that some new "fix" did not broke something else by accident ) !!!

Last edited by amilo3438; 22 October 2013 at 16:03.
amilo3438 is offline  
Old 22 October 2013, 13:38   #226
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Alpha and Omega (Demo) by Pure Metal Coders

Some glitches on lower screen part?! Does it happens also on a real A500?

EDIT: Probably not so important, but it works fine in WinUAE2010 (2009-12-23) version! (@heavy - thanks for info!)
Attached Thumbnails
Click image for larger version

Name:	PmcAO_002.png
Views:	103
Size:	2.6 KB
ID:	37363   Click image for larger version

Name:	PmcAO_005.png
Views:	105
Size:	25.7 KB
ID:	37364  

Last edited by amilo3438; 22 October 2013 at 14:11.
amilo3438 is offline  
Old 22 October 2013, 13:45   #227
heavy
Registered User
 
Join Date: Jun 2007
Location: europe
Posts: 169
Quote:
Originally Posted by amilo3438 View Post
Alpha and Omega (Demo) by Pure Metal Coders

Some glitches on lower screen part?! Does it happens also on a real A500?
no

works with an old winuae version
heavy is offline  
Old 22 October 2013, 16:41   #228
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by amilo3438 View Post
Alpha and Omega (Demo) by Pure Metal Coders

Some glitches on lower screen part?! Does it happens also on a real A500?

EDIT: Probably not so important, but it works fine in WinUAE2010 (2009-12-23) version! (@heavy - thanks for info!)
"MoreNewStuffy / PlasmaForce" update was not completely correct.

Writing to BPLxPTL when same bitplane is fetched in next cycle works differently if it is cycle that adds modulos vs normal non-modulo cycle. (MoreNewStuffy was non-modulo case, this one is modulo case)

Fixed.

Quote:
works with an old winuae version
Never say something like that here! Only acceptable way: Same image (CRC confirmed) does work with vx.y/it broke in vz.zz.
Toni Wilen is online now  
Old 22 October 2013, 17:01   #229
heavy
Registered User
 
Join Date: Jun 2007
Location: europe
Posts: 169
Quote:
Originally Posted by Toni Wilen View Post
Never say something like that here! Only acceptable way: Same image (CRC confirmed) does work with vx.y/it broke in vz.zz.
eh stay calm

I used winuae since version 0.8, with same images (my own tested on A500)
I only say that the last time I tested AlphaOmega with my image, there are no glitchs. no more.
I can't remember the version exactly : 2.0.1 seems good
the CRC of my version of AO : B12426BA
heavy is offline  
Old 22 October 2013, 17:15   #230
heavy
Registered User
 
Join Date: Jun 2007
Location: europe
Posts: 169
same thing about "Deformations/Deform"
http://janeway.exotica.org.uk/release.php?id=8393

the end part corrupted sound if due to a bad dump (tested on real A500), but also if no clean start and cycle exact enabled with a good dump.
CRC of my version (different of exotica) : 88E02B3A

good version of Trashcan/Wizzcat (start logo and end part) adf : CRC 34880480
a good dump of Hardwired (2 adfs) : disc1 F8B9D6BA - disc2 BF608522
a good one of Ecliptica/trsi adf : BF7550DE
a good one of Masterpieces/kefrens adf : 3D430A60

Last edited by heavy; 22 October 2013 at 17:55.
heavy is offline  
Old 22 October 2013, 17:30   #231
heavy
Registered User
 
Join Date: Jun 2007
Location: europe
Posts: 169
about Silkcut, with the final version
http://janeway.exotica.org.uk/release.php?id=12313

so, yes the last time I started it with 68040/2 Mb chip, 8 Mb fast, 32 Mb zfast config, that was in 2006
I retested it with last versions (2.5.1, 2.6.1,2.7 b6,7,8,9) and I got a "out of memory - can't allocate 10244 bytes" at the end of the "mountains" part, even with more than 32 mb.
wrong config or ?
Attached Thumbnails
Click image for larger version

Name:	Image2.png
Views:	85
Size:	2.5 KB
ID:	37367  
heavy is offline  
Old 22 October 2013, 17:46   #232
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by heavy View Post
about Silkcut, with the final version
http://janeway.exotica.org.uk/release.php?id=12313

so, yes the last time I started it with 68040/2 Mb chip, 8 Mb fast, 32 Mb zfast config, that was in 2006
I retested it with last versions (2.5.1, 2.6.1,2.7 b6,7,8,9) and I got a "out of memory - can't allocate 10244 bytes" at the end of the "mountains" part, even with more than 32 mb.
wrong config or ?
It is bug in demo, something corrupts memory somewhere if timing is not what demo expects (or something like that), I don't really about newer demos, 2000+ or so. (EDIT: I mean new demos that are not for basic unexpended Amigas)

Last edited by Toni Wilen; 22 October 2013 at 17:58.
Toni Wilen is online now  
Old 22 October 2013, 19:43   #233
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Quote:
Originally Posted by heavy View Post
same thing about "Deformations/Deform"
http://janeway.exotica.org.uk/release.php?id=8393

the end part corrupted sound if due to a bad dump (tested on real A500), but also if no clean start and cycle exact enabled with a good dump.
This demo has buggy trackloader. If it finds sector header at the end of track buffer (sector contents ends early), it detects checksum error correctly but then it sets disk side selection to zero and retries.. So if this error happens on side 1, it retries from wrong disk side..

This can happen on real hardware too, depending on rotation speed of drive that was used for writing and reading because trackread buffer is too small.
Toni Wilen is online now  
Old 22 October 2013, 22:40   #234
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Quote:
Originally Posted by heavy View Post
about Silkcut, with the final version
http://janeway.exotica.org.uk/release.php?id=12313
Please no AGA demos here! ... this thread is only for OCS/ECS Amiga demos/intros/etc. WinUAE problems!

To collect AGA demos problems is better then to open a new thread ... and this will probably get more in focus in future when it will got status "I care".
amilo3438 is offline  
Old 22 October 2013, 22:43   #235
heavy
Registered User
 
Join Date: Jun 2007
Location: europe
Posts: 169
oh! keep calm !!!

it's just some demos tests, not a question of life or death

heavy is offline  
Old 22 October 2013, 22:53   #236
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Quote:
Originally Posted by heavy View Post
oh! keep calm !!!

it's just some demos tests, not a question of life or death

Of course its not.

But for AGA, please open a new thread titled f.e. "Problematic AGA Demos" or similar if you have some more about! Thanks.
amilo3438 is offline  
Old 22 October 2013, 23:33   #237
heavy
Registered User
 
Join Date: Jun 2007
Location: europe
Posts: 169
Floppy disk

no more aga, just a question :
I read somewhere something about Twisted/Polka Brothers , but I can't find the thread ?
2 bugs in first part are fixed with whdload patch, but there is another one : the tunnel in the second part. seems to be a bad dump disks (3 adfs versions tested), but the bug is always here with the HD version.


About Deformations/Deform, try this adf version (the end part corrupted digit) :
if that works, that was only 3 bytes to fix (or 2 lines to swap) on the trackloader (checksum error flag)
edit : i also fixed the boot

(some years ago, I fixed Rampage/TEK crash... but no more needed since version 1.6.2 )
Attached Files
File Type: zip Deform_Deformations_fix.zip (746.1 KB, 47 views)

Last edited by heavy; 23 October 2013 at 19:20.
heavy is offline  
Old 23 October 2013, 00:00   #238
amilo3438
Amiga 500 User
 
Join Date: Jun 2013
Location: EU
Posts: 1,114
Quote:
Originally Posted by heavy View Post
no more aga, just a question :
I read somewhere something about Twisted/Polka Brothers , but I can't find the thread ?
"no more aga, just a question" ... very, very funny!

Btw. you will find it on "support.WinUAE" thread on page 3!
amilo3438 is offline  
Old 23 October 2013, 00:03   #239
heavy
Registered User
 
Join Date: Jun 2007
Location: europe
Posts: 169
ah! thanks
heavy is offline  
Old 23 October 2013, 08:02   #240
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,517
Don't bother with AGA demos, you won't get reply from me. Usual reasons. (EDIT: and currently it is really pointless idea, until 68020 stuff stabilizes, if ever)

Last edited by Toni Wilen; 23 October 2013 at 08:07.
Toni Wilen is online now  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problematic GVP A530 Turbo Mogsy support.Hardware 22 13 November 2012 19:12
Problematic thread? prowler project.EAB 5 28 October 2011 00:06
Problematic Holiday Lemmings 94 demo disk MethodGit support.Games 19 08 November 2010 03:56
Problematic slaves list keropi project.Killergorilla's WHD packs 44 28 November 2008 12:46
Looking for two demos... eternalcrusader request.Demos 3 01 August 2006 08:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:28.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.24061 seconds with 12 queries