English Amiga Board


Go Back   English Amiga Board > News

 
 
Thread Tools
Old 31 May 2013, 23:57   #1
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 475
Post NetSurf for AGA

NetSurf 3.0 (web browser) ported to AGA 68k BETA 1.

Requriements:
- An AGA Amiga
- Amiga OS 3
- very fast CPU with FPU
- AFA_OS truetype rendering engine
- patience

Archive contains all needed files with installes script.

Available in The Zone! or ami-soft.blogspot.com

Posted this with NetSurf.

Please note:

This is first release so it is slow and not fully optimised.
Page layout may be wrong on some sites because scale option is set to 70 to show more on 640x480 screen.
Also font size can be changed in options file aswell if it is not readable on your monitor.
Animated and background images are disabled by default.

Big thanks to NovaCoder for SDL_AGA

Last edited by arti; 01 June 2013 at 00:25.
arti is offline  
AdSense AdSense  
Old 01 June 2013, 00:48   #2
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,667
Send a message via Skype™ to Retrofan
That's great

Do you think you'll be able to make it run without Ixemul?
Retrofan is offline  
Old 01 June 2013, 00:49   #3
attila06
Zone Friend
 
Join Date: Oct 2006
Location: Nice / France
Posts: 176
Uploaded NetsurfAGA BETA 1
[ Show youtube player ]


Sorry for the quality, I will upload another one tomorrow if i have time...

(I haven't AFA OS installed, but minimum requirements is a graphic card , i'm wrong ?)
attila06 is offline  
Old 01 June 2013, 01:10   #4
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 475
Wow, your're fast. Nice video.

I didn't know that fonts would work without AFA_OS!
arti is offline  
Old 01 June 2013, 01:11   #5
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 475
Quote:
Originally Posted by Retrofan View Post
That's great

Do you think you'll be able to make it run without Ixemul?
Maybe...
arti is offline  
Old 01 June 2013, 01:18   #6
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,667
Send a message via Skype™ to Retrofan
Wow Arti, I've just tried it on WinUAE (060 emulated) and you've done a lot of work since the last beta, it goes much faster and I like the fast link to EAB too. Still it's a bit difficult to delete and so when writting something.
Retrofan is offline  
Old 01 June 2013, 01:39   #7
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 475
I have almost working delete key.
arti is offline  
Old 01 June 2013, 01:44   #8
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,667
Send a message via Skype™ to Retrofan
I forgot to say that it looks amazing using 16 colors too (I had to recheck I was using them... perhaps it uses more ?)

(I can't post a photo because "Impr Pant" on my Pc now doesn't take but a black screen)

Edit: BTW Attila06 I think you should get Roadshow; it's faster than Miami.

Last edited by Retrofan; 01 June 2013 at 03:49.
Retrofan is offline  
Old 01 June 2013, 01:47   #9
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,444
Great job Arti

I'll send you the latest version of my library today
NovaCoder is offline  
Old 01 June 2013, 05:11   #10
bbond007
Registered User
 
Join Date: Sep 2011
Location: MIAMI/USA
Posts: 69
Cool

Cool! this one seems to be working on my computer ...

Good work!

I'm using my A1200 060 with 80mMB RAM to post this.

I'm aalso playing a MIDI file on my sc88pro

Let me hit post and see if this works.

My fonts are doing some strange stuff but maybe I don't have AFA_OS truetype...
bbond007 is offline  
Old 01 June 2013, 05:31   #11
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,444
Quote:
Originally Posted by Retrofan View Post
I forgot to say that it looks amazing using 16 colors too (I had to recheck I was using them... perhaps it uses more ?)

(I can't post a photo because "Impr Pant" on my Pc now doesn't take but a black screen)

Edit: BTW Attila06 I think you should get Roadshow; it's faster than Miami.
No it uses 256 colors and it's looking good
NovaCoder is offline  
Old 01 June 2013, 06:44   #12
bbond007
Registered User
 
Join Date: Sep 2011
Location: MIAMI/USA
Posts: 69
Quote:
Originally Posted by NovaCoder View Post
No it uses 256 colors and it's looking good
Do you think it would be possible to run in HGFX mode even by reducing the colors to 64 or something?

it really does seem to work pretty well I went to several sites with my midi playing in the background and everything kept going...

the biggest thing is sometimes the text seems to disappear. I did run the installer for AFA which I know nothing about. So I need to do some reading...

thanks!
bbond007 is offline  
Old 01 June 2013, 07:58   #13
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,444
Wouldn't true type fonts hurt performance?
NovaCoder is offline  
Old 01 June 2013, 09:14   #14
arti
Registered User

 
Join Date: Jul 2008
Location: Poland
Posts: 475
Yes, but I couldn't get internal fonts work so far.
Need to investigate more.
arti is offline  
Old 01 June 2013, 12:08   #15
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,667
Send a message via Skype™ to Retrofan
Quote:
Originally Posted by NovaCoder View Post
No it uses 256 colors and it's looking good
That's great if someday it doesn't need Ixemul, as my AmiKit conversion doesn't have memory problems when using 256 colors (I could use my ACA30/56, AmiKit and NetSurfAGA), also using as it does an smaller screen it surely uses few memory.
Actually I'm using NetSurfAGA with my AmiKit conversion adding FPU on WinUAE.
Retrofan is offline  
Old 01 June 2013, 13:50   #16
attila06
Zone Friend
 
Join Date: Oct 2006
Location: Nice / France
Posts: 176
You are right Retrofan, i should try it with Roadshow to increase speed.
attila06 is offline  
Old 01 June 2013, 17:17   #17
fishyfish
Banned
 
Join Date: Jul 2010
Location: Australia
Posts: 475
Good stuff.

Just for the record, true type fonts dont require AFA_OS (they've existed on os3.x a long time before AFA_OS).
fishyfish is offline  
Old 01 June 2013, 20:14   #18
attila06
Zone Friend
 
Join Date: Oct 2006
Location: Nice / France
Posts: 176
Very strange i thought that Roadshow was faster, but that's not true.

Tested both Miami and Roadshow (Twice) with the same sites results are here (time to display the site):


Miami / Roadshow

Eab : 62 sec / 72,6 sec
Amiga.org : 44 sec / 51,2 sec
Amigaworld : 36,6 sec / 43,9 sec

Tested with my 3c589 on my 1260 60Mhz, 64Mo.

Someone can confirm ?
I will do other Tests, i have a doubt......

Last edited by attila06; 01 June 2013 at 21:43.
attila06 is offline  
Old 02 June 2013, 00:57   #19
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,667
Send a message via Skype™ to Retrofan
I've only heard about AmiTCP being faster; that using X-Surf with the new drivers of Jens:

Quote:
Originally Posted by Schoenfeld View Post
Users on a1k.org have reported a speedup with AmiTCP that Roadshow can't keep up with (over 42% speedup).

This new device has an optimized transfer routine, but I did not expect it to be *that* much more efficient. Since I don't have a test-setup here, please do some load tests and report how fast and how reliable you can go with V1.4.

thanks,
Jens
BTW people were talking about problems installing NetSurf, and now I've had them. Something about it can't find a drawer. Also:
Quote:
Originally Posted by bbond007 View Post
I think finally tracked down all of the files needed to run this thing, or not...

I get SDL : no available video device...

What am i doing wrong?

Thanks
It seems it tries to find Env in Sys:, to copy the video files, and you are surely using Env-Archive, so just copy those files there from the installer. Dunno why I didn't have those problems first or perhaps I was using another installer. Anyway, I had those files already there in my AmiKit conversion.

Last edited by Retrofan; 02 June 2013 at 02:57.
Retrofan is offline  
Old 02 June 2013, 01:17   #20
Cymru
Registered User
 
Join Date: Sep 2012
Location: Dorathea/AT
Posts: 371
NetSurf for AGA

Quote:
Originally Posted by attila06 View Post
Very strange i thought that Roadshow was faster, but that's not true.

Tested both Miami and Roadshow (Twice) with the same sites results are here (time to display the site):


Miami / Roadshow

Eab : 62 sec / 72,6 sec
Amiga.org : 44 sec / 51,2 sec
Amigaworld : 36,6 sec / 43,9 sec

Tested with my 3c589 on my 1260 60Mhz, 64Mo.

Someone can confirm ?
I will do other Tests, i have a doubt......
Are you saying you measured the time to access the websites (using the two different stacks) from the time you clicked on the URL until it loaded? Or did you use some test of an averaged speed (let's say a set download or averaged complex communication)? Even a simple ping crosses a dozen nodes there are back and gives just a snapshot figure.
Cymru is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
NetSurf works on the raspberry pi mcbone Amiga scene 2 08 July 2013 06:17
Netsurf 2.8 released for OS4 utri007 News 0 23 September 2011 22:07
netsurf and owb turrican3 support.Apps 7 07 May 2011 15:37
Netsurf 68k utri007 Coders. General 0 09 March 2011 12:30
problems w/ 68k netsurf, dosbox, and sdl watertonian support.Other 1 04 July 2009 21:01

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:29.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.23399 seconds with 12 queries