English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > New to Emulation or Amiga scene > Member Introductions

 
 
Thread Tools
Old 05 February 2013, 18:00   #1
RichyV
 
Posts: n/a
Hi all...

Hi everyone,

glad to be here.

Here's a quick(ish) rundown on my Amiga experience:

Bought new A500 back in 1988. Variously upgraded it over time and ended up with what was, in affect, a 500+ with external 20mb harddisk & 28MHz accelerator.
Took this to uni with me in '93.
[regular reader of: Amiga Format, Amiga Computing, Amiga INternational and The One]
Sold it all off to afford a CD32 with SX-1 in '95 (wooooo, AGA! )
Unfortunately due to necessity of Windows software etc., this only lasted a year or so...

Anyway, fast forward to 2005 and, having been using Cloanto's Amiga Forever (which I still upgrade every year), I managed to get hold of a decently priced A4000D.
Started adding cards to it:- Accelerator, GFX, sound etc. But the motherboard (which was slightly corroded due to earlier battery leakage) gave up on me and, to this day still will not boot past a Yellow or Green screen).
Sold my add-in cards to fund an A1200 towered project, which I still have and it works fine, with accelerator, Mediator, Flicker-fixer etc.
But somehow this isn't really making me as happy as it should - I need my A4000 to live again!
So, I decided to join you in the hope that I can get hold of a working motherboard and be part of a lively Amiga Scene once more....
 
AdSense AdSense  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:09.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.08506 seconds with 10 queries