English Amiga Board


Go Back   English Amiga Board > Coders > Coders. System

 
 
Thread Tools
Old 15 November 2012, 18:34   #21
apex
Registered User
 
Join Date: Apr 2010
Location: Amigaplanet
Posts: 355
I am still using workbench.library 45.131, I think I have to update.
apex is offline  
AdSense AdSense  
Old 19 November 2012, 11:00   #22
apex
Registered User
 
Join Date: Apr 2010
Location: Amigaplanet
Posts: 355
Some days ago I updated the lib and everything is running fine till yet.
apex is offline  
Old 22 November 2012, 16:54   #23
Bamiga2002
BlizzardPPC'less

Bamiga2002's Avatar
 
Join Date: May 2004
Location: Finland
Age: 40
Posts: 3,210
Send a message via MSN to Bamiga2002
Any luck removing the "afadaba..." -requester from appearing?
Bamiga2002 is offline  
Old 22 November 2012, 17:49   #24
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,973
Yes, this strange requester won't appear anymore. That's fixed as far as it concerns the requester. Nevertheless, if you drag & drop a "disk.info" into the root dir of a drive for at least 3 times then there are still Enforcer hits coming up. But usually there's no good reason to do this 3 times and it's too difficult to track down the bug in the workbench.library.
PeterK is offline  
Old 28 November 2012, 01:21   #25
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,450
Hiya Peter,

Any news on this interesting project, are you going to carry on working on this?
NovaCoder is offline  
Old 28 November 2012, 01:30   #26
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,973
Sorry, but I've no intentions to maintain wblib atm.
http://eab.abime.net/showthread.php?p=838685#post838685
PeterK is offline  
Old 28 November 2012, 01:38   #27
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,819
Jeje... but now you can't do anything else for icon.library... it's so perfect...
Retrofan is online now  
Old 28 November 2012, 01:39   #28
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,973
Read the ToDo list of icon.library It's never perfect and finished.

The workbench.library patch 45.132 was made by me only to support OS 3.0.

Last edited by PeterK; 28 November 2012 at 01:54.
PeterK is offline  
Old 23 October 2015, 23:21   #29
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,053
Thread revival!

Any chance of bringing 68000 compatibility back in workbench.library 45.13x? 45.127 works well, but there seem to be at least some desirable fixes since then, or? I want to build an alternative prefs program to use on 68000 systems, but I was never a programmer and between work, beer, sleep and ... there is only limited time and energy
kolla is offline  
Old 24 October 2015, 00:02   #30
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,973
Hmm, sorry, but I really don't have a good mind to rewrite and recompile workbench.library. Not for the 68000, nor for the 68020+ !!

Indeed v45.127 was the last 68000 compatible WB. V45.128 - v45.131 have been written by Mikolaj Calusinski. But it seems that he has simply disassembled v45.127 and then patched and optimized it here and there before reassembling it for the 68020. He has probably never tried to get the disassembler sources first in such a way that you can reassemble the code to get a 100 % identical executable compared to the original v45.127.

So, I would have to start with v45.127 again and need to reimplement all of Mike's bugfixes. That job really makes no fun.

But who knows, maybe one day I will feel soooo much bored that I start doing unexpected things. Better don't wait for that day.
PeterK is offline  
Old 24 October 2015, 04:19   #31
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,053
Oh I see, so this has nothing to do with original spirces, whatever happened to them...
kolla is offline  
Old 24 October 2015, 05:22   #32
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,973
No, the only one who has the original sources of the icon.library and the workbench.library is their author Olaf Barthel (Olsen). But he once said in an interview many years ago that he would never like to touch these libraries again. Mikolaj Calusinski probably never had access to the original source code, same as me, too.
PeterK is offline  
Old 24 October 2015, 11:36   #33
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,053
Ah yes, now that you mention it, I remember reading that too. Anyways, what you have done with icon.library is pretty amazing
kolla is offline  
Old 24 October 2015, 15:50   #34
HanSolo
Registered User

 
Join Date: Aug 2014
Location: Gdynia/Poland
Posts: 155
Did somebody have workbench.library 45.135 by Cosmo to share ???
HanSolo is offline  
Old 24 October 2015, 16:23   #35
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,973
Send me an email, plz. (no PM)
PeterK is offline  
Old 04 November 2015, 22:30   #36
apex
Registered User
 
Join Date: Apr 2010
Location: Amigaplanet
Posts: 355
Quote:
Originally Posted by HanSolo View Post
Did somebody have workbench.library 45.135 by Cosmo to share ???
What did Cosmo change?!?
apex is offline  
Old 04 November 2015, 22:52   #37
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,973
Version 45.134 was his last stable workbench.library. I'm using it for more than a year now without any problems. But v45.135 wasn't a successfull attempt of Cosmos yet. And I don't spread broken libs!

Since he is also is a member at A1k.org you should have a good chance to ask him for further details. Btw, Cosmos and not Cosmo, please. (Look for cosmosamiga, apex) Thanks!

Last edited by PeterK; 04 November 2015 at 23:43.
PeterK is offline  
Old 17 October 2017, 13:32   #38
bladecgn
Registered User

 
Join Date: Nov 2013
Location: Essen / Germany
Posts: 122
Quote:
Originally Posted by clauddio View Post
I know it is possible because I have OS3.9 installed on my A1200+ kickstart 3.0 since long time ago....and it works like a charm
supposedly I always assumed that the malicious check for V40 libraries are inside the workbench.library

here is the beginning of my startup-sequence


run >nil: patchlibrary expansion.library 40
run >nil: patchlibrary exec.library 40
run >nil: patchlibrary utility.library 40
run >nil: patchlibrary graphics.library 40
run >nil: patchlibrary layers.library 40
run >nil: patchlibrary keymap.library 40
run >nil: patchlibrary intuition.library 40
run >nil: patchlibrary dos.library 40
run >nil: patchlibrary gadtools.library 40
Has anyone got it working as Claudio recommended? Could you show your full s-s? I would like to see how you made it to run 3.9 on 3.0.

Last edited by bladecgn; 17 October 2017 at 13:42.
bladecgn is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot open "workbench.library" amigatv project.ClassicWB 8 17 April 2012 12:57
Patch for Workbench version requester Leandro Jardim request.Apps 8 19 November 2011 20:41
three in one? (SCSI Patch,Mac Patch,MapRom) RogerWilco09 support.Apps 0 05 May 2009 16:56
looking for Amigaguide.library v44.5 patch voxel request.Apps 5 03 October 2006 20:44
Making a shared library from a gcc .a library JoJo Coders. General 1 10 March 2003 19:06

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 22:03.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.08820 seconds with 13 queries