English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > New to Emulation or Amiga scene > Member Introductions

 
 
Thread Tools
Old 03 September 2012, 16:40   #1
grobda
Registered User
 
Join Date: Sep 2012
Location: glasgow
Posts: 15
Hi from Glasgow

hi all

Im a retrogamer, it started with emulation, and then getting a jamma setup to play the games i loved 'arcade perfect' as a kid. As some boards arrived or became faulty, and the prices started going up, I branched out from collecting into repairing too.

I've pretty much reached a point where I've got all the games I wanted, and the rest are crazy expensive, so for novelty value I decided to return to some of the games I loved on home systems.

One of such systems is the Amiga and I picked up a 500 recently. Of course with all hardware I love tinkering and am looking for ways to improve it (mainly disk loading times ) so my web travels brought me to this forum.

So expect a few annoying questions, but Ill use the search function 1st I promise.
grobda is offline  
AdSense AdSense  
Old 03 September 2012, 17:24   #2
Smakar
Amiga Fan in Phoenix
Smakar's Avatar
 
Join Date: Aug 2012
Location: Phoenix, AZ USA
Age: 59
Posts: 60
Welcome, grobda. I too am new to this forum, and like yourself have returned to an older gaming platform, but one that was (and still is) a favorite, the Amiga 500. The difference is I had my old A500 boxed up since 1993 so I didn't have to buy one (it's truly amazing that, after all this time, it booted up after only having to blow-off and re-seat the chips on the motherboard
Like yourself, I am looking at ways to beef-up my machine. I was pointed to this link, and am waiting on delivery (I have a Rev5 motherboard for which the card wasn't ready yet).
http://eab.abime.net/showthread.php?t=65155
One upgrade that I completed yesterday was replacing my 40mb SupraDrive 500XP hard drive with a 240mb SCSI drive. After having reloaded my backed-up files, I discovered I had bad sectors, so I had to perform another low-level format, this time with mapping (there were less than 100 bad sectors out of, well I can't remember but it was in the hundreds of thousands), and after 7 hours for this process (thank God I didn't have a drive with 500gb!), and then reloading again, it's running like a champ!.
My remaining upgrades that I've ordered and waiting to receive are: a) 3.1 ROM chip so I can install Workbench 3.1 (I'm on 2.05 now), b) 8mb DIMs to install on my 500XP SCSI controller, c) Clockport adapter for A500, and d) Hypercom High Speed Serial interface.
The last two of these are (hopefully) for transferring files between my PC and the A500. I currently have this working with a null-modem connected to the A500 serial port, and it works just fine except that it's SLOW (transfer speed is 19200). Speaking of, it you're not aware of it, there's a GREAT product called Amiga Explorer, which can be bought separately or as part of the Amiga Forever PC application (a truly wondrous app which is half the cost of PC games now-a-days).
Sorry for the long post but I wanted to share what I've done/will do with someone like me.
Cheers!
Smakar is offline  
Old 03 September 2012, 18:15   #3
grobda
Registered User
 
Join Date: Sep 2012
Location: glasgow
Posts: 15
Hey Smakar, good to read of your experiences. ive no idea what happened to my original amiga i think my mum took it to the rubbish dump when i was at university . Id like a hard disk but this zeus68k thing looks interesting so i might hold off for that. at the moment im using a parallel cable for transfers, bit faster than a serial (adf takes 2 mins rather than 8 ) as detailed here;- http://www.amiga.org/forums/showthread.php?t=62243 easy enoough to build a cable and you can transfer the boot disk via serial before swapping to the parallel. looking at the docs it will do file transfer as awell as adf transfer.
grobda is offline  
Old 03 September 2012, 18:43   #4
BobRedthorp
Huge member

BobRedthorp's Avatar
 
Join Date: Jun 2003
Location: Glasgow, UK
Age: 35
Posts: 304
Hi from a fellow Glaswegian, Ive owned my Amiga since back in the day but only just recently decided to get it sorted out with an Accelerator, a 4GB HDD and get WHDLoad running.

The folks here are always quick to help out any queries!
BobRedthorp is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello from Glasgow, Scotland! grs Member Introductions 9 27 October 2012 13:26

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:43.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.18601 seconds with 11 queries