English Amiga Board Amiga Lore


Go Back   English Amiga Board > Main > Amiga scene

 
 
Thread Tools
Old 17 July 2013, 16:44   #201
JimNeray
X-bEnCh addict
JimNeray's Avatar
 
Join Date: Aug 2010
Location: France
Posts: 186
Hi all.

Many thanks for your bugs reports. I've a lot of returns and many many things to check and fix before releasing a new fix for xbench.

Does anyone have the same bug as attila06 ? Wich file system do you use ?

@Turran: Your video link is broken. Sadly i think that your issue is due to your custom rom :/
JimNeray is offline  
AdSense AdSense  
Old 17 July 2013, 18:41   #202
JimNeray
X-bEnCh addict
JimNeray's Avatar
 
Join Date: Aug 2010
Location: France
Posts: 186
For all of you that can't restart xbench after a reset. Can you tell me if this file exist:
Code:
xb:temp/i.???
If yes can you give me it's content ?
JimNeray is offline  
Old 18 July 2013, 18:56   #203
JimNeray
X-bEnCh addict
JimNeray's Avatar
 
Join Date: Aug 2010
Location: France
Posts: 186
Quote:
Originally Posted by JimNeray View Post
For all of you that can't restart xbench after a reset. Can you tell me if this file exist:
Code:
xb:temp/i.???
If yes can you give me it's content ?
Additionally do you have any error message when xb doesn't start ?
JimNeray is offline  
Old 19 July 2013, 12:21   #204
Turran
Registered User

Turran's Avatar
 
Join Date: May 2012
Location: Stockholm / Sweden
Age: 42
Posts: 768
Quote:
Originally Posted by JimNeray View Post
@Turran: Your video link is broken. Sadly i think that your issue is due to your custom rom :/
Fixed
http://www.grandis.nu/images/Xbench_problem.MOV

Althought I dont think its the roms. Most likely the Apollo 4040..
Turran is offline  
Old 24 July 2013, 23:56   #205
JimNeray
X-bEnCh addict
JimNeray's Avatar
 
Join Date: Aug 2010
Location: France
Posts: 186
@Turran: Thanx for the vid. Now i've seen your problem. Really strange !! Hope you will be able to try this without the apollo a day.

I'm finishing the 0.90beta1. Hope someone with the bugs noticed upstair can send me the content of his xb:temp/i.??? file before i release the beta1.
JimNeray is offline  
Old 05 August 2013, 17:42   #206
JimNeray
X-bEnCh addict
JimNeray's Avatar
 
Join Date: Aug 2010
Location: France
Posts: 186
X-bEnCh 0.90Beta is out and available on www.jimneray.com as usual.

Here is the release txt:

Quote:
The history.txt is splited from the XB guide to light it a bit.(about20k)
A new icon is set for X-bEnCh.exe and X-bEnCh.guide.
The X-bEnCh.guide was updated but the setup part is still outdated.

Xinstaller0.6
-Fixed the textgadgets display bug.
-Internals fixs.

Xinit1.8
-Fixed an init bug if no Top15 was previously created.
-Internal fixs.

Xlaunch2.0
-Empty Top15 crash fixed.
-Top15 is no more displayed if it blank.
-If no Top15 file exist, autocreate one.
-Fixed the display lag in the checkerboard loader screen when
accessing datas. (checkerboard v0.4)
-Now the music'll not end before the display is closed in the
checkerboard loader screen. (checkerboard v0.4)

Xcli0.9
-Fixed the "topupdate" command if no Top15 exist.

Xplorer0.2
-Display refresh bug after deleting a file fixed.
JimNeray is offline  
Old 07 August 2013, 19:44   #207
subone
Registered User
subone's Avatar
 
Join Date: Jun 2005
Location: France
Age: 44
Posts: 86
That new release rocks ... as always

Thanks JimNeray.
subone is offline  
Old 09 August 2013, 12:34   #208
attila06
Zone Friend
 
Join Date: Oct 2006
Location: Nice / France
Posts: 174
Good job Jim,

No more crash on my system .

Just a little problem, when i quit X-bench i can't see my workbench screen, but a black screen and a window with the copper.
Maybe because i use Highgfx and cooper, but it worked fine with the 0.87b.

Last edited by attila06; 09 August 2013 at 19:52.
attila06 is offline  
Old 09 August 2013, 20:58   #209
JimNeray
X-bEnCh addict
JimNeray's Avatar
 
Join Date: Aug 2010
Location: France
Posts: 186
@subone & @attila06 : Thanx

Quote:
Originally Posted by attila06 View Post
Just a little problem, when i quit X-bench i can't see my workbench screen, but a black screen and a window with the copper.
Maybe because i use Highgfx and cooper, but it worked fine with the 0.87b.
Yes it's a known issue. It's because the option to show the whdload requester is not finished. It should not have been activated before completion. It is a mistake on my part that will be corrected in a future 0.9x release soon as it is finished to implement. You can simply switch off the "whdlreq" in the launcher setup to hack this issue.
JimNeray is offline  
Old 27 August 2013, 00:49   #210
JimNeray
X-bEnCh addict
JimNeray's Avatar
 
Join Date: Aug 2010
Location: France
Posts: 186
X-bEnCh download server is down. It'll be back as soon as possible.
JimNeray is offline  
Old 02 September 2013, 23:44   #211
JimNeray
X-bEnCh addict
JimNeray's Avatar
 
Join Date: Aug 2010
Location: France
Posts: 186
The download link is fixed !
JimNeray is offline  
Old 03 September 2013, 11:32   #212
mcbone
Registered User
 
Join Date: May 2013
Location: nottingham uk
Posts: 93
Quote:
Originally Posted by JimNeray View Post
You can see a video of the setup and basic usage of the old release here: [ Show youtube player ]
better but world be better if you talk as you was slow it
mcbone is offline  
Old 03 September 2013, 14:16   #213
JimNeray
X-bEnCh addict
JimNeray's Avatar
 
Join Date: Aug 2010
Location: France
Posts: 186
Quote:
Originally Posted by mcbone View Post
better but world be better if you talk as you was slow it
I 'm sorry but I 'm not sure to understand what you mean ?
JimNeray is offline  
Old 03 September 2013, 14:39   #214
roy bates
Registered User
 
Join Date: Apr 2011
Location: birmingham
Age: 48
Posts: 2,797
Quote:
Originally Posted by JimNeray View Post
I 'm sorry but I 'm not sure to understand what you mean ?

i think he meant," its better,but would be better still if you talked people through the video as it played"
roy bates is offline  
Old 03 September 2013, 22:59   #215
JimNeray
X-bEnCh addict
JimNeray's Avatar
 
Join Date: Aug 2010
Location: France
Posts: 186
Ok ! I'm sorry but i will not do that !

My english skill is too bad to talk by voice. And text is easyest to understand for non english people. But if somebody want to talk over this vid he can !

I'll do others videos soon after a future release. This one is outdated.
JimNeray is offline  
Old 15 September 2013, 09:52   #216
JimNeray
X-bEnCh addict
JimNeray's Avatar
 
Join Date: Aug 2010
Location: France
Posts: 186
X-bEnCh 0.91 Alpha is out today !

You can download it on: www.jimneray.com

The main features of this update are:
- Now with up to 272 colors on AGA (128 with OCS/ECS)
- New .mod replay routine that's now perfectly working.
- CDMode to create your own CD32/CDTV compilations.
- Enhanced display on ECS/OCS.
- New 68060 recognition routine.
- You can now setup the RTC in the setup panel.
- New shortcuts (F1-F6) to access your 6 launching lists.
- New colorful loading bar on init.
- Double redraw bug fixed in the setup.
- X-bEnCh.guide now up to date.
- ...

Please note that X-bEnCh is no more freeware. Due to the big time that i spend to dev and update it, xbench is now donationware. Note that the unregistered version is full and has no limitation except a screen that notice that xbench is not registered on startup.

Hope you'll enjoy it !

Complete release note is available in the lha archive. (Do not extract it with windows or this'll not work. Only use lha x under Amiga Os)

If you want you can follow the X-bEnCh Page on Facebook: https://www.facebook.com/xbenchproject
JimNeray is offline  
Old 15 September 2013, 10:20   #217
attila06
Zone Friend
 
Join Date: Oct 2006
Location: Nice / France
Posts: 174
Thanks for this new release.
I ll try as soon as possible.
attila06 is offline  
Old 16 September 2013, 14:05   #218
JimNeray
X-bEnCh addict
JimNeray's Avatar
 
Join Date: Aug 2010
Location: France
Posts: 186
It seem to have a bug that made Xbench (Xinit.exe) fail in some case.

I've made a special version of the xinit.exe file. You can download it here: http://www.jimneray.com/download/Xinit.exe

If Xbench init.exe fail for you, can you replace the xinit.exe file and try this one ? I've fixed two smalls mistake and added an output window that count all the steps before the black fader on the workbench screen so if this is not fixing your issue, this will let us know where is the last working step and where this is going wrong.

Waiting for your returns

JimNeray is offline  
Old 16 September 2013, 17:05   #219
mfilos
Paranoid Amigoid

mfilos's Avatar
 
Join Date: Mar 2008
Location: Athens/Greece
Age: 38
Posts: 1,576
Send a message via Skype™ to mfilos
The output in my case (which has a problem) is:
XStep Output = 8

After that it continues to stop responding with an error #8000000B)
mfilos is offline  
Old 16 September 2013, 22:16   #220
JimNeray
X-bEnCh addict
JimNeray's Avatar
 
Join Date: Aug 2010
Location: France
Posts: 186
Does someone have tried this release without any problem ?
JimNeray is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
whdload games launcher Nova support.Games 5 01 May 2013 00:44
[FS-UAE] Amiga Game Database for FS-UAE Launcher nexusle support.FS-UAE 31 24 August 2012 21:24
Whdload launcher with 2 partitions for games? emuola project.ClassicWB 3 07 November 2011 22:35
New WHDLoad launcher - seconds on a standard A1200! Bloodwych project.ClassicWB 35 17 January 2008 22:29
If WinUAE cannot detect your supposedly empty HDD, look for zap.exe or wipe.exe. fmcpma support.WinUAE 5 08 August 2006 01:35

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:22.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Page generated in 0.23681 seconds with 12 queries