English Amiga Board


Go Back   English Amiga Board > Main > Amiga scene

 
 
Thread Tools
Old 23 May 2012, 01:59   #1
slaapliedje
Registered User
slaapliedje's Avatar
 
Join Date: Jul 2010
Location: Utah, USA
Posts: 134
Getting a hold of DiscreetFX?

Where to begin with my issues...

It all started because I decided I wanted to play around with a Video Toaster. Ended up ordering one from DiscreetFX when they had a bundle deal with Aladdin 4D. Ordered it, waited patiently for it to be sent to me, then realized too late that my Paypal account was still set to my parent's house. They finally received it, then delivered it to me.

That was when I had realized that I couldn't even put it in my A4000D, since I have a Mediator board in there (unless of course I wanted to swap out the whole board every time I wanted to use it). So I talked to Pyromania that works there and he said that they had an A4000D sitting around that they could part with for 300 bucks, I said that I would then half to find a flicker fixer, unless he could get a monitor, then I couldn't really justify it. So he found a monitor that he said he'd throw in for free.

So after 360 bucks (60 bucks for shipping that beast. Ouch!) I waited, and waited... it took about 7 months of us bouncing messages back and forth.

Finally I got it (after they had to fire their shipping intern 'cause he had been sitting on the package for all that time..) I received the monitor first, and it was caved in in the front. So I tried to power it on and all I got was an arcing tube. Took it to an electronics repair shop, who told me what I already knew, and said he couldn't fix it because he'd have to find an identical tube for it (35 bucks for nada).

When I received the A4000D, it had no cover on it, no keyboard, battery damage, the A3640 was loose and rattling around in the case, and there was a 3GB hard drive. It was just horrible.

So Pyromania said to send it on back, which cost me another 45 bucks, and I sent it along with the Video Toaster, he said I could keep the monitor, which does me no good since it's toast.

He state that they received it on 3-10-2012. Then let me know that it'd take 30 days to receive a refund. Well, it's now been 72 days, no refund.

I've now tried emailing support@discreetfx.com, waited a few days for a reply, I've left private messages for Pyromania here, I've sent him emails via this site, etc. I called them up today and left a voicemail.

Anyone know of any other methods for getting a hold of them? Without counting shipping and handling, they owe me about 430 bucks, which I'd like to spend on some ZorRam or something.

Arrrgggh, talk about frustrating. Haven't had this many issues with ordering something since the days of the 8-bit when we ordered Lords of Conquest and Racing Destruction Set for our Atari 800XL and about after 8 months we finally got Lords of Conquest (so long we'd forgotten we'd ordered it.) and we never did receive Racing Destruction Set (they said they were out of stock the whole time).

Hmm, maybe I should let off some steam by playing some RDS!

Please help!!

slaapliedje
slaapliedje is offline  
AdSense AdSense  
Old 23 May 2012, 03:17   #2
Akira
Registered User

Akira's Avatar
 
Join Date: May 2001
Location: New York
Posts: 18,274
It sucks that you've been having such horrible issues.
Pyromania logged in here 5 days ago. I hope you can get a hold of him.
Akira is offline  
Old 23 May 2012, 03:18   #3
slaapliedje
Registered User
slaapliedje's Avatar
 
Join Date: Jul 2010
Location: Utah, USA
Posts: 134
Yeah, I saw that he had logged into amiga.org as well, where I also posted the same message.

That's not even counting the ZorRam card that I think I installed upside down the first time around and now haven't been able to get replaced... my luck sucks.

slaapliedje
slaapliedje is offline  
Old 23 May 2012, 12:51   #4
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 39
Posts: 5,591
Send a message via MSN to FOL Send a message via Skype™ to FOL
Quote:
Originally Posted by slaapliedje View Post
That's not even counting the ZorRam card that I think I installed upside down the first time around and now haven't been able to get replaced... my luck sucks.
If the caps were on top, then it was correct.
If the caps were on bottom, then it was incorrect.
FOL is offline  
Old 23 May 2012, 20:40   #5
slaapliedje
Registered User
slaapliedje's Avatar
 
Join Date: Jul 2010
Location: Utah, USA
Posts: 134
Yeah, the initial way I put it in was wrong, because I was talking to my brother when I installed it, and sadly telling him how awesome easy it was to slap in a board and have it auto detect (although really RAM works that way anyhow.) So for whatever reason my brain saw the 'Backside' arrow, and reversed that so it was actually the front... then when I didn't come up, I read the install paper and thought 'oh shit!'

slaapliedje
slaapliedje is offline  
Old 23 May 2012, 21:31   #6
Smiley
Amiga-less!
Smiley's Avatar
 
Join Date: Feb 2005
Location: UK
Posts: 1,351
I take it you have tried calling them on: 1 (800) 259-6220
Smiley is offline  
Old 23 May 2012, 22:38   #7
slaapliedje
Registered User
slaapliedje's Avatar
 
Join Date: Jul 2010
Location: Utah, USA
Posts: 134
I opened a ticket with them and they had me try all these tests to see
if the card worked... then I got tired of it, I still have an opened
ticket, it says on the install paper that they sent with the card that
if you install it upside down, the warranty doesn't cover it.

slaapliedje
slaapliedje is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
the speed of a key hold down (Octamed) lost_lemming support.Apps 11 02 July 2012 17:53
1084s-d1 Vertical hold adjustment skforty support.Hardware 12 21 August 2009 12:51
Windows mouse -click hold- exoticaga support.Other 2 05 April 2009 18:58
I need to get hold of the APoV team mantisspider Amiga scene 4 16 December 2003 17:16
Got hold of an A4000/040, but... SilentBob support.Hardware 9 28 November 2003 16:34

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 09:13.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.12961 seconds with 11 queries