English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 22 August 2002, 15:22   #1
oldpx
 
Posts: n/a
ppc.library and WarpOS

Everytime I boot my system, WarpOS activates itself and displays a message stating that I should terminate ppc.library for WarpOS cannot work if ppc.library is enabled. I always click terminate but I wonder if there is a permanent solution to this.
 
AdSense AdSense  
Old 22 August 2002, 19:23   #2
Akira
Registered User

Akira's Avatar
 
Join Date: May 2001
Location: New York
Posts: 17,933
Some program might be starting it. Look in your startup scripts for a loadlib command being issued towards the ppc.library!

Or bruteforce it: move ppc.library to somewhere away from libs: and see what happens
Akira is offline  
Old 22 August 2002, 19:28   #3
oldpx
 
Posts: n/a
It's not in the libs, I'm afraid it's on the bios of the ppc card or something :/
 
Old 23 August 2002, 09:37   #4
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,526
On the A1200 (BlizzardPPC) the ppc.library is in the Flash ROM and is activated automaticaly during boot up.

You can either set the Env variable TERMINATOR to 2 (terminate without ask), or install BPPCFIX. You must install BPPCFIX if you want to install the ppc.library emulation (in order to run PowerUP and WarpOS programs concurrently).

Here is the link to ppclibemu and BPPCfix: http://devnull.owl.de/~frank/ppcemu.html

Also read the WarpOS documentation about ENV variables.


Edit: just saw that the page is in german. Here is the english version: http://devnull.owl.de/~frank/ppcemu_e.html

Last edited by thomas; 23 August 2002 at 09:47.
thomas is offline  
Old 23 August 2002, 10:39   #5
oldpx
 
Posts: n/a
I've chosen Terminator 2 option and it's done. I was nearly sure it was previously terminator 2 too. But the problem is solved, thank you a lot for the help.
 
Old 23 August 2002, 16:57   #6
Akira
Registered User

Akira's Avatar
 
Join Date: May 2001
Location: New York
Posts: 17,933
Further proof that I have no clue about "current" meegas
Akira is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Building WarpOS binaries on classic / 3.x mousehouse Coders. General 8 31 January 2012 16:52
SiN WarpOS/PPC Game fitzsteve request.Old Rare Games 7 03 May 2011 10:19
LHA v2.11 for WarpOS available on Aminet! keropi Amiga scene 8 16 March 2006 02:29
GCC warpos linking error? JoJo Coders. General 0 21 March 2003 00:09
Making a shared library from a gcc .a library JoJo Coders. General 1 10 March 2003 19:06

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:04.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.21021 seconds with 11 queries