English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 09 July 2011, 14:23   #1
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 2,998
AHI only playing out of one channel?

My real Amiga has a strange issue, if I set the 'Music Unit' to Paula 8 bit stereo it only plays out of the right speaker

Not sure why this is, I assume it must be a hardware fault because the same install works fine under WinUAE.

I tried upgrading AHI from V4 to V6 but that didn't help, if you set the 'Music Unit' to 8 bit stereo++ (or 8 bit mono) it works fine

What do the other units do in the prefs program, not really sure what those settings should be?

Last edited by NovaCoder; 09 July 2011 at 14:30.
NovaCoder is offline  
AdSense AdSense  
Old 09 July 2011, 14:35   #2
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 4,615
Please read the docs. What you describe is exacty the difference between stereo and stereo++.
thomas is online now  
Old 09 July 2011, 16:10   #3
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 2,998
Hiya Thomas, yes you are right but that is a bit silly.

Anyway maybe you can answer this question for me, is AHI V4 generally less CPU intensive than V6 on a 030?

Edit: V4 seems better because of the 'FAST' modes which use lookup tables.

Last edited by NovaCoder; 09 July 2011 at 16:47.
NovaCoder is offline  
Old 09 July 2011, 18:02   #4
Mad-Matt
Longplayer

Mad-Matt's Avatar
 
Join Date: Jan 2005
Location: Lincoln / UK
Age: 35
Posts: 1,517
Send a message via ICQ to Mad-Matt Send a message via MSN to Mad-Matt
v4 was the last version compiled from asm I believe adding to its beter performance.
Mad-Matt is online now  
Old 09 July 2011, 20:17   #5
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 927
To check the 4 native audio channels it is easy by using e.g. Protracker (play a sample on each track). And yes, AHI 4.180 is the fastest version.
daxb is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
new AHI pages layout and AHI-archive Bamiga2002 Amiga scene 12 20 December 2007 15:44
Playing Artkanoid without using AHI lopos2000 support.Games 1 12 October 2007 21:03
4-channel sound andreas support.WinUAE 9 30 July 2006 13:46
Playing MP3s on WinUAE using AHI andreas support.WinUAE 5 07 March 2002 16:27

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:38.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Page generated in 0.11404 seconds with 11 queries