English Amiga Board Amiga Lore

Go Back   English Amiga Board > Main > Amiga scene

Thread Tools
Old 11 March 2011, 20:46   #1
Posts: n/a
Amiga floppy drives

Hi any help would be appreciated just got my Amigas down from the loft and they now do not seem to boot anything?
One is a 500 the other is a 1200 have even tried two external drives and neither of them seem to boot either.
Took the cover of one of them and the plate thing attached to the screw thing does not seem to come forward.
Neither have been on since the 90s though!!!
Sorry for the vague description and if I have posted in the wrong place maybe time to look for a replacement?
AdSense AdSense  
Old 11 March 2011, 20:59   #2
Targ Explorer

DDNI's Avatar
Join Date: Mar 2006
Location: Northern Ireland
Age: 42
Posts: 5,070
Send a message via ICQ to DDNI Send a message via MSN to DDNI
hi welcome. As a starter for 10 check the disk sensor near the fromt of the floppy drive opening is moving freely. Also you should get yourself a floppy disk drive cleaner from Maplin.
Where were your floppies stored? They are more likely to be bad than the drive.
DDNI is offline  
Old 11 March 2011, 21:07   #3
Posts: n/a
Hi thanks for the quick reply I actually had 3 amigas in total that would not boot but one of the 500s works now however i took the cover off the drive before it would work.
The software seems fine I have checked 15 ish games and none of them boot on the other 2 machines not even workbench but they work on the other one.
Is the disk sensor the two little pins near the write protect?
Old 11 March 2011, 22:45   #4
Targ Explorer

DDNI's Avatar
Join Date: Mar 2006
Location: Northern Ireland
Age: 42
Posts: 5,070
Send a message via ICQ to DDNI Send a message via MSN to DDNI
DDNI is offline  
Old 14 March 2011, 14:05   #5
Amigan - an loving it!!
LuMan's Avatar
Join Date: Nov 2010
Location: Nottingham, UK
Age: 47
Posts: 450
Do the faulty miggys show the boot/insert disk screen? If they do, listen for the drive-click noise - I'm sure you know what to listen for . If there's no drive click then it's likely the drive itself could be faulty.

If you don't even get the boot pic it could be something more sinister. If you've not already had the tops off it may be worth opening the computers up and checking for anything obvious on the mobo, such as moisture damage, bits of metal or dust shorting tracks, loose FDD ribbon or power header connection.

If it's been a good decade or so since they've been used it's worth giving them a bit of a clean up and service.

Hope this helps.
LuMan is offline  
Old 17 March 2011, 15:40   #6
Registered User
Hewitson's Avatar
Join Date: Feb 2007
Location: Melbourne, Australia
Age: 34
Posts: 2,198
Checking the cable should be the first step. I recently moved house and, believe it or not, the floppy cables on both my PC and my A2000 had come loose. What a coincedence!
Hewitson is offline  
AdSense AdSense  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Modifying PC floppy drives for Amiga use Jope Hardware mods 320 15 June 2016 00:23
Amiga 5.25-inch floppy disks and drives mips support.Hardware 24 03 May 2013 20:40
List of Amiga compatible PC floppy drives Olecranon support.Hardware 12 05 October 2011 17:38
Amiga 1200 Virtual Floppy Drives ? douglasamcintos New to Emulation or Amiga scene 16 18 September 2007 14:20
replacing amiga floppy drives with hard drives Gordon support.Hardware 2 06 March 2007 00:44

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +2. The time now is 21:34.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Page generated in 0.14938 seconds with 11 queries