English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 13 May 2011, 16:31   #121
mfilos
Paranoid Amigoid

mfilos's Avatar
 
Join Date: Mar 2008
Location: Athens/Greece
Age: 38
Posts: 1,576
Send a message via Skype™ to mfilos
Quote:
Originally Posted by Bloodwych View Post
PNG icons in the ClassicWB packs perhaps?
PNG as they are, aren't so enjoyful when it comes to speed. Converting them via Workbench's Icon Info though to 8bit... would make them a lot smaller (in size) and quick to load (plus full of win)

For 040/060 A1200's without RTG but with the awesome ClassicWB packs of yours... it's gonna be just awesome
mfilos is offline  
AdSense AdSense  
Old 15 May 2011, 03:55   #122
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,668
Many thanks to amigakit.com and Bloodwych for praising my efforts.
But never hesitate to report any kind of problems with my library, too.

Update: http://aminet.net/package/util/libs/IconLib_46.4

Last edited by PeterK; 15 May 2011 at 08:09.
PeterK is offline  
Old 15 May 2011, 09:11   #123
mfilos
Paranoid Amigoid

mfilos's Avatar
 
Join Date: Mar 2008
Location: Athens/Greece
Age: 38
Posts: 1,576
Send a message via Skype™ to mfilos
Peter what are the changes between 46.4.208 that you uploaded here and the Aminet 46.4.209 version?
Not so important, but just for info

Also what happened with version 46.4.207? I never saw it anywhere
mfilos is offline  
Old 15 May 2011, 09:22   #124
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,668
There are just a few additional fixes for some bugs that did not even get out of their holes yet. I've never seen them and nobody reported anything concerning these bugs.

The build number 207 was internal only like many other versions, too. You did not miss anything!
PeterK is offline  
Old 15 May 2011, 19:38   #125
SpeedGeek
Registered User
SpeedGeek's Avatar
 
Join Date: Dec 2010
Location: Wisconsin USA
Age: 54
Posts: 341
mfilos requested this post be mentioned here:
http://eab.abime.net/showpost.php?p=756079&postcount=92
SpeedGeek is offline  
Old 15 May 2011, 19:56   #126
amigakit.com
Registered User

amigakit.com's Avatar
 
Join Date: Aug 2004
Location: www.amigakit.com
Posts: 1,706
@PeterK

Classic Amiga's are my passion so it is always great to see new software developments.
amigakit.com is offline  
Old 15 May 2011, 20:29   #127
James
Registered User

 
Join Date: Mar 2010
Location: Beckenham/England
Posts: 454
@PeterK

Still getting crashes on WinUAE with the latest library, but not as frequently.

Have now installed it on my A1500 - all going well so far...
James is offline  
Old 15 May 2011, 20:58   #128
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 42
Posts: 1,260
Send a message via ICQ to Foul Send a message via MSN to Foul Send a message via Skype™ to Foul
can admin could rename this topic : 32 bits icons under Workench ? Aka PeterK's IconLib Official Thread !

Thx
Foul is offline  
Old 15 May 2011, 21:09   #129
TCD
Global Moderator

TCD's Avatar
 
Join Date: Sep 2006
Location: Germany
Age: 39
Posts: 24,032
Changed
TCD is offline  
Old 15 May 2011, 21:48   #130
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 42
Posts: 1,260
Send a message via ICQ to Foul Send a message via MSN to Foul Send a message via Skype™ to Foul
Thank you
Foul is offline  
Old 16 May 2011, 16:16   #131
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,668
@Foul
Sorry, please excuse me for hijacking your thread

@James

I need some more information about your system now:
- the startup-sequence, the user-startup, the WBStartup with all icons,
- which datatype do you use, with or without pngalpha.library
- the WinUAE config, WinUAE log files
- any Alert numbers if you got some
- are you using the Workbench or DOpus ?
You can send me all this packed into an lha as an email, if you prefer that.
Thank you.

@SpeedGeek

Please, send me your Visage icon with all these tooltypes. I would like to check that.
PeterK is offline  
Old 16 May 2011, 17:57   #132
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 42
Posts: 1,260
Send a message via ICQ to Foul Send a message via MSN to Foul Send a message via Skype™ to Foul
it's not a problem at all.

If we can help any Amiga users .. i'll be happy
Foul is offline  
Old 16 May 2011, 20:34   #133
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,668
@SpeedGeek
Congratulations, you found the bug that I couldn't see appearing anywhere, but fixed it in 45.4.209 (Aminet) already. It started in 206.

Quote:
I may have discovered a small bug in V46.4 related to the parsing of tooltypes. When I try to run Visage (which has quite a large number of tooltypes) I get an "Error parsing arguments - Object not found message". If I switch to an older version of icon.library it works just fine.
Quote:
There are just a few additional fixes for some bugs that did not even get out of their holes yet. I've never seen them and nobody reported anything concerning these bugs.
Thank you for reporting it.
PeterK is offline  
Old 29 May 2011, 11:31   #134
mfilos
Paranoid Amigoid

mfilos's Avatar
 
Join Date: Mar 2008
Location: Athens/Greece
Age: 38
Posts: 1,576
Send a message via Skype™ to mfilos
PeterK good morning.
I saw that a new version of BoingBag4 (0.8r) released that has an upgraded icon.library (46.4.209 --> 46.4.210).
What are the changes on this version cause I tried it and the PNG icons seem better on the previous (46.4.209) version on ECS Amiga 600. I can provide screenshots if needed

Thanks
mfilos is offline  
Old 29 May 2011, 13:18   #135
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,668
All changes are mentioned in the readme file on Aminet.
I tried to avoid any changes for screens with low depths, but other resolutions have a higher priority than ECS with 16 colors, I'm sorry.

Please, try out different settings for the icon quality in the Workbench preferences. 'Best' is not guaranteed to be the best configuration. But this has no effect, of course, if all colors are fixed like it is with Rebel's palette.

Sorry mfilos, my friend !!
I made a mistake in my modifications of the IconBeFast routine. And you found it! This was only a problem for ECS screens and I wanted to avoid it, but something went wrong

So, please try 211 and everything should work again as before on your ECS system.

Update: http://eab.abime.net/showpost.php?p=...&postcount=143

Last edited by PeterK; 07 June 2011 at 19:09.
PeterK is offline  
Old 29 May 2011, 14:23   #136
mfilos
Paranoid Amigoid

mfilos's Avatar
 
Join Date: Mar 2008
Location: Athens/Greece
Age: 38
Posts: 1,576
Send a message via Skype™ to mfilos
No problem Peter mate. Ofc ECS has lower priority and tbh I don't care much about it.
I haven't seen there was an Aminet version update as well

Cheers and thanks for the constant updates!
mfilos is offline  
Old 29 May 2011, 14:25   #137
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,668
Please read my updated posting above.
PeterK is offline  
Old 29 May 2011, 15:31   #138
mfilos
Paranoid Amigoid

mfilos's Avatar
 
Join Date: Mar 2008
Location: Athens/Greece
Age: 38
Posts: 1,576
Send a message via Skype™ to mfilos
Peter my friend thanks for looking at it.

I tried the new version of yours just now and I made the following screenshots comparing it with the previous 46.4.209 under my A600 ECS (and Rebel's palette).

Click image for larger version

Name:	46.4.209 - 46.4.211.png
Views:	151
Size:	67.2 KB
ID:	28764

The most important part is that pngalpha.library doesn't make ANY difference NOR WarpPNG's "Default Backround" that needed to be OFF for better results! That is really neat stuff there.

You can check the biggest difference that can be visible on Aladdin and AmiFish icons.

I hope it helps a bit

Thanks
mfilos is offline  
Old 29 May 2011, 15:43   #139
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,668
The configuration for the WarpPNG.datatype and the PNGdt 44.6 is done automatically by the icon.library now, no matter whatever you setup in the preferences. So, you can adapt your settings to what your favourite picture viewer needs and store that in the preferences. And the pngalpha.library won't be used anymore by these two datatypes.

Btw, is Rebel's palette suitable for MWB icons and MUI colors?

Last edited by PeterK; 29 May 2011 at 15:50.
PeterK is offline  
Old 30 May 2011, 16:03   #140
amigakit.com
Registered User

amigakit.com's Avatar
 
Join Date: Aug 2004
Location: www.amigakit.com
Posts: 1,706
Hello,

Thanks for the update on Aminet.

I have installed it and OS4.1 icons look good on my 3.9 system (16-bit P96 screenmode):



Thanks for your hard work on this library!
amigakit.com is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
C Code without official includes redblade Coders. Language 3 20 March 2013 14:05
A new OFFICIAL AmigaOne 500 DDNI News 49 18 July 2012 16:08
some goodies not in official .dat thevoice project.TOSEC (amiga only) 8 11 November 2006 12:35
The Official "Newly Aquired Games" thread StarEye project.SPS (was CAPS) 42 24 February 2006 01:33
official - CD32 better than dreamcast tin Retrogaming General Discussion 7 16 April 2004 21:43

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:11.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.25200 seconds with 12 queries