English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 19 January 2011, 13:33   #1
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 42
Posts: 1,260
Send a message via ICQ to Foul Send a message via MSN to Foul Send a message via Skype™ to Foul
Some icons not shown on OS3.9

Hi !

Still playing with my migy, i just upgraded my old workbench to OS3.9.

Now some games/demos icons are missing (not all) .. just a dot .. like not showing Newicons icons.

Is there a way to correct this ?


ps: still waiting the next pack
Foul is offline  
AdSense AdSense  
Old 19 January 2011, 13:46   #2
TCD
Global Moderator

TCD's Avatar
 
Join Date: Sep 2006
Location: Germany
Age: 39
Posts: 24,032
Quote:
Originally Posted by Foul View Post
like not showing Newicons icons.
Install NewIcons?
TCD is offline  
Old 19 January 2011, 13:53   #3
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 42
Posts: 1,260
Send a message via ICQ to Foul Send a message via MSN to Foul Send a message via Skype™ to Foul
with OS3.9, newicons icons are "integrated" in the system ... but in mine .. some are shown .. others don't ..

Don't know why ...
Foul is offline  
Old 19 January 2011, 14:01   #4
TCD
Global Moderator

TCD's Avatar
 
Join Date: Sep 2006
Location: Germany
Age: 39
Posts: 24,032
Upgrade NewIcons then? Can't see why some NewIcons should show correct, while others do not. Anyway, can you give an example of an icon that works and one that doesn't?
TCD is offline  
Old 19 January 2011, 18:28   #5
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 42
Posts: 1,260
Send a message via ICQ to Foul Send a message via MSN to Foul Send a message via Skype™ to Foul
waiting to be @ home to make a screenshot...


Last edited by Foul; 19 January 2011 at 19:58.
Foul is offline  
Old 19 January 2011, 19:59   #6
Wepl
Moderator
Wepl's Avatar
 
Join Date: Nov 2001
Location: Germany
Posts: 633
there were a handful of broken icons in the beginning, these can be fixed using fixni
Wepl is offline  
Old 19 January 2011, 20:03   #7
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 42
Posts: 1,260
Send a message via ICQ to Foul Send a message via MSN to Foul Send a message via Skype™ to Foul
excellent ! test it now
Foul is offline  
Old 19 January 2011, 20:09   #8
TCD
Global Moderator

TCD's Avatar
 
Join Date: Sep 2006
Location: Germany
Age: 39
Posts: 24,032
Good to know Wepl
TCD is offline  
Old 19 January 2011, 20:31   #9
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 42
Posts: 1,260
Send a message via ICQ to Foul Send a message via MSN to Foul Send a message via Skype™ to Foul
not working with my newicon.library v44

"you need newicon.library version 39. you must NOT have run any patches
on the newicon.library!"

where to find it ? nothing on aminet

edit : found : http://cd.textfiles.com/amigaformat/.../libs/020-V39/

Code:
4.DEMOS:V/VirtualWorld> fixni VirtualWorld.info
NormalImage   Width=120 Height=96  NumColor=33  Flags=1 Palette=106B8B1C Data=106B5E1C
SelectedImage Width=120 Height=96  NumColor=31  Flags=1 Palette=106BB89C Data=106B8B9C
4.DEMOS:V/VirtualWorld>
Still nothing

edit 1 : showing VirtualWorld icon playing with icon.library ... not working with some others ... !!?!!

edit 2 : Working with all before modifying with fixni

Last edited by Foul; 19 January 2011 at 20:55. Reason: Back to back posts merged. Use the edit function.
Foul is offline  
Old 19 January 2011, 20:52   #10
Wepl
Moderator
Wepl's Avatar
 
Join Date: Nov 2001
Location: Germany
Posts: 633
what tells fixni if you run it again with that icon, number of colors should be the same now...
no it wont change the number of colors.
upload the icon to the zone please

Last edited by Wepl; 19 January 2011 at 21:00.
Wepl is offline  
Old 19 January 2011, 21:05   #11
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 42
Posts: 1,260
Send a message via ICQ to Foul Send a message via MSN to Foul Send a message via Skype™ to Foul
done.

edit : icon Exe_NewIcon.info from http://aminet.net/util/app/AppAssign31.lha not showing too ...

Last edited by Foul; 19 January 2011 at 21:25.
Foul is offline  
Old 19 January 2011, 22:02   #12
Wepl
Moderator
Wepl's Avatar
 
Join Date: Nov 2001
Location: Germany
Posts: 633
the icon is too large 120 width, probably also height 96 are too much for os35/9, I'll add a crop to fixni...
Wepl is offline  
Old 19 January 2011, 22:05   #13
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 42
Posts: 1,260
Send a message via ICQ to Foul Send a message via MSN to Foul Send a message via Skype™ to Foul
cooooolll
Foul is offline  
Old 19 January 2011, 22:58   #14
Wepl
Moderator
Wepl's Avatar
 
Join Date: Nov 2001
Location: Germany
Posts: 633
updated fixni is in the zone, will crop the images to 94x94 because os3.5/3.9 doesn't display larger ones
Wepl is offline  
Old 19 January 2011, 23:19   #15
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 42
Posts: 1,260
Send a message via ICQ to Foul Send a message via MSN to Foul Send a message via Skype™ to Foul
Eek

Code:
4.Ram Disk:> dir
     Clipboards (dir)
     T (dir)
  newicon.library                  
4.Ram Disk:> version newicon.library 
newicon.library 44.3
4.Ram Disk:> rename newicon.library newicon2.library
4.Ram Disk:> dir
     Clipboards (dir)
     T (dir)
  newicon2.library                 
4.Ram Disk:> version newicon2.library 
newicon.library 39.1
4.Ram Disk:> ?????????
WTF ???

4.Amiga:> fixni exe_newicon.info
need original newicon.library version 39/40 in libs:
4.Amiga:>

edit : exe_newicon.info patched .. but still no icon showed

edit 2 : seems to be "normal" : http://eab.abime.net/showthread.php?p=730703#post730703

Last edited by Foul; 20 January 2011 at 00:29.
Foul is offline  
Old 20 January 2011, 09:12   #16
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,526
Quote:
Originally Posted by Wepl View Post
updated fixni is in the zone, will crop the images to 94x94 because os3.5/3.9 doesn't display larger ones

For me both icons show fine in OS 3.9 BB2.

I would rather check if the original NewIcons is completely removed from the system. Check s:user-startup and remove c:newicons and c:deficons from it. Then delete newicon.library V39 from libs:.
Attached Thumbnails
Click image for larger version

Name:	newicons.png
Views:	217
Size:	8.1 KB
ID:	27622  
thomas is offline  
Old 20 January 2011, 10:58   #17
Bamiga2002
BlizzardPPC'less

Bamiga2002's Avatar
 
Join Date: May 2004
Location: Finland
Age: 40
Posts: 3,211
Send a message via MSN to Bamiga2002
Has this icon.library update slipped unnoticed?
Bamiga2002 is offline  
Old 20 January 2011, 11:13   #18
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 42
Posts: 1,260
Send a message via ICQ to Foul Send a message via MSN to Foul Send a message via Skype™ to Foul
for me BB3 & BB4 installed...
Foul is offline  
Old 20 January 2011, 20:52   #19
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,668
Please try this icon.library 46.4.178. It should show your exe_newicon.info

Icon.library removed, an updated version will come out on Aminet....

Last edited by PeterK; 21 January 2011 at 02:51.
PeterK is offline  
Old 20 January 2011, 22:22   #20
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 42
Posts: 1,260
Send a message via ICQ to Foul Send a message via MSN to Foul Send a message via Skype™ to Foul
working on exe_newicon.info but not on VirtualWorld.info and VectorBallsDemo.info in the zone
Foul is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
DualPNG and OS4 icons on OS3 James Amiga scene 14 19 June 2017 15:21
Transparent desktop icons - OS3.9 NovaCoder support.Apps 3 17 August 2012 05:52
How do i change icons under OS3.9? portarinos support.Apps 13 11 July 2010 23:25
OS3.5 Icons Anubis project.ClassicWB 17 23 September 2007 12:05
AmiStart - PNG Icons - OS3.9 Stein support.WinUAE 1 30 November 2005 02:03

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 01:43.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.21462 seconds with 12 queries