English Amiga Board


Go Back   English Amiga Board > News

 
 
Thread Tools
Old 28 March 2014, 02:28   #321
Amicol
Registered User

 
Join Date: Dec 2013
Location: Hartlepool / England
Posts: 338
Quote:
Originally Posted by NovaCoder View Post
No it won't work, none of my ScummVM ports support the MT32.


I am interesting in buying one though, is this what I need to get?

MT-32

What about the Amiga to MT32 MIDI cable, where can you buy them from?

It would be pretty cool if I could get ScummVM to support both the Prisma and external MIDI for music playback
Yep, that's the one. You can also get the MT-100, it's a MT-32 (mk2) together with a sequencer. Sometimes a bit cheaper, and they don't have the 'buffer overflow' problem
Amicol is offline  
AdSense AdSense  
Old 28 March 2014, 03:34   #322
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,667
Send a message via Skype™ to Retrofan
I haven't heard of any game with buffer overflow (and less one that could be played on a miggy).

That MT32 has a good price, they are more expensive everytime. You will find some more for 100€ or more, so you won't have any problem if you need to resell it after a time, you would sell it better.

Nova you will also need a midi interface like this http://z-amigastore.com/index.php?op...ng=en&vmcchk=1 that is the same that I've got, the midi cable http://www.ebay.es/itm/5-Pin-Din-Mid...e317219&_uhb=1 and the thick audio cables that I think are these http://www.ebay.es/itm/1-5m-PULSE-2-...a4ce444&_uhb=1

please somebody tell me if I am wrong.

Edit: These are the audio selectors I use to buy if you -surely- need them (well, this is cheaper than mines): http://www.ebay.es/itm/AV-RCA-Select...f2d75c3&_uhb=1

Edit: Offtopic I've seen what do I need to connect it to a Pc [ Show youtube player ]

Last edited by Retrofan; 28 March 2014 at 04:41.
Retrofan is offline  
Old 28 March 2014, 05:01   #323
DonutKing
Registered User

 
Join Date: Sep 2011
Location: Australia
Posts: 38
This could be the go, as long as shipping from NZ isn't too bad.
http://www.ebay.com/itm/Roland-MT32-...-/261435568756
DonutKing is offline  
Old 28 March 2014, 05:42   #324
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,444
Thanks guys, will have to try and bag myself one
NovaCoder is offline  
Old 28 March 2014, 11:16   #325
Amicol
Registered User

 
Join Date: Dec 2013
Location: Hartlepool / England
Posts: 338
Quote:
Originally Posted by Retrofan View Post
I haven't heard of any game with buffer overflow (and less one that could be played on a miggy)
Buffer Overflow is a well known bug in the mk1 MT-32. Problem is more prominent while using with PC. Should be fine on Amiga, although I have never used mine with it.

Was corrected in mk2 MT-32, although some games made for mk1 MT-32 can sound different. Mk2 (the one with headphone jack at the back, everything else looks the same) are very rare and expensive. MT-100 is a cheaper way of getting hold of one. Just giving information.....
Amicol is offline  
Old 28 March 2014, 11:23   #326
AMike
Registered User
AMike's Avatar
 
Join Date: Jan 2007
Location: near Vienna/Austria
Posts: 114
Quote:
Originally Posted by NovaCoder View Post
No it won't work, none of my ScummVM ports support the MT32.


I am interesting in buying one though, is this what I need to get?

MT-32

What about the Amiga to MT32 MIDI cable, where can you buy them from?

It would be pretty cool if I could get ScummVM to support both the Prisma and external MIDI for music playback
I wanna say thank for your hard work in the past - do you have an paypal account?
AMike is offline  
Old 13 June 2014, 02:04   #327
Overmann
Registered User

 
Join Date: May 2014
Location: Norway
Posts: 20
Hello,

The program seems to be working for me but i have a couple of questions that i really hope someone can help me with.

I've seen someone on youtube get quite good performance on DOTT on an 030, but for me even MI1 crawls horribly. And I only manage to get PCspeaker sound. Are there some performance enhancements that has come to light that I might not have read about?

I don't get any sound or video-requester on startup (even though i have AUTO_SELECT_AUDIO_DEVICE=FALSE etc.) Are there circumstances where I would not get a requester?

I would be very grateful if someone could give me some tips as to how to configure for my system:
A1200 3.1 (BetterWB)
ACA1232 /ec40mhz
ACATune -maprom **
Idefix
AHI 4.18 (fast paula stereo++)

SCUMMVM AGA 030 (Stack 20400) set to:
AUDIO_THREAD_PRIORITY=1
MONITOR_TYPE=PAL
AUTO_SELECT_AUDIO_DEVICE=FALSE
AUTO_SELECT_VIDEO_DEVICE=FALSE

Any helpful tips to get me running?
(Btw, I have read through this thread)
Overmann is offline  
Old 13 June 2014, 03:53   #328
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,444
Hiya,

It sounds like there is something very wrong with your set up

I can't think of any reason that the requesters wouldn't come up, I'm actually surprised it runs at all?

I don't think you're running the latest release (which doesn't look like it supports requesters), you should be using -> 1.3.1.031

Are you sure your AHI is installed properly? Do you get any error messages when you open the AHI Prefs?

If installing the latest version and checking your AHI install doesn't help, the only other thing I can suggest is to use WinUAE and try and identify what part of your WB set up is causing the issue on your real hardware.

Performance with an ACA @ 40Mhz should be fine for Monkley Island 1/2 and DOTT as long as you don't enable MIDI music emulation (fast 040 required for MIDI emulation!). You shouldn't be using the PC speaker, just go with the defaults from the install which are set to the lowest possible (best performance).

PHP Code:
Performance Considerations:

 
1You should always patch exec.library's CopyMem() and CopyMemQuick() routines
for faster processor specific versions.
 2) Try reducing the audio playback frequency down to 8k if you'
re still having
performance issues
.
 
3) If you are using Paulastick with the 'FAST' 8 bit modes for AHI (prefs) -
a real 16 bit card will be faster with a 16 bit mode.
 
4This interpreter hits the hard drive so you'll need a fast transfer rate for
the newer games.
 5) Loading your ROM into FASTRAM is a great idea ;)
 6) Use v4.18 of AHI as the later versions are too slow! 
[ Show youtube player ]

Last edited by NovaCoder; 13 June 2014 at 03:59.
NovaCoder is offline  
Old 13 June 2014, 09:41   #329
Overmann
Registered User

 
Join Date: May 2014
Location: Norway
Posts: 20
Quote:
Originally Posted by NovaCoder View Post
Hiya,

It sounds like there is something very wrong with your set up

I can't think of any reason that the requesters wouldn't come up, I'm actually surprised it runs at all?

I don't think you're running the latest release (which doesn't look like it supports requesters), you should be using -> 1.3.1.031

Are you sure your AHI is installed properly? Do you get any error messages when you open the AHI Prefs?

If installing the latest version and checking your AHI install doesn't help, the only other thing I can suggest is to use WinUAE and try and identify what part of your WB set up is causing the issue on your real hardware.

Performance with an ACA @ 40Mhz should be fine for Monkley Island 1/2 and DOTT as long as you don't enable MIDI music emulation (fast 040 required for MIDI emulation!). You shouldn't be using the PC speaker, just go with the defaults from the install which are set to the lowest possible (best performance).

PHP Code:
Performance Considerations:

 
1You should always patch exec.library's CopyMem() and CopyMemQuick() routines
for faster processor specific versions.
 2) Try reducing the audio playback frequency down to 8k if you'
re still having
performance issues
.
 
3) If you are using Paulastick with the 'FAST' 8 bit modes for AHI (prefs) -
a real 16 bit card will be faster with a 16 bit mode.
 
4This interpreter hits the hard drive so you'll need a fast transfer rate for
the newer games.
 5) Loading your ROM into FASTRAM is a great idea ;)
 6) Use v4.18 of AHI as the later versions are too slow! 
[ Show youtube player ]
Hi Novacoder,

Thank you for your reply, and for the ScummVM-port!
I am using 1.3.1.031. I might be wrong, but I only seem to get PC-speaker sound. I would love to play MI1&2 with all the wonderful music on my Amiga (which, strangely, is how i remember it..), but I only get the occasional blips and blops, and not the constant soundtrack that I get on scummvm on PC.

I have now deleted all the AHI-files and reinstalled it, but nothing has changed (4.18). I get no error-messages when starting AHIprefs, and everything behaves the same now that I have my HDD hooked up to winUAE.

DOTT, MI2, Atlantis and MI1 are all running quite smoothly with no sound, but with sound enabled they behave differently.

DOTT - Still no sound
MI1 - PC-Speaker blippetiblop
MI2 - Black screen, nothing happends
Atlantis - Black screen, nothing happends

I have followed your performance guide. The only thing I haven't been able to do much about is my HDD transfer speed. Which is stuck at around 2mb. Internal IDE. I don't know of a way to increase this speed. I am using pfs3.

Thank you again for your reply!

EDIT:
And if i want to "add a game" from another partition then the one I installed ScummVM to the program freezes. When attempting to "go back" beyond DH1: . When using ScummVM ECS i am able to copy games to fastram and play them much faster. It does not crash when going beyond DH1: .

Last edited by Overmann; 13 June 2014 at 09:57.
Overmann is offline  
Old 13 June 2014, 12:14   #330
dlfrsilver
CaptainM68K-SPS France
dlfrsilver's Avatar
 
Join Date: Dec 2004
Location: Melun nearby Paris/France
Age: 40
Posts: 7,175
Send a message via MSN to dlfrsilver
i have more or less the same problem
dlfrsilver is offline  
Old 13 June 2014, 21:48   #331
Nobby_UK
Registered User
Nobby_UK's Avatar
 
Join Date: Jul 2013
Location: Liverpool
Posts: 836
Tried Zak McKracken and the Alien Mindbenders last night :
(A1200 + Apollo 040/25 + 32 Meg)
Looks Lovely, Speed is Fine
But I miss the music

Need to fiddle with the settings methinks.
Nobby_UK is offline  
Old 13 June 2014, 22:09   #332
Amicol
Registered User

 
Join Date: Dec 2013
Location: Hartlepool / England
Posts: 338
@Overmann
My system only had 2mb transfer speed with PFS3 and ScummVM works fine. So I don't think that is your problem. Maybe when the new sound card is released by Amigakit, NovaCoder will provide support for it. That should solve the problem for slower setups
Even better, support for MT32
Amicol is offline  
Old 13 June 2014, 23:29   #333
ancalimon
Supernormal

ancalimon's Avatar
 
Join Date: Jul 2007
Location: Istanbul / Turkey
Age: 36
Posts: 1,229
Quote:
Originally Posted by Amicol View Post
@Overmann
My system only had 2mb transfer speed with PFS3 and ScummVM works fine. So I don't think that is your problem. Maybe when the new sound card is released by Amigakit, NovaCoder will provide support for it. That should solve the problem for slower setups
Even better, support for MT32
I suggest getting some faster hdd interface. It makes a huge difference; especially FastATA MK4. But you need some kind of riser to use it with Indivision MK2.
ancalimon is offline  
Old 17 June 2014, 10:32   #334
Overmann
Registered User

 
Join Date: May 2014
Location: Norway
Posts: 20
I did a sysspeed and sysinfo check and found that my HDD get almost 3mb on both read and write. It's not as bad as i thought, but it would be nice with something faster.

Does anyone else experience crashes when attemting to add a game from a different partition/device then the one that ScummVM is running from?

Also, does anyone manage to get full sound/music? I get a lot more sound and music when running games in ScummVM on my PC. ALso the sound and music is much higher quality, but that I understand.
Overmann is offline  
Old 17 June 2014, 11:13   #335
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,444
Quote:
Originally Posted by Overmann View Post
I did a sysspeed and sysinfo check and found that my HDD get almost 3mb on both read and write. It's not as bad as i thought, but it would be nice with something faster.

Does anyone else experience crashes when attemting to add a game from a different partition/device then the one that ScummVM is running from?

Also, does anyone manage to get full sound/music? I get a lot more sound and music when running games in ScummVM on my PC. ALso the sound and music is much higher quality, but that I understand.
Are you using SFS/PFS3? FFS is really slow.

I think that bug when access different directories is something I've seen before, not sure why it happens. I normally just have all my games on the same partition so it's not an issue for me.

Do you mean MIDI emulated music? My 060 does a good job with emulated MIDI now days, I did a video but unfortunately the sound quality is very bad (using a mobile phone). Sounds much better in the flesh.

[ Show youtube player ]
NovaCoder is offline  
Old 17 June 2014, 11:49   #336
Overmann
Registered User

 
Join Date: May 2014
Location: Norway
Posts: 20
I am using PFS3.

Is the music that I am hearing during MI 1 titles and the "Part 1" screen not MIDI? If it's not and the rest of the music is MIDI, and somehow deactivated, then I guess I partly understand.

I remember that my old 060, ConciertoIV-setup did a great job with scommVM. I am not really surprised that mu 1232 is struggling a bit.
Overmann is offline  
Old 17 June 2014, 12:42   #337
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,444
Sorry but an 030 is too weak to emulate MIDI in ScummVM, you need either a fast 040 or an 060.

With an 030 it's best to just disable the music completely in most games.
NovaCoder is offline  
Old 17 June 2014, 12:56   #338
Overmann
Registered User

 
Join Date: May 2014
Location: Norway
Posts: 20
I see. Just out of curiosity: The music that I am hearing isn't MIDI? It plays perfectly smooth and works great, it's just very scarce. I didn't know that there was non-MIDI music in those games.

EDIT: Also, NovaCoder, I see you've been commenting regarding A-EONs new soundcard. Is this a device that would enable music to play on my setup if you were to implement it as part of your 030 build of ScummVM? Again, you're doing a great job!
Overmann is offline  
Old 17 June 2014, 13:54   #339
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,444
Quote:
Originally Posted by Overmann View Post
EDIT: Also, NovaCoder, I see you've been commenting regarding A-EONs new soundcard. Is this a device that would enable music to play on my setup if you were to implement it as part of your 030 build of ScummVM? Again, you're doing a great job!
It would only support compressed music playback in certain games (non-MIDI), for example Full Throttle. MIDI music in ScummVM is dynamically generated so you cannot simply record it and turn it into a compressed music file.
NovaCoder is offline  
Old 17 June 2014, 14:02   #340
Amicol
Registered User

 
Join Date: Dec 2013
Location: Hartlepool / England
Posts: 338
Quote:
Originally Posted by NovaCoder View Post
I think that bug when access different directories is something I've seen before, not sure why it happens. I normally just have all my games on the same partition so it's not an issue for me.
I have always used another partition for storing the games, with no problems at all. I am using PFS3. I think real midi support may be the only answer after reading your last post NovaCoder. Will this be possible to implement?
Amicol is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Latest version of ScummVM also ported to ECS NovaCoder News 121 02 March 2017 14:16
Latest version of ScummVM also ported to RTG NovaCoder News 200 08 June 2016 11:39
Quake 2 ported to AGA NovaCoder News 130 22 May 2014 18:44
Full Throttle AGA - ScummVM V1.0.0 NovaCoder project.Amiga Game Factory 102 04 July 2011 12:53
ScummVM and AGA Amiga HardStep support.Games 25 05 November 2006 21:19

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:33.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.24732 seconds with 12 queries