English Amiga Board


Go Back   English Amiga Board > Main > Retrogaming General Discussion

 
 
Thread Tools
Old 12 December 2010, 05:41   #1
uridium
Registered User
uridium's Avatar
 
Join Date: Dec 2009
Location: Sydney
Posts: 18
1541 clone + 1581 write only

Hello.

Quick summary:
I can "new" disks. I can save files. No flashing red LED at the end of disk ops. I can't then get a dir listing for the new disks. I have a BlueChip BCD5.25 and a c1581 3.5" drive. I can new, and save files but can't pull up a dir listing afterwards. What am I doing wrong?

Long Summary:
I've just dug my old Blue Chip BCD5.25 (1541 clone) and my c1581 out of storage. I've been using a retro replay for a few years. Anyway. I pulled the two drives out, gave the heads a clean with some metho spirits to get rid of the general spooge and chocolate fingers residue and plugged them in with the RRcart and other userport expansions disconected.

With both my breadbox c64 and 1541, I can New a disk in either drive with
OPEN15,8,15,"N0:quux,01":CLOSE 15

Both drives chuff away merrily for a while and finish without any flashing LED's. I can then go query the channel and it's "OK" no error. Yay! I can then write a quick 5 line basic program and do a:

SAVE "SOMETHING",8

Works fine. Then do a NEW to flush memory then do a:
LOAD"$",8

..and both drives sit there. Never return.

I can "sometimes" hit RUNSTOP and it'll drop to BASIC promptm then do a LIST, but it returns nothing.

Any ideas? Thanks in advance

Al.
uridium is offline  
AdSense AdSense  
Old 12 December 2010, 09:26   #2
uridium
Registered User
uridium's Avatar
 
Join Date: Dec 2009
Location: Sydney
Posts: 18
no.. wait got it now. OPEN1,8,15,"N0:QUUX,00":CLOSE 15

.. now it's happy False alarm and a healthy dose of PEBKAC on my part.
uridium is offline  
Old 12 December 2010, 09:34   #3
Exile
Registered User
Exile's Avatar
 
Join Date: Jul 2010
Location: The Netherlands
Age: 42
Posts: 116
blue chip drives

hi

be carefull with the blue chip drives, there not really compatible.
they have many problems with fast loaders.

could also be there out of aligment. better use a real cbm drive or a dec clone.
Exile is offline  
Old 12 December 2010, 12:15   #4
adolescent
Powered by Motorola

 
Join Date: Feb 2002
Location: Redondo Beach, CA
Age: 46
Posts: 1,064
Quote:
Originally Posted by uridium View Post
no.. wait got it now. OPEN1,8,15,"N0:QUUX,00":CLOSE 15
I don't see the error with your first command. Now with the one above you are opening and closing different file numbers which is wrong.
adolescent is offline  
Old 14 December 2010, 22:01   #5
uridium
Registered User
uridium's Avatar
 
Join Date: Dec 2009
Location: Sydney
Posts: 18
Hi Exile,

Yeah.. noticing Mostly I just use the RRPlay cart of late. Ended up with this thing decades ago and usually ignored it for my 1541 back at home with the old man, but it's the only 5.25 I have this side of the country. Wish I could set it to device 9 or 10. There's no jumpers. I ripped and dumped the ROM last night and the heads are now aligned. Definitely has a superior construction strength compared to the 1541-II's but not the original tool-box 1541.

Thanks for the tip.. I expect plenty of incompatibilities

Al.

adolescent:

Works though and the first one does something else. Still looking into this.

Last edited by TCD; 14 December 2010 at 22:03. Reason: Back to back posts merged. Use the edit function.
uridium is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
A bejewelled clone, deviish clone, columns clone Gordon Looking for a game name ? 10 16 June 2014 20:28
1541-1571_Drive_Alignment_Free_Spirit zharn request.Apps 3 30 April 2013 17:40
FREE 2x 1541 demusse MarketPlace 10 02 January 2010 00:36
Commodore 1581 Disk Drives nishtek MarketPlace 24 16 August 2009 02:27
amiga hd as 1541.. poppe Retrogaming General Discussion 7 19 December 2001 19:06

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:41.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.12178 seconds with 11 queries