English Amiga Board


Go Back   English Amiga Board > Main > Amiga scene

 
 
Thread Tools
Old 03 October 2011, 16:23   #221
Ezrec
Registered User
 
Join Date: Jan 2011
Location: Pittsburgh, PA
Posts: 31
Ok, lots of stuff being reported here. Let me make a thread for bug tracking and start a new thread...

Ok, new thread created. AROS m68k bug report page is at:

http://www.evillabs.net/wiki/index.p...k-amiga_Status

amiga_user, please update the bug report page with URLs and at what version (WinUAE version or AROS nightly build number) you saw the problems.

Last edited by TCD; 03 October 2011 at 17:36.
Ezrec is offline  
AdSense AdSense  
Old 03 October 2011, 16:54   #222
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,958
Quote:
Originally Posted by amiga_user View Post
ANY file requester ! Try to show volumes in multiview file requester or ANY other program.
Fixed. Bad BSTR handling in AROS asl.library.
Toni Wilen is offline  
Old 04 October 2011, 14:42   #223
Mequa
Registered User
 
Join Date: Nov 2009
Location: UK
Posts: 497
AROS site suspended?

It appears that aros.sourceforge.net is down, having been suspended "for exceeding its bandwidth threshold"?

I see from Google's cache of aros.sourceforge.net/download.php, however, that there was a release of AROS-68k on Sunday 2nd October, with both ROM images and a CD-ROM ISO.

Where can I download the latest AROS-68k builds now? I couldn't find any active mirrors.
Mequa is offline  
Old 04 October 2011, 17:06   #224
Dwyloc
Registered User
 
Join Date: Apr 2005
Location: Glasgow, Scotland
Age: 41
Posts: 81
@Mequa
Yes I have noticed the same error a few times of late when I have been attempting to go to the main AROS site to download the USB WiFi driver to test.

I am not aware of any other mirror sites offering the AROS nightly builds so I cant help there.
Dwyloc is offline  
Old 04 October 2011, 20:38   #225
Mequa
Registered User
 
Join Date: Nov 2009
Location: UK
Posts: 497
I'm not sure if anyone has a copy of "AROS-20111002-amiga-m68k-boot.lha" and "AROS-20111002-amiga-m68k-bootiso.zip" (or any newer builds)? If so, please send a PM.

Alternatively, uploading them to The Zone would be fantabulous.
Mequa is offline  
Old 07 October 2011, 17:37   #226
Dwyloc
Registered User
 
Join Date: Apr 2005
Location: Glasgow, Scotland
Age: 41
Posts: 81
Try this link http://sourceforge.net/projects/aros/files/ looks like you can still get at the project files.
Dwyloc is offline  
Old 16 October 2011, 16:04   #227
Dwyloc
Registered User
 
Join Date: Apr 2005
Location: Glasgow, Scotland
Age: 41
Posts: 81
I have just tested the latest nightly Aros-m68k build on my 4MB minimig and I want to confirm that I can soft kicking works fine and I can load a workbench 1.3 adf without problems.

AROS does not seem to see the A600 IDE interface on the minimig though as I get the AROS insert bootable media screen and my workbench 3.1 harddisk does not showup when I boot an adf image with workbench on it.
Dwyloc is offline  
Old 16 October 2011, 16:19   #228
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,958
Quote:
Originally Posted by Dwyloc View Post
AROS does not seem to see the A600 IDE interface on the minimig though as I get the AROS insert bootable media screen and my workbench 3.1 harddisk does not showup when I boot an adf image with workbench on it.
Gayle-based (A600/A1200) and A4000 IDE is supported. Only way to debug this is to get serial debug log.
Toni Wilen is offline  
Old 16 October 2011, 20:22   #229
Dwyloc
Registered User
 
Join Date: Apr 2005
Location: Glasgow, Scotland
Age: 41
Posts: 81
[reset]
CPU: 68000 FPU: -
[SysBase] fakebase at: 0000020c
[SysBase] kernel commandline 'sysdebug=InitCode'
RAM lower: 00c00000
RAM upper: 00d7ffff
RAM lower: 00001000
RAM upper: 001fffff
BSS lower: 0c8e028
BS uper 008e33SS lowr: 0c002
S upe: 0c9027
prtecKic: 0d7008
NuEntries:00000001
*
Start : 00d7d000
End : 00d7efff
Size : 00002000
NumEntries: 00000001
*
Start : 00ca7000
End : 00d7bfff
Size : 000d5000
NumEntries: 00000001
*
Start : 00c92000
End : 00ca5fff
Size : 00014000
NumEntries: 00000001
*
Start : 00c90000
End : 00c90fff
Size : 00001000
NumEntries: 00000001
*
Start : 00c8e000
End : 00c8efff
Size : 00001000
NumEntries: 00000001
*
Start : 00d7fe50
End : 00d7ffff
Size : 000001b0
NumEntries: 00000001
*
Start : 00d7fbe0
End : 00d7fe4f
Size : 00000270
Protect: 00c00000
* SS !
Start : 00c90028
End : 00c90827
Size : 00000800
* BSS !
Start : 00c8e028
End : 00c8e313
Size : 000002ec
First : 00c00020
Bytes : 0008dfe0
Resident modules (addr: pri flags version name):
+ 00ca02d6: 127 02 3 "kernel.resource"
+ 00c99d34: 120 01 45 "exec.library"
+ 00c9ddc4: 110 82 41 "expansion.library"
+ 00c9dee4: 105 01 41 "diag nit
00a040: 0 0 1 "ilSysemresure"+ 0c9f2: -901 41"robot"[SsBae a]:000040
RA Addr: : 00001000
RAM Size: : 001ff000
protectKick: 00d7d008
NumEntries: 00000001
NumEntries: 00000001
NumEntries: 00000001
NumEntries: 00000001
NumEntries: 0000000
NumEntres:000001
umEtris: 00000
Potet:000100
*SS
Start : 00c9028
End : 00c9827
Size : 00000800
* BSS
Start : 00c8e028
End : 00c8e313
Size : 000002ec
First : 00001020
Bytes : 001fefe0
[ColdCapture] Igoring AOS>ARS ramolie
[sart IntCoe(TF_INGETAK, 0
[nitode calig IitRsidnt 11 82"exansonlibary)
configchain
configchain done
adding ram boards
ram boards done
[InitCode] leave InitCode(0x02,0)
KickemPr: 0d700
NmEnrie: 000001Numntres:000001
umEtris: 000001
NuEnties 000001Numntres:00000001
NumEntries: 00000001
NumEntries: 00000001
S lwer 008c00SS uppr:00cdff
[nitod] eterIniCoe(001,0)[IntCde]kicmemtr0x000000 ickagtr=0x00D7FE70 kickchecksum=0x293966B2
[InitCode] Resident modules after KickTags merge:
+ 00CA02D6: 127 02 3 "kernel.resource"
+ 00C99D34: 120 01 45 "exec.library"
+ 00C9DDC4: 110 82 41 "expansion.library"
+ 00C9DEE4: 105 01 41 "diag init"
+ 00CA8468: 103 81 41 "utility.library"
+ 00CA72A4: 101 81 41 "aros.library"
+ 00D6D32C: 100 81 41 "potgo.resource"
+ 00D661A8: 99 01 2 "processor.resource"
+ 00CBA74C: 94 81 42 "oop.library"
+ 00D4BE78 2 8 "iddlas.hid"
+ 00A060: 8 0 "ileysem.esurc"+ 006D12: 8 01 0"ci.rsouce"
+ 00D65C3C: 70 81 41 "battclock.resource"
+ 00D590E4: 66 81 1 "graphics.hidd"
+ 00CD51BC: 65 81 41 "graphics.library
+ 00DAAC: 6081 50"laerslibar"
0025B8: 5081 41"tier.evie"+ 007994: 4 81 41"cad.esorce"
+ 00D5A274: 45 81 1 "keyboard.hidd"
+ 00D5AB90: 45 81 1 "mouse.hidd"
+ 00D6DBF0: 45 01 41 "misc.resource"
+ 00D27558: 4 81 4 "kybord.evce"
+ 002FF0: 4 81 41"gaeprt.evie"
+ 00C284: 4 81 41 "keyap.library"
+ 00D5B478: 40 81 1 "amigakbd.hidd"
+ 00D5BEA8: 40 81 1 "amigamouse.hidd"
+ 00D6D938: 39 81 41 "isk.resouce"
+ 002F44: 3 81 41"trckiskdevce"
+ 0026AC: 3 81 41"iputdevce"
+ 00CC12C: 20 1 3 "partition.library"
+ 00CFF2AC: 15 81 50 "intuition.library"
+ 00D608CC: 9 81 1 "amigavideo.hidd"
+ 00D2CAE4: 4 81 41 "console.device"
+ 00D36A0: 4 1 1 "ta.evce"
+ 00BBB0: 081 40 "matieeesinbas.librry"
+ 00D0B10: 0 1 1 "gadtools.library"
+ 00D3DB18: -1 01 1 "cdrom-handler"
+ 00D47D6C: -1 01 41 "afs-handler"
+ 00C9DF2C: -9 01 41 "romboot
+ 00D4EC: -1081 1"uagfxhid"+ 00D2424: -4 81 41 680x0.lirary"
+ 00DA00: 45 1 41 "alert.hook
"
+ 00D68CC0: -50 01 41 "dosboot.resource"
+ 00CB75F8: -120 00 50 "dos.library"
+ 00CBB0F0: -120 80 41 "athffp.libary
001514: 12 80 45"workench.lirary"
+ 00D31218 -120 8 41 audo.dvic"
00D6CA7C: -120 04 41 "DOSBoot cleanup"
+ 00D11A20: -122 84 44 "icon.library"
+ 00D66C80: -123 04 41 "lddemon.resource"
+ 00D70438: -123 04 41 "shell.resource"
+ 00D73ED0: -123 04 41 "shellcommands.resource"
+ 00D77DC0: -123 04 44 "workbook.resource"
+ 00D7845E: -123 00 40 "workbench.task"
+ 00D410C4: -124 04 41 "con-handler"
+ 00D4B738: -125 04 1 "amber-ram-handler"
[InitCode] calling InitResident (120 01 "exec.library")
[InitCode] calling InitResident (105 01 "diag init")
callroms
callromsdone
[InitCod] callig InitResdent (13 81 "utlit.lirar")
[IitCde]calingIniResident (101 81 "aros.library")
[InitCode] calling InitResident (100 81 "potgo.resource")
[InitCode] calling InitResident (9 01 "procesor.resouce")
[InitCde calin IntRsidnt 9481 ooplibary)
[Iitode calig IitRsidnt(9281 hidclass.hid")
[IitCod] cllig nitesient(8 01"FieSste.reoure"
[IitCde calin IntRsidnt 80 1 ciaresurc")[InitCode] calling InitResident (70 81 "battclock.resource")
[InitCode] calling InitRsident (6681 grahis.hdd"
[nitode calin IitRsidnt (65 81 "graphics.library")
[InitCode] calling InitResident (60 81 "layers.library")
[nitode calig IitRsidnt(5081 timr.dvie")
[IitCde]callig InitResident (48 81 "card.resource")
[InitCode] calling InitResident (45 81 "keyboard.hidd")
[IitCde calin IntRsidnt 45 1 moue.hdd"
[InitCode] calling InitReident (45 1 "iscreoure")
[IitCde calin IntRsidnt 44 1 keyoar.dvic")
[IitCde]calin IntResident (44 81 "gameport.device")
[InitCode] calling InitResident (40 81 "keymap.library")
[InitCode] calling InitResident (40 81 "amigakbd.hidd")
[InitCode] calling InitResident (40 81 "amigamouse.hidd")
[InitCode] calling InitResident (39 1 "disk.rsouce"
[IitCde calin IntReidnt 35 1 "rakdik.dvic")
[InitCode] calling InitResident (30 81 "input.device")
[InitCode] calling InitResident (20 81 "partition.library")
[InitCode calingIntReidnt 15 1 intitin.ibrry"
[Iitode]calingIniReidet ( 81 "amigavideo.hidd")
[IitCode] calling InitResident (4 81 "console.device")
[InitCode] calling InitResident (4 81 "ata.device")
[ATA] Gayle ID=00. Possible IDE port=00000000.
[InitCode] calling InitResident (0 81 "mathieeesingbas.library")
[InitCode] calling InitResdent (0 8 "gdtolslibary)
[InitCode] calling InitResident (-1 01 "cdrom-handler")
[InitCode] calling InitResident (-1 01 "afs-handler")
[InitCode] calling InitResident (-9 01 "romboot")
romtaginit
romtaginit done
[InitCode] calling InitResident (-10 81 "uaegfx.hidd")
[nitod] cllig Iitesient(-4 8 "60x0librry"
[IitCde]calin IntReidnt -4501 alet.ook
")
[InitCode] calling InitResident (-50 01 "dosboot.resource")
[Iitode] enter InitCode(0x04, 0)
[InitCode] calling InitResident (-120 04 "DOSBoot cleanup")
[InitCode] calling InitResidet (12284 icn.lbray")
[IitCde calin IntRsidnt -12 04"ldemn.resource")
[IntCoe] calling InitResident (-123 04 "shell.resource")
[InitCode] calling InitResident (-123 04 "shellcommands.resource")
[nitode calin IitRsident -123 04 workbookresource)
[InitCode] calling InitResident (-124 04 "con-handler")
[nitode calin IitRsidnt -15 0 "aberra-hadle")
[InitCode] leave InitCode(0x04, 0)
Dwyloc is offline  
Old 16 October 2011, 20:32   #230
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,958
Quote:
[ATA] Gayle ID=00. Possible IDE port=00000000.
It seems Minimig does not implement Gayle ID register.

AOS A600 IDE driver probably does not care but AROS does because it needs to detect correct hardware model.
Toni Wilen is offline  
Old 16 October 2011, 23:34   #231
yaqube
Registered User
 
Join Date: Mar 2008
Location: Poland
Posts: 158
Quote:
Originally Posted by Dwyloc View Post
AROS does not seem to see the A600 IDE interface on the minimig
I'm aware of this problem. The solution is known but it decreases performance significantly. I'm working on a better one.
yaqube is offline  
Old 17 October 2011, 14:23   #232
Dwyloc
Registered User
 
Join Date: Apr 2005
Location: Glasgow, Scotland
Age: 41
Posts: 81
@Toni Wilen
I am just happy to see AROS-m68k making such good progress, their is something special about seeing and Open Amiga OS reimplementation running classic hardware on a modern open hardware reimplementation of Amiga hardware.

I know that WinUAE is probably a more cost effective way of running old Amiga software, but its always nice to have more than one way of doing things and the Minimig does take up much less space and use less power than a PC or even an A500 setup with a harddisk.
Dwyloc is offline  
Old 17 October 2011, 16:53   #233
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,958
Quote:
Originally Posted by Dwyloc View Post
@Toni Wilen
I am just happy to see AROS-m68k making such good progress, their is something special about seeing and Open Amiga OS reimplementation running classic hardware on a modern open hardware reimplementation of Amiga hardware.

I know that WinUAE is probably a more cost effective way of running old Amiga software, but its always nice to have more than one way of doing things and the Minimig does take up much less space and use less power than a PC or even an A500 setup with a harddisk.
Compatibility with classic hardware is the main goal.

Badly behaving emulation or re-implementation is considered broken and won't be supported unless it can be easily worked around without breaking compatibility with real classic hardware.

Missing Gayle ID can't be worked around. Gayle ID can be read safely on all classic hardware models and it can be used to identify different hardware very easily, other model specific registers aren't that safe.
Toni Wilen is offline  
Old 17 October 2011, 17:14   #234
Dwyloc
Registered User
 
Join Date: Apr 2005
Location: Glasgow, Scotland
Age: 41
Posts: 81
Quote:
Originally Posted by Toni Wilen View Post
Compatibility with classic hardware is the main goal.

Badly behaving emulation or re-implementation is considered broken and won't be supported unless it can be easily worked around without breaking compatibility with real classic hardware.
I completely agree with that sentiment and as the Minimig is FPGA based hardware, a software fix in AROS would be the wrong place to fix any issue I find testing AROS on my Minimig that don't also effect genuine Classic Amiga hardware.

Plus if people don't post about the issues they find then other people will not know what issues to expect if they try the same thing :-)

I was just interested to see AROS-m68k running on a low specification 68000 CPU based system, as until the Minimig supports 1MB ROMs I expect very few people will even be interested in attempting to use it on a Minimig.

Anyway keep up the good work and I will look forward to making further use of AROS-m68k in the future.
Dwyloc is offline  
Old 20 October 2011, 08:00   #235
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,444
Quote:
Originally Posted by Toni Wilen View Post
Compatibility with classic hardware is the main goal.

Badly behaving emulation or re-implementation is considered broken and won't be supported unless it can be easily worked around without breaking compatibility with real classic hardware.
I agree with that, get it right on the original HW and as long as the FPGA hardware itself is 100% compatiable with the original HW all should be fine

BTW, I'd like to say that it's great to see such rapid progress made on this important project....keep it up guys
NovaCoder is offline  
Old 24 October 2011, 18:33   #236
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,958
Quote:
Originally Posted by Toni Wilen View Post
I am totally stuck with real hardware issues that can't happen in emulation. Namely 68060 copyback cache. If it is enabled, Blizzard SCSI hangs during booting, time to hang is random.
This bug was finally found (details will be explained in another post soon..).

CopyBack is again enabled by default which increases performance greatly, also MMU is used to remap arosbootstrap loaded rom image to real fast from chip if accelerator fast ram is not MEMF_KICK capable (for example Blizzard A1200 accelerators), result is another big speed up.

040/060 MMU is used by default, 030 requires "mmu" command line parameter because EC030 can't be easily detected, in worst case it hangs the system instantly.

card.resource is also implemented, etherlink3 and prism2 driver compatible PCMCIA cards will work soon..
Toni Wilen is offline  
Old 25 October 2011, 15:05   #237
amiga_user
 
Posts: n/a
@Toni:

The Locale prefs & OpenURL prefs give a recoverable alert: memory header not located.


PS. Is screen dragging in hardware now, or is it still in software ?
Attached Files
File Type: txt winuaelog.txt (22.8 KB, 95 views)

Last edited by amiga_user; 25 October 2011 at 15:13.
 
Old 25 October 2011, 20:03   #238
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,958
Quote:
Originally Posted by amiga_user View Post
@Toni:

The Locale prefs & OpenURL prefs give a recoverable alert: memory header not located.
Locale prefs problem is caused by non-m68k compatible codesets.library (assumes stack based registers, m68k uses registers)

Should work if you replace it with AOS native m68k version of codesets.library.

Quote:
PS. Is screen dragging in hardware now, or is it still in software ?
Chipset screen dragging has always used. It would be painfully slow in software. (Dragging still does not support multiple screens, all screens behind current screen are not visible)

RTG screens support software dragging. (devs:monitors/compositor)
Toni Wilen is offline  
Old 28 October 2011, 15:22   #239
shdwkat
 
Posts: n/a
Uae/e-uae

Toni,
It is with much pleasure that I have been following your progress
on AROS m68k. Keep up the good work.

I first used the Amiga while staioned in Germany. I am presently
a Linux user and after finding WInUAE/UAE/E-UAE It felt like being
reuinited with a long lost family member.

It is with great anticipation that I await your further develpments
with AROS and even more so with the NATAMI Team.
 
Old 02 November 2011, 19:16   #240
amiga_user
 
Posts: n/a
@Toni:

When I CLOSE "Aweb", it gives the following Recoverable alerts:

"file handler closed more than once"
"memory header not located"
Attached Files
File Type: txt winuaelog.txt (23.3 KB, 108 views)

Last edited by amiga_user; 04 November 2011 at 12:24.
 
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
ChipQuik and substitute kipper2k Hardware mods 18 27 September 2013 11:55
AROS m68k Bug Reports Ezrec Amiga scene 1 03 October 2011 23:40
AROS m68k running on WinUAE turrican3 Amiga scene 1 01 January 2011 05:07
Kickstart substitute gilgamesh request.UAE Wishlist 19 17 January 2009 16:37
New Bounty-Project started for AROS: Kickstart replacement Paul News 0 26 December 2004 13:12

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 03:59.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.30807 seconds with 12 queries