English Amiga Board


Go Back   English Amiga Board > Main > Retrogaming General Discussion

 
 
Thread Tools
Old 04 June 2010, 16:26   #1
tonyyeb
Has the Amiga bug again
tonyyeb's Avatar
 
Join Date: Oct 2007
Location: Hull, UK
Age: 37
Posts: 792
Send a message via MSN to tonyyeb
Custom PSP Firmware question

Hi all

Just ordered a Pandora battery for my PSP 1003 so I can use custom firmware for PSPUAE etc... Question I have is if I have a custom firmware installed, can I still use UMD based games? Do I have to reflash back to a genuine PSP firmware?

Cheers!
tonyyeb is offline  
AdSense AdSense  
Old 04 June 2010, 16:32   #2
StingRay
move.l #$c0ff33,throat

StingRay's Avatar
 
Join Date: Dec 2005
Location: Berlin/Joymoney
Posts: 5,591
Quote:
Originally Posted by tonyyeb View Post
Question I have is if I have a custom firmware installed, can I still use UMD based games?
You can! Without any problems.
StingRay is offline  
Old 04 June 2010, 16:33   #3
tonyyeb
Has the Amiga bug again
tonyyeb's Avatar
 
Join Date: Oct 2007
Location: Hull, UK
Age: 37
Posts: 792
Send a message via MSN to tonyyeb
Great stuff! Was worried i'd be flashing and reflashing all the time. Looking forward to it even more now.
tonyyeb is offline  
Old 04 June 2010, 17:40   #4
Zetr0
Ya' like it Retr0?
Zetr0's Avatar
 
Join Date: Jul 2005
Location: United Kingdom
Age: 43
Posts: 9,769
@tonyyeb

hiyas buddy, put the kettle on, make yourself a brew and start reading (chocky hob-nobs optional, but recommended)

heres what you need with links and how to do it.


1. Pro Duo Memory stick with MagicGate(tm) enabled

Heres a reasonable priced item from eBay.co.uk BIN 4.61 (includes postage)

please make sure to ask the seller to ensure that these cards are offical sandisk that have magic gate capability. (if they dont they are fakes and no use to you)

Now the next part is programming the card(s) - Follow this guide on how to make a Magic Memory Stick under windows XP or Vista, this does assume you have a way of connecting the PSP or ProDuo card to the PC, if not have a look on eBay for Pro Duo to USB adapter, they should be under 2 inc postage.
(i have included the software you need in a link very shorty)


2. The Pandora (Service) Battery

Good news is that I can send you one free - I will convert an existing PSP Slim battery (dont worry its a spare and of no use to me) and pop it in a jiffy bag to you- send me your address and I will send it tomorrow morning =D

I have uploaded a two packs for download

Pack 1> Magic Memory Stick Creator [26MB]
  • This package has 1 Directory

    1. Unpack the file
    2. review the guide posted earlier
    3. read the README.TXT file
    4. run the program "autorun.exe"
    5. Follow onscreen instructions

After you have used the Magic Memory Stick Creator, you should be able to UNLOCK your PSP with the Pandora Battery and the memory stick.

Turn off complete the PSP, insert the memory card, and then remove the existing battery and replace it with the Pandora Battery - if the PSP is CFW friendly it will attempt to load a Firmware from the Memory card. (you will notice the MSProDuo read light flashing)

when present follow the onscreen instructions (press X to continue flashing)

When complete and you have done a reboot, you will have CFW 3.71 installed from here you will need the next package

Pack 2> PSP_Update_Pack [67MB]
  • This package has 3 directories

    1. 5.00 m33-6
    2. 5.50 GEN D
    3. selplugins

Installing Custom Firmwares

Once you are CFW enabled we can now update your PSP with the following

1. Update for 5.00 M33-6 (needed before 5.50GEN-D) (connect PSP or Card to USB)
  • a. Copy the "500.PBP" file from the "5.00 m33-6" directory to the ROOT of the memory card
    b. Copy the "UPDATE" folder from the "5.00 m33-6/5.00M33-6" directory to the "PSP/GAME" on the Memory Card

Now using the PSP navigate to GAME on the XMB, press X and select the UPDATE icon (you will now update to 5.00M33-6)

2. Upadte for 5.50 GEN-D (support 6.x SFW)(connect PSP or Card to USB)
  • a. Copy the "550.PBP" file from the "5.50 GEN D" directory to the ROOT of the memory card
    b. Copy the "UPDATE" folder from the "5.50 GEN D\5.50GEN-D\PSP\GAME" directory to the "PSP/GAME" on the Memory Card

Now as above, using the PSP navigate to GAME on the XMB, press X and select the UPDATE icon (you will now update to 5.50 GEND-D)

I have thoroughly tested GEN-D on vairious PSP's now and I am pleased to say its well worth getting upgraded too, its got great legacy support (in the sense none of the old stuff is broken!) and gives you 6.xx OFW Game support =D (includes Gran Turismo) yummy


Whats all this "selplugins" and recovery stuff all about?

well its about software libraries for the POPs (POrtable Playstation) emualtion on the PSP. cutting a long story short not ALL games were complied / converted with the same libraries as such some games wont load without that set in memory so what we need to do is.

1. Copy the "selplugins" directory to the ROOT of the memorycard you have you games on.
2. Completely "TURN OFF" the PSP and restart in Revovery Mode
  • Hold down Right Shoulder Button and then turn on the PSP, this will enable the recovery options.

In the recovery Menu

We will enable Games to run from the memory card (without the need for UMD)
Enable selplugins for POPs

1. select [[Configuration ->]] by pressing 'X'
2. highlight [[UMD Mode]] and press 'X' untill it states "( M33 Driver - No UMD)"
3. highlight and select [[Back]]
4. highlight and select [[Plugins ->]]
5. highlight and select [[popsloader.prx [POPS]]] by pressing 'X' to [Enable]
6. highlight and select [[Back]] and then highlight and select [[Exit]]

your PSP will now reboot with POP's fully enabled and PSP games can now run from ISO's from your Game memory Card.

There that lot should helps =D



Now, do you want to know more about PSP emulation?


A while back I did some youtube guides (including how to setup other emu on on retro Gamer)
That should get your gaming glands going =D
Zetr0 is offline  
Old 04 June 2010, 17:46   #5
tonyyeb
Has the Amiga bug again
tonyyeb's Avatar
 
Join Date: Oct 2007
Location: Hull, UK
Age: 37
Posts: 792
Send a message via MSN to tonyyeb
@Zetro

Kettle on! Cheers buddy.

PS - Already ordered a Pandora battery but thanks for the offer.
tonyyeb is offline  
Old 04 June 2010, 18:01   #6
kipper2k
Registered User

 
Join Date: Sep 2006
Location: Thunder Bay, Canada
Posts: 3,617
Nice Guide Zetro,

I haven't updated mine for ages, its a 1.5, with 3.2 FW i think was the last time it got updated. Mabbe its time to upgrade
kipper2k is offline  
Old 09 June 2010, 21:14   #7
tonyyeb
Has the Amiga bug again
tonyyeb's Avatar
 
Join Date: Oct 2007
Location: Hull, UK
Age: 37
Posts: 792
Send a message via MSN to tonyyeb
Can't seem to get SNES9x TYL 0.4.2 to work. I've copied the 1.5 folder contents to GAME150 but not joy, it keeps saying "The game could not be started (80020148).

What am I doing wrong?

EDIT: I have got PicoDrive running but I don't have any Mega Drive ROMs...

EDIT2: Got Sonic now and it works a treat!! Now onto Amiga emulation... hopefully someone can help get the SNES emu working too!

Last edited by tonyyeb; 09 June 2010 at 21:28.
tonyyeb is offline  
Old 09 June 2010, 21:45   #8
alexh
Thalion Webshrine
alexh's Avatar
 
Join Date: Jan 2004
Location: Oxford
Posts: 11,942
On a side note, anyone know if a PSP 1000 is incapable of doing WPA2 WiFi?

I've got a PSP 1000 with 5.50 GEN-D and it just says Security : "Not Supported".

On my router (O2 Wireless box II) I've got WPA2-PSK security mode enabled.

Edit : I guess no PSP can do WPA2 then

Last edited by alexh; 09 June 2010 at 22:03.
alexh is offline  
Old 09 June 2010, 22:52   #9
alexh
Thalion Webshrine
alexh's Avatar
 
Join Date: Jan 2004
Location: Oxford
Posts: 11,942
Quote:
Originally Posted by tonyyeb View Post
it keeps saying "The game could not be started (80020148).
You need the 1.50 kernel addon pack. 150.PBP in the root of your memory stick.
alexh is offline  
Old 10 June 2010, 00:37   #10
MethodGit
Junior Member
MethodGit's Avatar
 
Join Date: Dec 2002
Location: The Streets
Age: 33
Posts: 2,723
With all due luck I should have my hands on a PSP-2000 in a matter of days. I previously had a silver PSP-1000 (imported from an online store) before but lost it a couple of years ago, much to my annoyance. At least it's given me an opportunity to try a Slim model this time.

I was hoping the GP2X Wiz I got for my birthday would do enough perfect emulation all round for me to not worry about wanting a PSP for a while, but much to my grievance, some emulators are coded rather poorly. Its CPS2, NeoGeoCD and SMS/GG emulators, for instance, can't shine a candle to the superior efforts for the PSP community. And it's yet another one of those handhelds that can't do Duke3D right!

Doesn't help that people didn't put as much effort into the Wiz scene due to a) complaints that it isn't different enough to the original GP2X (indeed many Wiz programs were simply lazy ports from the original GP2X with no changes or enhancements), and b) the Pandora.
MethodGit is offline  
Old 10 June 2010, 10:50   #11
StingRay
move.l #$c0ff33,throat

StingRay's Avatar
 
Join Date: Dec 2005
Location: Berlin/Joymoney
Posts: 5,591
Quote:
Originally Posted by alexh View Post
You need the 1.50 kernel addon pack. 150.PBP in the root of your memory stick.
This won't help him since he's running 5.50 Gen-XX FW. Besides, 150.PBP is just the normal 1.50 FW and has nothing to do with any 1.50 kernel addon pack!

Last edited by StingRay; 10 June 2010 at 10:57. Reason: typo
StingRay is offline  
Old 10 June 2010, 10:54   #12
tonyyeb
Has the Amiga bug again
tonyyeb's Avatar
 
Join Date: Oct 2007
Location: Hull, UK
Age: 37
Posts: 792
Send a message via MSN to tonyyeb
Quote:
Originally Posted by StingRay View Post
This won't help him since he's running 5.50 Gen-XX FW. Besides, 150.PBP is just the normal 1.50 FW and has nothinig to do with any 1.50 kernel addon pack!
So what do I need to get this to work? Should I use a different SNES emulator?
tonyyeb is offline  
Old 10 June 2010, 10:55   #13
StingRay
move.l #$c0ff33,throat

StingRay's Avatar
 
Join Date: Dec 2005
Location: Berlin/Joymoney
Posts: 5,591
Quote:
Originally Posted by tonyyeb View Post
So what do I need to get this to work? Should I use a different SNES emulator?
Yes. 5.50 GEN has no 1.50 kernel addon.
StingRay is offline  
Old 10 June 2010, 11:05   #14
alexh
Thalion Webshrine
alexh's Avatar
 
Join Date: Jan 2004
Location: Oxford
Posts: 11,942
This definitely works with 5.50 GEN-D3, dunno if it is any good.

http://dl.qj.net/download/snes9x-euphoria-r1.html
alexh is offline  
Old 10 June 2010, 11:18   #15
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 39
Posts: 5,591
Send a message via MSN to FOL Send a message via Skype™ to FOL
Why anyone would want to use 1.50 is beyond me. Virtually everything has now been made to run on higher firmwares.
Most the of the time, the 1.50 eboots can be converted to a single eboot and they work fine.

DCemu UK have a good list of emulators for PSP, and includes different versions.
FOL is offline  
Old 10 June 2010, 12:28   #16
Arnie
R.I.P Smudge 18-08-16

Arnie's Avatar
 
Join Date: Aug 2005
Location: Leicester/UK
Age: 59
Posts: 3,861
It`s now possible to use Original firmware 6.20 and the pandora battery with XGEN PANDORA v4.0 to boot into CFW 5.00 m33-4 , 4.01 m33-2, 360 m33 & CFW 150 using the test m33 function and DC8. Once your card is setup with DC8 and you have setup your plugins and pops you`re good to go.
Arnie is offline  
Old 11 June 2010, 00:45   #17
MethodGit
Junior Member
MethodGit's Avatar
 
Join Date: Dec 2002
Location: The Streets
Age: 33
Posts: 2,723
Quote:
Originally Posted by Arnie View Post
It`s now possible to use Original firmware 6.20 and the pandora battery with XGEN PANDORA v4.0 to boot into CFW 5.00 m33-4 , 4.01 m33-2, 360 m33 & CFW 150 using the test m33 function and DC8. Once your card is setup with DC8 and you have setup your plugins and pops you`re good to go.
Presumably you can't do this with a Go?


Also, which was the last firmware to have a 1.50 kernel addon? Not that it'd be of much use with a Slim though I guess. I wonder how difficult it actually is to do a simple port of 1.50-only programs to User Mode? I feel MMSPlus and Apple II Portable could do with an update.
MethodGit is offline  
Old 11 June 2010, 02:29   #18
Zetr0
Ya' like it Retr0?
Zetr0's Avatar
 
Join Date: Jul 2005
Location: United Kingdom
Age: 43
Posts: 9,769
Quote:
Originally Posted by tonyyeb View Post
So what do I need to get this to work? Should I use a different SNES emulator?
sounds to me a like borked install, this can easily happen.

I would delete existing directory on the PSP and then reinstall it on your "ROOT/PSP/GAME5xx/"

I have had this on many PSP1000 (PHAT) models and never had to use the 1.50 Kernal addon under 5.50 GEN-D

Download SNES9x TYL and follow this guide it should see you thought =)
Zetr0 is offline  
Old 11 June 2010, 10:26   #19
tonyyeb
Has the Amiga bug again
tonyyeb's Avatar
 
Join Date: Oct 2007
Location: Hull, UK
Age: 37
Posts: 792
Send a message via MSN to tonyyeb
Sorry guys should have said (got two similar threads on the go at the moment) I have SNES emulation working now, cheers.
tonyyeb is offline  
Old 11 June 2010, 10:59   #20
Arnie
R.I.P Smudge 18-08-16

Arnie's Avatar
 
Join Date: Aug 2005
Location: Leicester/UK
Age: 59
Posts: 3,861
I`m using a slim, TA83 i think, the last 150CFW for the slim was a hybrid 360+150, which is what i`m using. I don`t know if it`s actually any use but it`s there in case i need it.
Arnie is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
DataFlyer SCSI Plus firmware 2.1 papa_november request.Other 17 22 November 2017 16:15
For sale : boxed 1003 psp w/custom firmware terexuk MarketPlace 4 01 May 2011 19:46
New PSP Amiga emualtor: PSP UAE4ALL r1 Hungry Horace News 6 17 January 2008 22:43
DataFlyer SCSI Plus firmware 2.1 Computolio request.Apps 2 23 September 2007 13:02
CSPPC/060 firmware upgrade alewis support.Hardware 4 25 August 2006 12:12

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 01:11.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.48863 seconds with 11 queries