English Amiga Board


Go Back   English Amiga Board > News

 
 
Thread Tools
Old 28 March 2010, 12:12   #1
oRBIT
Zone Friend
 
Join Date: Apr 2006
Location: Gothenburg/Sweden
Age: 42
Posts: 223
A/NES is back from the dead

It was more than two years ago A/NES, the Nintendo 8-bit emulator for classic AmigaOS, was declared dead.
But now it has risen from it's grave, and it's back, with a new beta-release v1.17beta1.
Some of it's fixes are:
* Palette bugfixes
* Minor graphicsoptimizations
* Implementation of NTSC/PAL screenmodes
+ some other misc stuff

Check out the website
http://www.anes.se
oRBIT is offline  
AdSense AdSense  
Old 28 March 2010, 12:56   #2
Retro1234
5150

Retro1234's Avatar
 
Join Date: Jun 2006
Location: Sycophantazia
Posts: 3,776
Cool - Just tried and does seem better, Mario works about 85% but still little slow on my A1200/030/40 -Turtles doesnt work
Retro1234 is offline  
Old 28 March 2010, 13:26   #3
fryguy
Registered User
 
Join Date: Aug 2005
Location: Hjo, Sweden
Age: 38
Posts: 724
Mario was way too fast on my 040/40. But perhaps i didn't have sound emulated (not sure as i don't have any speakers connected to my Amiga). I had to limit speed to make it playable.
fryguy is offline  
Old 28 March 2010, 15:21   #4
Cammy
Registered User
Cammy's Avatar
 
Join Date: Aug 2007
Location: Gold Coast, Australia
Age: 32
Posts: 1,134
Thanks oRBIT! I just played Batman and Super Mario Bros. 3 and they ran almost full speed on the 030/50, but there were a few of graphic glitches. The sound and music seemed fine though. Is there any way to force the games to open on an NTSC screen instead of PAL? Even American and Japanese ROMs still opened on a PAL screen. Keep up the good work!

Last edited by Cammy; 28 March 2010 at 15:27.
Cammy is offline  
Old 28 March 2010, 16:39   #5
oRBIT
Zone Friend
 
Join Date: Apr 2006
Location: Gothenburg/Sweden
Age: 42
Posts: 223
Thanks for all your feedback, they mean alot!
About the glitches, yeah, there are still lots of things to fix. Time will tell how that'll progress.

Be sure the header of your NES ROMs are correct now if you want a proper screenmode. For technical interested, byte 9, bit 0 of the headers is set to 0 if it's an NTSC ROM or 1 for PAL. The PAL bit is rarely set on ROMs found on the internet so you may want to verify that bit if things behave strangely.

If A/NES is running too fast for you (perhaps on 040 and definitely on 060 systems), be sure the "limit speed" option is enabled in the GUI.
oRBIT is offline  
Old 28 March 2010, 16:43   #6
Bloodwych
Moderator

Bloodwych's Avatar
 
Join Date: Jun 2001
Location: I'm behind you!
Posts: 3,763
I'm going to be including an emulation addon pack for the ClassicWB packs in the future - I can add this if you want oRBIT.
Bloodwych is offline  
Old 28 March 2010, 17:00   #7
Retro1234
5150

Retro1234's Avatar
 
Join Date: Jun 2006
Location: Sycophantazia
Posts: 3,776
Maybe NTSC would squeeze a little more speed - I think I will need a frame skip.
@oRBIT Seriously well done.
Retro1234 is offline  
Old 29 March 2010, 01:26   #8
DyLucke
Cookie Muncher
DyLucke's Avatar
 
Join Date: Nov 2008
Location: Spain
Age: 42
Posts: 232
Congrats oRBIT, time to do a test run... Lemme say the old version was pretty good, and i'm anxious to see the improvements.

I hope other developers could follow your example and give some improved versions for the emus we actually have on our classic amigas. 030 /50 is a very capable CPU for 8bit emulation. Thanks for keeping your project alive.
DyLucke is offline  
Old 29 March 2010, 18:33   #9
Xenon
Registered User
Xenon's Avatar
 
Join Date: Nov 2004
Location: Zaragoza, Pamplona-Iruņa, Bera
Age: 36
Posts: 426
Oustanding
Xenon is offline  
Old 29 March 2010, 19:49   #10
fryguy
Registered User
 
Join Date: Aug 2005
Location: Hjo, Sweden
Age: 38
Posts: 724
I just realised that i have 060/50 in my A4000, it's borrowed. So i haven't tried the emulator on my 040/40 yet. That explains the great speed
fryguy is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
A NES Site I've created, NES-Bit.com Lorfarius Retrogaming General Discussion 63 05 June 2012 18:14
Amiga Samba for Idiots Site - Back from the dead. Mikey_C News 3 16 October 2008 21:00
NES emu anyone? Shoonay Retrogaming General Discussion 37 08 August 2008 15:51
Ok ---Im ready to be transported back.back.back to the 90s. Check out what Ive got. nc88keyz Amiga scene 9 12 January 2008 23:58
Back To The Roots back from the dead! MethodGit News 11 22 October 2007 20:27

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:38.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.35413 seconds with 11 queries