English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > New to Emulation or Amiga scene

 
 
Thread Tools
Old 07 February 2010, 22:17   #1
Zed
Registered User
Zed's Avatar
 
Join Date: Jan 2010
Location: Sweden
Posts: 27
Question about CD-Rom support in WinUAE

Hi!
I have made a Workbench 3.1 installation and also got the CD-Rom working in the emulated Amiga. Many thanks to Thomas for his great guide I found at this adress: http://thomas-rapp.homepage.t-online.de/uaescsi.html

I have a question about this. In the guide at 2.8 it says this:

Quote:
scroll down to the MaxTransfer line. Change the value to 0xfc00.
When I opend the CD0 using the command:
Code:
ed devs:dosdrivers/CD0
I couldn't find the line. I have added it in CD0 like this:
Code:
MaxTransfer = 0xfc00
Now, I can't see any different if the line exists in CD0 or not. I can read Amiga CD:s without any problem so far nomatter if this line is in the configuration or not.

My question is, what is this parameter used for? I assume it has something to do with the transfer of data between the CD and the Harddrive.

Kind Regards
Zed
Zed is offline  
AdSense AdSense  
Old 08 February 2010, 08:52   #2
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,526
MaxTransfer defines how many bytes may be read by one command to the device. If it is too high you'll get read errors or corrupted files.

People who tried to install OS 3.9 know what I mean, because the installer always sets MaxTransfer = 0x1000000 which sooner or later results in "volume AmigaOS3.9 has a read/write error".
thomas is offline  
Old 08 February 2010, 18:13   #3
Zed
Registered User
Zed's Avatar
 
Join Date: Jan 2010
Location: Sweden
Posts: 27
Thank you Thomas for the information.
I have another question about this. What happends if the parameter MaxTransfer is missing in the configuration of CD0. Will it have a default value that is to high?

Kind Regards
Zed
Zed is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
support for AROS boot rom Worfje support.WinFellow 16 16 November 2011 21:43
CD-ROM support on A500/A600 Eamoe support.Hardware 21 27 April 2011 21:58
Portaudio support (was: WinUAE support for ASIO drivers) Akira support.WinUAE 57 28 March 2009 21:15
A1200 4-Way IDE Adapter: IDEfix & CD-ROM support in OS3.9 StevenJGore support.Hardware 8 01 June 2008 00:27

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:30.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.12146 seconds with 12 queries