English Amiga Board


Go Back   English Amiga Board > News

 
 
Thread Tools
Old 13 December 2009, 17:07   #1
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,934
WinUAE 2.0.0 released

http://www.winuae.net/

WinUAE 2.0.0 (13.12.2009)
====================

Main new features:

- Huge A500 cycle exact mode compatibility improvement.
- Improved unexpanded A1200/CD32 emulation compatibility. Approximate cycle-exact 68EC020/68020 emulation implemented, includes emulated 68020 instruction cache, approximate prefetch emulation.
- 68040 MMU emulation (from Aranym) For example Enforcer and M68K Linux compatibility. Not compatible with JIT.
- A2065 Zorro II hardware ethernet card emulation.

Other updates:

- CD32 drive emulation compatibility improved, includes animation CD streaming.
- Old game protection dongles emulated (Leaderboard, Robocop3, etc..)
- Built-in Vista/Windows 7 WASAPI sound API support.
- Real harddrive safetycheck only complains if drive is mounted read-write and has mounted Windows partitions.
- Full NTSC timing implemented (long/short line toggle etc..)
- "AutoVSync" mode that change native refresh rates automatically.
- Basic CPU frequency/bus multiplier configuration option added.
- Gayle IDE emulation compatibility improved.
- Single sided PC/Atari ST disk images supported.
- AVI and wave sound recording improved.
- File paths support http, https and ftp protocols.
- Automatic split DMS support.
- File dialog file type setting is stored to registry/ini.
- Display width is not anymore restricted to values divisible by eight.
- Bsdsocket emulation MSG_WAITALL implemented, CVS compatibility fix.
- Uaescsi.device TD_REMOVE implemented.
- DMA cycle debugger implemented.
- RTG screen mode on-screen leds.
- "Add PC drives at startup" does not mount drives that are also configured as real harddrives.

Bugs fixed:

- Programmed refresh (non-PAL or NTSC) rate modes had bad sound.
- Right border background color error in some programs.
- On the fly USB input device insert changed unrelated keyboard layout settings.
- Non-DMA mode sprites work again (broke long time ago)
- 5.1 sound mode had wrong center and sub mixing ratio.
- CD32 pad default mapping green and yellow, RDW and FFW reversed.
- Uaescsi.device TD_GETGEOMETRY off by one error and no media status fixed.
- Directory filesystem ACTION_FH_FROM_LOCK notification bug fixed.
- Some types of serial ports were not detected.
- Randomly appearing single jumping black scanline finally fixed.
- Command line quote parsing was not compatible.
- Mouse didn't capture properly in mouse driver (tablet) mode.
- Directory harddrive duplication was possible in configuration file if path included national characters.

and much more than ever before.. (probably bugs too..)
Toni Wilen is online now  
AdSense AdSense  
Old 13 December 2009, 18:00   #2
andreas
Zone Friend
 
Join Date: Jun 2001
Location: Germany
Age: 43
Posts: 5,858
Send a message via ICQ to andreas Send a message via AIM to andreas
A historical day!
(This lets one remember the fact that WinUAE has now been developed for over 15 [FIFTEEN] years!)
andreas is offline  
Old 13 December 2009, 18:10   #3
antonvaltaz
Registered User
antonvaltaz's Avatar
 
Join Date: May 2009
Location: Mirfield, West Yorkshire, UK
Age: 36
Posts: 511
Hurrah! Have downloaded and installed this (it's only the winuae.exe file which has changed, isn't it?)

Do the improved A500 cycle exact emulation and the new A1200 cycle exact emulation demand more CPU horsepower? Are there recommended specs for this version?
antonvaltaz is offline  
Old 13 December 2009, 18:15   #4
TCD
Registered User

TCD's Avatar
 
Join Date: Sep 2006
Location: Germany
Age: 39
Posts: 24,032
Nice one Toni
TCD is offline  
Old 13 December 2009, 18:20   #5
Graham Humphrey
Global Moderator
Graham Humphrey's Avatar
 
Join Date: Jul 2004
Location: Norwich, Norfolk, UK
Age: 31
Posts: 10,974
Great! Another fantastic release.
Graham Humphrey is offline  
Old 13 December 2009, 18:22   #6
CodyJarrett
Global Moderator

CodyJarrett's Avatar
 
Join Date: Mar 2001
Location: UK
Age: 40
Posts: 5,743
Thank you Toni!
CodyJarrett is online now  
Old 13 December 2009, 18:26   #7
the wolf
Just Leeching
the wolf's Avatar
 
Join Date: Apr 2002
Location: Italy
Age: 46
Posts: 416
Thank you VERY much, this is a great, long awaited news! Keep up the good work!
Long life to WinUAE (and Toni)!
the wolf is offline  
Old 13 December 2009, 19:41   #8
Retroplay
Lemon Curry ?

Retroplay's Avatar
 
Join Date: Sep 2004
Location: Denmark
Posts: 2,928
The best just got better
Retroplay is offline  
Old 13 December 2009, 19:47   #9
NewDeli
Banned
 
Join Date: Oct 2007
Location: Paris / FRANCE
Age: 44
Posts: 1,248
Send a message via ICQ to NewDeli Send a message via Skype™ to NewDeli
Great news, especially for discarding 1.6 series as the "stable branch" !

Quote:
Originally Posted by Toni Wilen View Post
and much more than ever before.. (probably bugs too..)
Hope you don't mean "more bugs in this release than ever before" .

Quote:
Originally Posted by antonvaltaz
Are there recommended specs for this version?
Problem is some Atom equipped laptop users manage to use WinUAE without any hassle (or so they say). Also, some settings (e.g. sound buffer set to 1) could cause a not CPU dependant performance penalty.
Should you create a thread to discuss this, I would surely post the minimal & recommended settings based on my own little experience.
NewDeli is offline  
Old 13 December 2009, 20:04   #10
Maren
Banned
 
Join Date: Jul 2009
Location: *
Posts: 567
What an arsekicker of a release
Maren is offline  
Old 13 December 2009, 20:22   #11
Kyon
Banned
 
Join Date: Dec 2008
Location: SOS Brigade
Age: 26
Posts: 696
Send a message via MSN to Kyon
i have a question this version better than 1.6.1 for playing swos ???
Kyon is offline  
Old 13 December 2009, 20:31   #12
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,278
In what way? Have you had problems when playing SWOS in WinUAE 1.6.1?
prowler is offline  
Old 13 December 2009, 21:01   #13
NewDeli
Banned
 
Join Date: Oct 2007
Location: Paris / FRANCE
Age: 44
Posts: 1,248
Send a message via ICQ to NewDeli Send a message via Skype™ to NewDeli
and there are at least 3 official versions of SWOS. Which version is infected... I mean affected when you run it with WinUAE v1.6.1 ?
NewDeli is offline  
Old 13 December 2009, 21:16   #14
Kyon
Banned
 
Join Date: Dec 2008
Location: SOS Brigade
Age: 26
Posts: 696
Send a message via MSN to Kyon
i dont know it @prowler because i dont see original amiga version 1:1
@Deleauvive i mean all versions
Kyon is offline  
Old 13 December 2009, 21:32   #15
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,278
Quote:
Originally Posted by Kyon View Post
@prowler because i dont see original amiga version 1:1
Have you downloaded WinUAE 2.0.0? If so, try it and see. If not, download it and then try it. (You're going to have to try it eventually, you know )

No-one else can test this for you. Your problem may be caused by your graphics card driver, for example.
prowler is offline  
Old 13 December 2009, 21:38   #16
Graham Humphrey
Global Moderator
Graham Humphrey's Avatar
 
Join Date: Jul 2004
Location: Norwich, Norfolk, UK
Age: 31
Posts: 10,974
Please take it to a new thread as well, thanks...
Graham Humphrey is offline  
Old 13 December 2009, 21:58   #17
Leffmann

 
Join Date: Jul 2008
Location: Sweden
Posts: 2,025
Thank you, Toni!
Leffmann is offline  
Old 13 December 2009, 22:11   #18
Kyon
Banned
 
Join Date: Dec 2008
Location: SOS Brigade
Age: 26
Posts: 696
Send a message via MSN to Kyon
sorry @GH
Kyon is offline  
Old 14 December 2009, 04:11   #19
rsn8887
Registered User
rsn8887's Avatar
 
Join Date: Oct 2006
Location: USA
Posts: 738

The master has struck again!
Thank you Toni!
rsn8887 is offline  
Old 14 December 2009, 09:05   #20
HOL2001
Amigamaniac

HOL2001's Avatar
 
Join Date: Mar 2005
Location: Neheim / Germany
Age: 44
Posts: 465
YESSSS!
HOL2001 is online now  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE 2.5.0 released Toni Wilen News 30 08 December 2012 19:48
WinUAE 1.4.3 Released! Avanze News 14 10 August 2007 09:42
WinUAE 1.3.4 released Paul News 11 02 January 2007 05:09
WinUAE 1.3.2 Released Avanze News 10 05 September 2006 22:08
New WinUAE Help released Paul News 3 02 January 2005 22:56

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:48.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.21799 seconds with 11 queries