English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > New to Emulation or Amiga scene

 
 
Thread Tools
Old 18 June 2009, 11:06   #1
SunChild
EAB Noobie

SunChild's Avatar
 
Join Date: Jun 2009
Location: Natori-shi, JAPAN
Age: 42
Posts: 117
Question ADZ files won't run (while ZIP ones do!)

Ok, while I'm not exactly /new/ to either the emul scene in general or the Amiga in particular, I figured my issue here is kinda too dumb and basic to post it elsewhere (although I swear I have checked both the board here and Googled a bit as well, to no avail).
Now I'm in fact expecting to feel quite ashamed once somebody on the board will most likely come up with the over-obvious answer to it , so here is:

I've recently reinstalled WinUAE (v1.6.0) on a brand new laptop (Intel Core2Duo, alas! running under Vista) and, just as my post title suggests, I can't seem to make any ADZ file to start! Which is weird as hell since WinUAE supports them natively, right?!

Now, for what I've already checked so far in trying to fix this:
- Renaming any of my ADZ files with a ZIP extension instead will fix the problem and let WinUAE load the disk image perfectly. So the problem is definitely with the extension not being recognized or sth...
- Clicked "Associate All" button under the "Priority & Extension" section to ensure that all related formats including adz were well registered to belong to WinUAE. (One strange thing though is that neither ADF nor ADZ files will get the WinUAE icon, although I verified that they are associated with the emulator all right)


Now, anyone please step forward and point out exactly what stupid obvious detail I might just have overlooked...!
Thx in advance as always.
SunChild is offline  
AdSense AdSense  
Old 18 June 2009, 13:28   #2
s2325
Zone Friend

s2325's Avatar
 
Join Date: Jun 2006
Location: Gargore
Age: 37
Posts: 17,650
ADZ it's file compressed with gzip, not zip. You need zlib.dll and zlib1.dll with older versions of WinUAE, I don't know if with newer too.
s2325 is online now  
Old 18 June 2009, 13:35   #3
TCD
Global Moderator

TCD's Avatar
 
Join Date: Sep 2006
Location: Germany
Age: 39
Posts: 24,032
You don't need them anymore s2325.
Do the .adz disks work when put in DF0: via the GUI? I also had the problem that without the file associations inside WinUAE .adz images wouldn't be 'mounted' when just associated via 'open with' in Windows. Setting the associations inside WinUAE fixed that for me.
TCD is offline  
Old 18 June 2009, 13:40   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,682
Probably some simple bug, unfortunately you are 1 day too late reporting it
Toni Wilen is offline  
Old 19 June 2009, 11:15   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,682
Should be already fixed in 1.6.1 (gzip issue).

If icons are incorrect AND associations are set in associations panel AND you have vista or newer AND not using installer: run winuae with administrative privileges (only once) to fix missing important registry entry related to associations.
Toni Wilen is offline  
Old 05 October 2010, 10:25   #6
s2325
Zone Friend

s2325's Avatar
 
Join Date: Jun 2006
Location: Gargore
Age: 37
Posts: 17,650
On Windows 2000 Pro zlib1.dll is not visible for WinUAE 0.8.25. I can not use newer version because I can not install DirectX 9
s2325 is online now  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to mount ADF / ADZ / DMS files using XFS Akira support.Apps 24 13 April 2015 21:42
What are ADZ files? Graham Humphrey New to Emulation or Amiga scene 3 11 April 2010 16:03
MIME type for .ADZ files on the Abime.net server eLowar project.EAB 1 16 September 2007 12:10
adz -> adf -> files staticgerbil support.Apps 12 06 November 2003 11:40
ADZ files birdy-scc support.WinUAE 20 25 September 2001 16:39

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 15:39.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.12277 seconds with 11 queries