English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 01 March 2009, 10:02   #1
olesio
Registered User
 
Join Date: Apr 2007
Location: Poland
Posts: 337
How to set polish catalog for EaglePlayer or other soft?

Hello.
I'm newbie in Amiga stuff user and use only WinUAE and emulation, so I ask about that
So how to set Eagle Player 2.03 to use polish catalog files and display texts in Polish or
how to use catalog files at all? I want to made hdf file with EaglePlayer - at this moment I
test whole thing on directory mounted as harddisk. So in root of harddisk I made directory
Locale/Catalogs/english and placed *.catalog files like EP_Engine.catalog ant others there
but when I run EaglePlayer it is still in english. How to make Eagle Player in Polish. I seen
in startup-sequence lines like bellow, but I leave language as English (default) so these 3
lines are ignored. Do I have to switch SetEnv Language "english" to "polish"? Or for catalog
files is no matter which language is set? As far I remember under Workbench 3.1 I swich a
language to Polish by setenv command and copy EP_*.catalog to Locale/Catalogs/polski,
but EaglePlayer was still in English. Please help and explain me how to do it right? T.I.A.

Code:
  IF NOT $Language EQ "english"
    CD LOCALE:Catalogs/$Language
    C:LoadResource Sys/workbench.catalog Sys/libs.catalog Sys/prefs.catalog Sys/commodities.catalog Sys/utilities.catalog
    CD SYS:
  EndIF
olesio is offline  
AdSense AdSense  
Old 01 March 2009, 16:06   #2
hit
Registered User
 
Join Date: Jun 2008
Location: planet earth
Posts: 1,115
hi,

i just grabed http://www3.uk.freebsd.org/mus/play/EP_Polski.lha and found an Install script inside. this seems to copy the whole "Catalogs" folder into "Eagleplayer2:" if it exists. Then i found a LOCALE tooltype in Eagleplayer.
so i would open the icon information window (on the workbench) of Eagleplayer and set the Tooltype "LOCALE" to "Polski".
not tested but i hope this helps a bit.
hit is offline  
Old 01 March 2009, 18:02   #3
olesio
Registered User
 
Join Date: Apr 2007
Location: Poland
Posts: 337
I have the same files in Catalogs/Polski and I added tooltype LOCALE="Polski" to icon in Workbench
Informations Dialog, but EaglePlayer still runs in english. What do I wrong? Any other ideas? T.i.A.
olesio is offline  
Old 01 March 2009, 19:43   #4
hit
Registered User
 
Join Date: Jun 2008
Location: planet earth
Posts: 1,115
hmm, seems i was wrong. i run it in winuae (a2000 setup) using snoopdos, and there is no such tooltype "LOCALE". no "LANGUAGE" or anything related.
it seems it tries to load the language catalog of the default system-language.
Eagleplayer looks for its cataloge files in:
LOCALE:Catalogs/polski/EP....
PROGDIR:Catalogs/polski/EP...

if you set your system Default Lnaguage to Polski, it should fin the catalog files inside the Eagleplayer folder. i was using this version: http://www3.uk.freebsd.org/mus/play/...layer_2.03.lha (keyfile is also on that page: http://www3.uk.freebsd.org/mus/play/Eagleplayer_key.lha )
i have no clue whats wrong :/
hit is offline  
Old 01 March 2009, 21:59   #5
olesio
Registered User
 
Join Date: Apr 2007
Location: Poland
Posts: 337
Problem solved. Polish locale works fine under pure WB and DeathMieszko's partition also
and I do not have idea what files was corrupted or missed but I donwloaded once again lha
from aminet with whole player, copy configs and players from backup and all works fine
Thanks for all answers and hints. And moderators can remove/close this topic if they want.

Last edited by olesio; 01 March 2009 at 22:37.
olesio is offline  
Old 02 March 2009, 11:48   #6
hit
Registered User
 
Join Date: Jun 2008
Location: planet earth
Posts: 1,115
some magic seems sometimes involved, i'd say
hit is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
EaglePlayer V2.04 as final? Promax request.Apps 1 18 August 2010 01:22
EaglePlayer DyLucke request.Apps 2 27 December 2009 14:15
EaglePlayer under WinUAE Another World New to Emulation or Amiga scene 27 13 December 2008 13:08
corrupted quartarback catalog trnepalla support.Apps 2 22 May 2006 00:45
Eagleplayer now GPL Frog News 11 15 June 2005 15:07

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:42.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.15531 seconds with 11 queries