English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 17 August 2008, 18:30   #1
Marcuz
Wurk???
Marcuz's Avatar
 
Join Date: Jun 2002
Location: .
Age: 41
Posts: 5,170
General OS3.9 Questions

i have some questions, not completely ClassicWB related only, but to Workbech at large.
i have tested the last beta and it seems to work very fine for the rest.

1) why only a bunch of fonts among the many more bitmaps in the font directory are available to set in the preferences?

2) how do you force the workbench' window listing to use Z3 or Fast Mem instead of chip one? (useful for large directories)

3) is there a way in OS3.9 to create a link or clone of a program icon in the workbench window without to use "leave out"/"put away" so to keep one in the program directory?

4) some action in DirOpus, namely, SHOW, seems to work no more with fonts, (if i have not made some mess myself with the configuration files) is that correct?

5) on OS3.9 is there a way to display a clock in the workbench bar and maybe a custom text, like in Scalos?

thank you for the cool work Bloodwych!
Marcuz is offline  
AdSense AdSense  
Old 17 August 2008, 23:56   #2
Bloodwych
Moderator

Bloodwych's Avatar
 
Join Date: Jun 2001
Location: I'm behind you!
Posts: 3,763
Hi Marco, I'll try and answer but some require more research and are probably better off in their own thread.
  1. Iím not sure what you mean by this.
  2. In the normal ClassicWB packs, Scalos seems more efficient at window list/text formats using fastram, and FBlit is there for NewIcons/graphics to fastram. OS39 obviously has Scalos removed and Iíve tried my best to replace the missing features but it does seem to have some memory quirks and is less efficient in some areas. I need to consult with OS39 experts and see if I'm missing any patches/tools. It is also using FBlit (and FText) and is set up to shift icons/graphics to fastram (which works fine), but as you say switching to the list/text view seems to eat up chipram. Not sure why?
  3. You could just select the program icon, right click and select ďicons->copyĒ. This will create a ďcopy_of_Ē the program and icon. Then leave it out. You canít name it the same as the original however, as it remains physically in the same drawer even if itís left out. Not ideal, I know, and it might create problems. All "leave out" does is create an entry in the .backdrop file so Workbench knows to show it on the desktop and hide it in the programís directory.
  4. Iíve never changed most the default Dopus buttons and Show is one of those default built in commands. I mainly only added new buttons and features. I never really use it, and not aware that it ever did work with fonts.
  5. Again this is going back to me trying to find replacements for Scalos features. Iím sure there is a utility that does this, but canít remember off hand. As for the time, there is a nice calendar/clock utility thatís used in AmiKit and AmigaSYS but I donít know what itís called. I'm not sure if one exists that adds time to the actual bar like Scalos.
Bloodwych is offline  
Old 18 August 2008, 01:29   #3
Marcuz
Wurk???
Marcuz's Avatar
 
Join Date: Jun 2002
Location: .
Age: 41
Posts: 5,170
the font issue is not tied to OS3.9: i don't know why, but as i recall, in every version of Workbench, only some of the fonts in the fonts directory, albeit in the same format as the other do show up for use in the font panel of Prefs.

i asume that for some, like system text, some attribute of the typeface, like size, should be considered, but for the icons in .backdrop that's strange. i don't know if there's some setting to be touched.

in DirOpus, the previous versions of ClassicWB DO show the typefaces. but it's not a problem that, i will just have to check if i've broken something in the current one, which i probably did

about the ram issue: does it makes a difference about fast ram and z3 fast ram?

[edit] @ Global Mod please do remove the last posts to a thread of their own, if you like, i posted it here and only after typed it all, i've doubted it was pertinent... thank you!
Marcuz is offline  
Old 18 August 2008, 10:00   #4
Graham Humphrey
Moderator
Graham Humphrey's Avatar
 
Join Date: Jul 2004
Location: Norwich, Norfolk, UK
Age: 30
Posts: 10,932
As you wish Marco

I hope I've put this in the right place...?
Graham Humphrey is offline  
Old 18 August 2008, 10:42   #5
Marcuz
Wurk???
Marcuz's Avatar
 
Join Date: Jun 2002
Location: .
Age: 41
Posts: 5,170
thank you Graham
Marcuz is offline  
Old 19 August 2008, 21:52   #6
twizzle
Registered User
twizzle's Avatar
 
Join Date: Sep 2005
Location: taunton.som.uk
Age: 66
Posts: 681
the wb bar clock that you need is called title clock

i found it on an early af cd ???
there are later versions,but for some reason this didnt work as well on my os3.5 sys
twizzle is offline  
Old 19 August 2008, 21:59   #7
Marcuz
Wurk???
Marcuz's Avatar
 
Join Date: Jun 2002
Location: .
Age: 41
Posts: 5,170
cool thank you i will look for it!
Marcuz is offline  
Old 25 August 2008, 10:35   #8
Marcuz
Wurk???
Marcuz's Avatar
 
Join Date: Jun 2002
Location: .
Age: 41
Posts: 5,170
dou you know what's the program that adds an amiga ball on the title bar?
Marcuz is offline  
Old 05 September 2008, 09:17   #9
marcfrick2112
Registered User
 
Join Date: Apr 2008
Location: Milwaukee, WI USA
Posts: 132
Marco: I think the program to add the Amiga ball is either AmiLogo, or AmiBoing.. possibly both Aminet has them.
marcfrick2112 is offline  
Old 05 September 2008, 11:29   #10
Marcuz
Wurk???
Marcuz's Avatar
 
Join Date: Jun 2002
Location: .
Age: 41
Posts: 5,170
hey marcfrick2112 thank you! i will download both of them and test my new ClassicWB in the weekend!
Marcuz is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Please help a n00b with some general questions devnull support.Hardware 4 13 July 2012 03:32
general questions about assembler Joe Maroni Coders. General 8 10 November 2010 12:39
General GBA questions made project.MAGE 0 27 March 2009 16:24
A few general Amiga questions. Hougham support.Hardware 6 30 April 2008 22:13
Some general newbie questions Pixel New to Emulation or Amiga scene 10 14 March 2002 18:35

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:40.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.16349 seconds with 11 queries