English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 26 October 2007, 17:49   #1
laser
Banned
 
Join Date: Aug 2006
Location: Argentina
Age: 44
Posts: 648
kick 1.2 VS Kick 1.3 for A500'games compatibility

After I tested games like one on one,archon and archon 2.....that games works only on kick 1.2 for unknown reasons......I changed my own basic A500 config file on winuae to use kickstart 1.2 instead kick 1.3

thread aboout this here:

http://eab.abime.net/showthread.php?...ghlight=archon


OK

kick 1.2 seems to be more compatible for A500'games...at least I can't found a game that not works on kick 1.2 but works on kick 1.3

so...it seems that kick 1.2 is the best solution for the Amiga 500 or a winuae' A500 config

Im right?

or

anyone knows a game that doesn't work on kick 1.2 but works on kick 1.3 ?

Last edited by laser; 26 October 2007 at 18:02.
laser is offline  
AdSense AdSense  
Old 26 October 2007, 18:20   #2
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 45
Posts: 10,628
Use Kickstart 1.2 for some really old games from the mid 80s, like Marble Madness, One-on-One, Archon, Seven Cities of Gold etc.

Most of the A500 games from 1987/88 - 199x works fine with Kickstart 1.3.
Retro-Nerd is offline  
Old 26 October 2007, 18:35   #3
laser
Banned
 
Join Date: Aug 2006
Location: Argentina
Age: 44
Posts: 648
Quote:
Originally Posted by Retro-Nerd View Post
Use Kickstart 1.2 for some really old games from the mid 80s, like Marble Madness, One-on-One, Archon, Seven Cities of Gold etc.

Most of the A500 games from 1987/88 - 199x works fine with Kickstart 1.3.
yes..I know that....but it seems that the best kickstart for all A500'games ...old or not so old is kick 1.2

or you know a game from 1987/88 - 199x that doesn't work on kick1.2 ?
laser is offline  
Old 26 October 2007, 18:47   #4
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 45
Posts: 10,628
Quote:
Originally Posted by laser View Post
or you know a game from 1987/88 - 199x that doesn't work on kick1.2 ?
I can't remember a specific game, because i've got my first A500 in 1989 with KS 1.3. But there are probably enough games, which works with Kickstart 1.3 only. Mosty games from the 90s iirc.
Retro-Nerd is offline  
Old 26 October 2007, 19:12   #5
laser
Banned
 
Join Date: Aug 2006
Location: Argentina
Age: 44
Posts: 648
Quote:
Originally Posted by Retro-Nerd View Post
I can't remember a specific game, because i've got my first A500 in 1989 with KS 1.3. But there are probably enough games, which works with Kickstart 1.3 only. Mosty games from the 90s iirc.
don't believe that there are probably enough games, which works with Kickstart 1.3 only and fail on kick 1.2

found one and I will make you a granite' statue



there are tons of A500 withh kick 1.2.....games' developers tend to maintain certain backward compatibility
laser is offline  
Old 26 October 2007, 19:34   #6
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 45
Posts: 10,628
This is not too hard. Try DeluxeGalaga. This one needs at least KS 2.04.
Retro-Nerd is offline  
Old 26 October 2007, 19:45   #7
laser
Banned
 
Join Date: Aug 2006
Location: Argentina
Age: 44
Posts: 648
Quote:
Originally Posted by Retro-Nerd View Post
This is not too hard. Try DeluxeGalaga. This one needs at least KS 2.04.
ah....but that's another thing....also I know that turbotrax and dracula requires kick 2.0+

the thing here is between kick 1.2 & 1.3
laser is offline  
Old 26 October 2007, 20:18   #8
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,535
1.3 is THE Kickstart everyone expects and knows. It won't be changed.
Toni Wilen is online now  
Old 26 October 2007, 20:40   #9
laser
Banned
 
Join Date: Aug 2006
Location: Argentina
Age: 44
Posts: 648
Quote:
Originally Posted by Toni Wilen View Post
1.3 is THE Kickstart everyone expects and knows. It won't be changed.
you are the expert but...I don't care about everyone expects and knows

I always used kick 1.3 but now I use kick 1.2 because is most compatible with games

just changed my opinion a few days ago and I don't expect a revolution on the amiga'scene about this

btw,

Now I offer a Ferrari as reward to found a game that fail on kick1.2 but works on kick.13

laser is offline  
Old 26 October 2007, 22:24   #10
samklein
Registered User
samklein's Avatar
 
Join Date: May 2007
Location: Novo Hamburgo/Brazil
Age: 45
Posts: 33
Send a message via MSN to samklein
Don´t forget murphy! He used to show up when you don´t expect.. uheuhee
samklein is offline  
Old 26 October 2007, 22:47   #11
woody.cool
Registered User
woody.cool's Avatar
 
Join Date: Oct 2006
Location: Northampton, England
Age: 34
Posts: 118
All the early EA demos released in the early days of the Amiga require Kick 1.2 but don't work correctly on 1.3

The very first couple of demos that existed on the Amiga (including the EA special demo that allegedly 'only works on an A1000') don't even work with 1.2 and only work with Kick 1.0 and 1.1
woody.cool is offline  
Old 26 October 2007, 23:13   #12
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 40
Posts: 8,984
From the 450+ games I've configured a year or so ago, 95% of all OCS / ECS games work perfectly with Kickstart v1.3... There are only a very small minority that don't
DamienD is offline  
Old 26 October 2007, 23:50   #13
DrF
Blessed A1200 Of TeH Rat
DrF's Avatar
 
Join Date: Aug 2007
Location: Bham, UK
Age: 35
Posts: 497
I don't think theres a need for anything under 1.3, on a emulator you can have you pick of Kickstart Roms, but I would not run a real Amiga with anything less than KS2, I guess it depends what you want

I think theres a crap load of games that won't run on KS2 though, weather this is down to KS2, RAM configuration, chipsets I never knew.
DrF is offline  
Old 27 October 2007, 00:10   #14
laser
Banned
 
Join Date: Aug 2006
Location: Argentina
Age: 44
Posts: 648
bla bla bla...but it seems until now that kick 1.2 it's better and more compatible for games than kick 1.3

anyways I will wait if somebody found a valid argument to convince me to return to kickstart 1.3

come on guys...nobody wants to be a pharaoh?....nobody wanna ride a Ferrari?
laser is offline  
Old 27 October 2007, 01:02   #15
BippyM
Global Moderator

BippyM's Avatar
 
Join Date: Nov 2001
Location: Nottingham, UK
Age: 42
Posts: 8,544
does it matter? really?
BippyM is offline  
Old 27 October 2007, 01:06   #16
Graham Humphrey
Moderator
Graham Humphrey's Avatar
 
Join Date: Jul 2004
Location: Norwich, Norfolk, UK
Age: 30
Posts: 10,906
I wouldn't have thought so but obviously it does to some people
Graham Humphrey is offline  
Old 27 October 2007, 01:07   #17
Nogg
Registered User
Nogg's Avatar
 
Join Date: Sep 2007
Location: Sweden
Posts: 22
Dune II?
Nogg is offline  
Old 27 October 2007, 01:08   #18
BippyM
Global Moderator

BippyM's Avatar
 
Join Date: Nov 2001
Location: Nottingham, UK
Age: 42
Posts: 8,544
lemme yawn
BippyM is offline  
Old 27 October 2007, 01:26   #19
andreas
Zone Friend
 
Join Date: Jun 2001
Location: Germany
Age: 43
Posts: 5,858
Send a message via ICQ to andreas Send a message via AIM to andreas
Quote:
Originally Posted by laser View Post
kick 1.2 seems to be more compatible for A500'games...at least I can't found a game that not works on kick 1.2 but works on kick 1.3
Neither can I (for now).

However how about a game that does not work on either 1.2 or 1.3, but 1.1 only?
The game is not much known and rare as an original: I have already mentioned it in a related thread 4 years ago: it's Quintette!

FWIW ...
andreas is offline  
Old 27 October 2007, 01:38   #20
Paul_s
needs more ice cream

Paul_s's Avatar
 
Join Date: Nov 2006
Location: Amigaville
Age: 39
Posts: 3,161
Quote:
Originally Posted by DrF View Post
I don't think theres a need for anything under 1.3, on a emulator you can have you pick of Kickstart Roms, but I would not run a real Amiga with anything less than KS2, I guess it depends what you want

I think theres a crap load of games that won't run on KS2 though, weather this is down to KS2, RAM configuration, chipsets I never knew.

It's mainly down to the chipset as well. I well remember the aggro caused when the Full ECS chipset was launched.. a load of games never ran on that until they were patched.

Even relokick wouldn't run some of my older games on my 1200 iirc. Although that's going years back..

1.3 KS fixes a lot of bugs over 1.2 anyway so I'd stick with 1.3...
Paul_s is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Whdload on A500+ kick 1.3 sidchip_fr project.WHDLoad 8 16 July 2010 22:05
A500 kick 1.3 in A600..? 8bitbubsy support.Hardware 14 02 November 2009 23:10
Kick Off games vs SensibleSoccer games JudasEZT Retrogaming General Discussion 65 04 June 2004 11:00
How to reboot into kick 2.0 using kick 1.3 as_frigg New to Emulation or Amiga scene 2 04 September 2002 10:03
Kick Off 2 or should that be Kick Off 2002 dannyd Nostalgia & memories 0 31 January 2002 01:27

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:50.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.21672 seconds with 11 queries