English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 10 May 2001, 00:05   #1
LaundroMat
Junior Member
LaundroMat's Avatar
 
Join Date: Apr 2001
Location: In the cellar. With your mum.
Age: 42
Posts: 404
Installing amitcp

Hi there,

I've just been trying to set up a system with WinUAE and the "Amiga in a box" tools (which has saved me a lot of time), and ofcourse I'd like to access the internet with my emulated Amiga.

I've downloaded the AmiTCP package from Aminet (v22), but when trying to install it, the install script produced an error. I chose to ignore the error (never a good thing), and then I got an OS error (you know, where all the processor registry data is listed), upon which I had to freeze the Install app.

Has anyone tried to install a fully functional TCP/IP stack? If AmiTCP is no good (which would surprise me), what else is?

tia.
LaundroMat is offline  
AdSense AdSense  
Old 10 May 2001, 00:10   #2
Akira
Registered User

Akira's Avatar
 
Join Date: May 2001
Location: New York
Posts: 17,946
Hey!

No need to run AmiTCP (and even if you needed to run a stack, AmiTCP would be the last one I'd use).

WinUAE's bsdsocket.library emulation will let you use your PC's internet connection. This means:

- Connect the PC
- Launch WinUAE
- You've got an emulated Amiga with full TCP/IP access

Every network service you have access to with the PC, will be accessible too thru the Amiga.

If you had to install a stack in a real Amiga, I wouldn't even use AmiTCP. I'd use Miami which is fast, friendly and very cool.
Akira is offline  
Old 10 May 2001, 09:57   #3
LaundroMat
Junior Member
LaundroMat's Avatar
 
Join Date: Apr 2001
Location: In the cellar. With your mum.
Age: 42
Posts: 404
Didn't know about UAE inet connection

Ah, that's good of those friendly UAE people.

The reason why I try to install a TCP/IP stack however, is that Voyager, AmIRC or any other inet related doesn't start up correctly. SnoopDos reports no errors, and the last action is a dir change to SYS: (which means the app has launched correctly).

Anyway, I'll fiddle with it a bit more tonight.
LaundroMat is offline  
Old 10 May 2001, 18:44   #4
Akira
Registered User

Akira's Avatar
 
Join Date: May 2001
Location: New York
Posts: 17,946
Well, I remember using them perfectly (they came with AIAB too). Something must be misconfigured, or something. Just UNINSTALL AmiTCP, whatever you have installed of it. It just will confuse the system.

Have you checked that you have bsdsocket.library emulation enabled? It's an option in one of the WinUAE menus. Make sure it is ticked.
Akira is offline  
Old 10 May 2001, 20:21   #5
Jambo
Yarr!
 
Join Date: Mar 2001
Location: n. A place where something is or could be located; a site.
Age: 42
Posts: 112
The non-startup of some programs in the latest AIAB is a know bug.

Make sure, though, that you tick the 'BSD socket library emulation' box on the MISC tab of WinUAE, if that already is ticket then you can have a look at the AIAB forum (http://aiab.emuunlim.com/bin/wwwboard) and hopefully you will find an answer there (I know it WAS posted there, but James has deleted some of the older posts), I think it had something to do with James using the newer JIT version of AIAB, and setting it up with that version in mind, post a message on the board if you can't find the answer.

Hope this helped!

**UPDATE** Looks like you'll just have to wait for the JIT version of WinUAE, read http://aiab.emuunlim.com/bin/wwwboard/messages/357.html **

Thanks
James Thomas
Jambo is offline  
Old 11 May 2001, 10:07   #6
LaundroMat
Junior Member
LaundroMat's Avatar
 
Join Date: Apr 2001
Location: In the cellar. With your mum.
Age: 42
Posts: 404
Thanks

Thanks for the info. I'll keep an eye on the forums.

Anyway, the Internet connection is not that important, but it could've been interesting. I'll wait, as a true Amigan is used to do

And I'll hook up my A1200 again, to play Ruff 'n Rumble anyway. w00t! I really can't wait till tonight. lol.
LaundroMat is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with installing AmiTCP/IP emuola project.ClassicWB 40 27 March 2014 03:34
amitcp/ip lambrettadave support.Hardware 1 21 October 2010 16:42
Amitcp Pentangle request.Apps 2 07 May 2008 09:03
AmiTCP DDNI support.Apps 4 07 April 2006 12:11
AmiTCP/IP questions Fackamato support.Apps 0 03 October 2004 16:36

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:31.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.14158 seconds with 11 queries