English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 19 April 2007, 06:47   #1
xenepp
Registered User
 
Join Date: Sep 2006
Location: Rochester, UK
Posts: 23
Kick up/500+ emulator?

I have an A500 but need to kick it up to a 500+

When I was young and had an A500, I swear I used Relokick to do this, but it's my understanding this will downgrade, was there a version that did what I need?

Also, I have tried using Kickfile but that runs out of memory. I have a 512mb upgrade in the back of my A500, is this the total RAM I have? Do I need to try and locate a 1mb upgrade instead?

Cheers folks!

-Joel
xenepp is offline  
AdSense AdSense  
Old 19 April 2007, 06:55   #2
s2325
Zone Friend

s2325's Avatar
 
Join Date: Jun 2006
Location: Gargore
Age: 34
Posts: 13,743
512mb?
s2325 is online now  
Old 19 April 2007, 07:56   #3
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 34
Posts: 4,521
Send a message via MSN to Jope Send a message via Skype™ to Jope
So what you want is basically to run kickstart 2.04 on your A500 and forget the other A500+ enhancements?

Softkicking is the word here and it'll eat up 512kB of your ram. Take a look at skick and mkick on aminet.
Jope is online now  
Old 22 April 2007, 10:01   #4
xenepp
Registered User
 
Join Date: Sep 2006
Location: Rochester, UK
Posts: 23
Erm, yes, 512kb, not mb

I have tried a variety of softkickers but it seems I don't have enough RAM. It's my understanding that the A500 had 512kb built in and the 501 512kb upgrade gave it 1mb total RAM, correct?

I'm getting conflicting software reports on this though.

Pinball Fantasies detects the extra RAM and lets me know everything's ok, where as Alien Breed will tell me it can only find 512kb. Now does this mean my 501 RAM pack is on the fritz or am I missing something?

But yeah I just wanted to use the softkick so I can use 500+ only software. I'd get a 2.04 ROM and a ROM selector but I've no idea where to get them.

-Joel
xenepp is offline  
Old 22 April 2007, 10:43   #5
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 34
Posts: 4,521
Send a message via MSN to Jope Send a message via Skype™ to Jope
2.05 roms can be bought from:
Vesalia
Amigakit

Kickswitchers aren't available new, but there are plans on Aminet on how to build your own.

Regarding the 512kB mem expansion, boot up workbench, open CLI/Shell and type in avail.. That'll tell you how much RAM the OS detected.
Jope is online now  
Old 22 April 2007, 17:26   #6
T_hairy_bootson
Workbitch 1.3

T_hairy_bootson's Avatar
 
Join Date: Oct 2001
Location: Melbourne, Australia
Age: 37
Posts: 2,003
what software requires kickstart 2.XX?

I only know of a particular version of deluxe galaga.
T_hairy_bootson is offline  
Old 22 April 2007, 21:24   #7
amigarobbo
Registered User
amigarobbo's Avatar
 
Join Date: Mar 2007
Location: UK
Posts: 182
I've got a 2.04 (could be 2.05 Rom?) taken out of A600, is that any good to you?
amigarobbo is offline  
Old 23 April 2007, 03:59   #8
xenepp
Registered User
 
Join Date: Sep 2006
Location: Rochester, UK
Posts: 23
To be honest, I've found an A500+ locally today so I'll probably just use it in tandem with my A500 but thanks for the offer amigarobbo!

There were numerous games that only worked with the 500+ and most importantly, Workbench 2. At least that's what I found back in the day.

-Joel
xenepp is offline  
Old 23 April 2007, 05:34   #9
T_hairy_bootson
Workbitch 1.3

T_hairy_bootson's Avatar
 
Join Date: Oct 2001
Location: Melbourne, Australia
Age: 37
Posts: 2,003
Quote:
Originally Posted by xenepp
To be honest, I've found an A500+ locally today so I'll probably just use it in tandem with my A500 but thanks for the offer amigarobbo!

There were numerous games that only worked with the 500+ and most importantly, Workbench 2. At least that's what I found back in the day.

-Joel
Besides public domain and actual software I think you will be struggling to find many commercial games that require kickstart 2.XX.
T_hairy_bootson is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why would an Amiga 500 need Kick 3.1? Kitty support.Hardware 18 19 October 2009 09:14
Test of MPDOS (Amiga 500 Floppy Emulator) StoneOakvalley support.Hardware 6 02 February 2009 09:33
kick 1.2 VS Kick 1.3 for A500'games compatibility laser support.WinUAE 27 31 October 2007 00:32
WTB: Amiga 500 floppy drive, Kick 2.04 and Rom Selector xenepp MarketPlace 0 14 April 2007 19:42
c64 emulator for amiga 500 _ThEcRoW Amiga scene 33 13 July 2005 19:10

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 19:10.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Page generated in 0.15764 seconds with 11 queries