English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 05 November 2006, 01:59   #1
Raqoon
 
Posts: n/a
CrossDos help needed

I recently aquired an Amiga 2000, but I am having a few problems...maybe someone here can help with this...

Computer is the following:

Amiga 2000, 4.5 Motherboard
8 megs ram
2 800k floppies
Amigen Genlock
System 2.1

Intalled with:
Broadcast Titler
Scala MM300 (with the dongle)

Problems:

No mouse - this is a real pain in the neck to try to use this without one...currently doing the keyboard method but its very frustrating as the arrow doesn't move very fast....any way to get it to go a bit faster until I can find a mouse somewhere for it?

No monitor - All I get is black and white out of the video output, and the Genlock has no breakout cable...I found the pinouts, but from what I'm seeing, it is only outputting black and white as well

No terminal software - I can't connect to anything else to get software into the machine because there's no communications program installed that I can find.

CrossDos won't work - I can't get CrossDos to work. Putting in an 700 K PC disk gives you FD1:???? or FD0???? I've checked the devs folder and there is a PC0: in there, I also copied over a folder called DOSDrivers which contains PC1 PC0 AUX and RAD, but this makes no difference. WHen you attempt to mount PC0: you get an error saying that it is an unknown device

My best bet I think would be to get crossdos working, so I can get some other software in there. Any ideas what I'm doing wrong?

I have no system disks for this computer, all I have is what is in the hard drive right now.
 
AdSense AdSense  
Old 05 November 2006, 09:23   #2
TikTok
Registered User

TikTok's Avatar
 
Join Date: Jul 2001
Location: Malayasia
Age: 37
Posts: 657
This is from the top of my head since I don't have an Amiga or WinUAE handy right now.

If you are using Workbench 2, the DOSDrivers directory will be no use to you. DOSDrivers directory is only used by Workbench 2.1 and above. You need to add an entry for PC0 into your mountlist file (in devs directory IIRC). Basically you effectively copy the contents of DOSDrivers/PC0 (which is a text file) to the bottom of your mountlist. There is one line you need to remove when copying this IIRC.

You should also have mfm.device in devs and CrossDOSFileSystem in L.
TikTok is offline  
Old 05 November 2006, 09:46   #3
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 37
Posts: 6,267
Send a message via Skype™ to Jope
Hold down shift along with Amiga when moving the mouse pointer.

You are probably missing mfm.device? The dosdriver alone will not help unless you have a suitable filesystem and device driver. Look at the dosdriver to see what it uses.

RAmiga-E
newcli[enter]
type devs:dosdrivers/pc0[enter]
[read and understand]
endcli[enter]
Jope is offline  
Old 05 November 2006, 13:09   #4
snarkhunter
Registered User
snarkhunter's Avatar
 
Join Date: Nov 2005
Location: France
Age: 52
Posts: 79
You should be able to order a mouse from the following web site :

http://www.vesalia.de/?V02b0f1452554...8246661592b626

I did get two mice from them myself, a couple of years ago. Not the same brand as the currently available ones, but I guess these should be ok too...


sh

Last edited by snarkhunter; 05 November 2006 at 13:20.
snarkhunter is offline  
Old 05 November 2006, 23:38   #5
Raqoon
 
Posts: n/a
Thanks for the replies,

I took a look at the mountlist, and there was no entries for PC0 and PC1 so I've added those, however, I'm missing the mfm.device and the CrossDosFileSystem in L. I can't seem to find these anywhere on the computer either, so its looking like I'm stuck again.

I'll look into getting one of those new mice if I can't find something local (and I can get around this somehow)

I also hooked in a SCSI CD ROM, the machine knows its there, but doesn't know what to do with it, so its not much use right now.

Is there any kind of terminal program that might be in the system that I'm overlooking? Looks like that might be the only way right now.

and thankyou for the mouse/keyboard tip...thats way faster and easier
 
Old 09 November 2006, 19:08   #6
alewis
Monochrome and 8 bit

 
Join Date: Nov 2004
Location: Underbarrow, Gods Country
Age: 51
Posts: 587
The mfm.device doesnt have an icon, open the window and do a Show All Files from the, erm, top menu
alewis is offline  
Old 10 November 2006, 07:10   #7
Raqoon
 
Posts: n/a
>You should also have mfm.device in devs and CrossDOSFileSystem in L.

Is there anywhere I can download these two files?

I did find a terminal program in the Amiga, so with some fiddling I think I can get two dialup modems to connect to each other (or I'll have to dial in from the amiga to another machine somewhere else) and download them in that way. Once they are in there I can read DOS disks and this won't be a problem anymore. (I can't use a null modem cable because only one computer store nearby sells these and they want $35 for it!)

Would someone be able to email me working CrossDos files?

Please?
 
Old 10 November 2006, 14:32   #8
TikTok
Registered User

TikTok's Avatar
 
Join Date: Jul 2001
Location: Malayasia
Age: 37
Posts: 657
You could also try one of the several free CrossDOS style programs available on Aminet (www.aminet.net). I can't remember any names from the top of my head but there are a couple of popular ones.
TikTok is offline  
Old 10 November 2006, 15:08   #9
ppill
CON: artist
ppill's Avatar
 
Join Date: Feb 2006
Location: Poland
Age: 36
Posts: 1,157
Send a message via Skype™ to ppill
Fat95 is one of those and available on aminet. Here's the link http://aminet.net/search.php?query=fat95.
ppill is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Do I have CrossDOS? mancity support.Apps 28 02 January 2013 22:25
CrossDos omnigate support.Apps 2 07 August 2011 23:35
CrossDos Stigodump New to Emulation or Amiga scene 4 22 July 2005 08:04
CrossDOS (again) witchmaster support.Apps 10 11 June 2005 15:11
CrossDos leongt request.Apps 12 08 October 2003 03:52

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 22:46.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.15279 seconds with 11 queries