English Amiga Board


Go Back   English Amiga Board > Other Projects > project.WHDLoad

 
 
Thread Tools
Old 18 September 2005, 17:10   #1
MheAd
Registered User
MheAd's Avatar
 
Join Date: Jun 2003
Location: Stockholm
Posts: 59
In-game interruptions while harddrive is loading

Hi!
I'm pretty new with this WHDLoad thing, but I've figured out how to use it.
I've even sucessfully managed to install a game myself (Elvira) using the patch from whdload.de.
I have a question though.

In all games that I've played so far, including my own install of Elvira, when harddrive is accessing information, the picture becomes black for split of second and even the sound disapears. This is very annoying, especially during adventure games (Elvira, in this case) where disk is being accessed basically frequently (every time after moving through couple of locations in game).

My question is whether this is normal? Is it maybe due the fact that I'm not using registered version of WHDLoad or is this likely to happen either way?

Thanks in advance!
MheAd is offline  
AdSense AdSense  
Old 18 September 2005, 21:15   #2
mr_a500
Amiga-based Cyborg
mr_a500's Avatar
 
Join Date: Dec 2004
Location: Canada
Posts: 786
This bothers me too, but in your case I think you can avoid it with the tooltype "PRELOAD". With this tooltype, the entire game will be loaded into memory so it doesn't have to access the HD during play. (except for highscore/game saves)

I was a bit annoyed when loading a saved game in Dune II - it would flicker about 20 times.

My main problem though is with the Kick1.3 ("emulating" WB1.3 from 3.1). It used to flicker a few times if I saved something, but now it flickers about 50 times when loading and whenever I open a folder! I don't know why it would get worse.
mr_a500 is offline  
Old 18 September 2005, 22:01   #3
MheAd
Registered User
MheAd's Avatar
 
Join Date: Jun 2003
Location: Stockholm
Posts: 59
Please explain what you mean by this "tooltype" - thing, whatever that means.
Thanks in advance!
MheAd is offline  
Old 19 September 2005, 00:52   #4
mr_a500
Amiga-based Cyborg
mr_a500's Avatar
 
Join Date: Dec 2004
Location: Canada
Posts: 786
Wow, you are new - tooltype is a pretty basic Amiga OS thing.

Tooltypes are like the icon equivalent of command line options. You can add or remove these options and they are saved in the icon.

To edit tooltypes, select an icon and select Icons>Information... from the Workbench menu.

You should check the EAB FAQ and other Workbench help documents for more information on how to use Workbench.
mr_a500 is offline  
Old 19 September 2005, 09:45   #5
MheAd
Registered User
MheAd's Avatar
 
Join Date: Jun 2003
Location: Stockholm
Posts: 59
Believe it or not, I'm not an Amiga newbie - but I've not been messing with anything inside WB for like 11 years or something...
So could you just be kind and tell me the command lines for preloading this game, and I'll figure out how to create a tootype myself...

Thanks in advance!
MheAd is offline  
Old 19 September 2005, 13:29   #6
dlfrsilver
CaptainM68K-SPS France
dlfrsilver's Avatar
 
Join Date: Dec 2004
Location: Melun nearby Paris/France
Age: 41
Posts: 7,487
Send a message via MSN to dlfrsilver
left clic the game icon, clic on ADD to add the tooltype and type on the right :
PRELOAD
NOCACHES
NOMMU

and save !!! now launch your game ^^
dlfrsilver is offline  
Old 19 September 2005, 15:24   #7
MheAd
Registered User
MheAd's Avatar
 
Join Date: Jun 2003
Location: Stockholm
Posts: 59
Thank you!
Now it works with no problems whatsoever!
MheAd is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Black screen but game is still loading? pekr support.FS-UAE 9 04 February 2013 17:31
Issue loading game wozza support.FS-UAE 3 20 January 2013 02:47
C64 game, US flag loading screen StarEye Looking for a game name ? 15 21 June 2006 21:43
Problems with WHD game loading speeds MethodGit support.WinUAE 1 21 March 2003 00:00
Game Loading Superstition ! xamigax support.Games 7 03 May 2002 14:38

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:08.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.07272 seconds with 12 queries