English Amiga Board


Go Back   English Amiga Board > Main > Amiga scene

 
 
Thread Tools
Old 02 October 2007, 06:19   #21
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,735
Quote:
Originally Posted by Stokey View Post
OS 3.5 and 3.9 have the following lines in the Startup-Sequence:

C:RemLibrary icon.library
C:RemLibrary workbench.library

If these are still there that may be why icon.library isn't resident.
Sorry, but I've never seen "RemLibrary" yet, neither in "C:" nor in the
startup-sequence of OS 3.9.

Anyway, the icon.library can indeed successfully loaded resident from the
ROM if you simply remove it from the Libs: drawer first. Tested it last year!
PeterK is offline  
AdSense AdSense  
Old 02 October 2007, 10:38   #22
Mad-Matt
Longplayer

Mad-Matt's Avatar
 
Join Date: Jan 2005
Location: Lincoln / UK
Age: 38
Posts: 1,580
Send a message via ICQ to Mad-Matt Send a message via MSN to Mad-Matt
I built a custom rom sometime back for uae use (since im not gonna be burning to real chips). All os39 updates applied and all updates since including iconbefast which works quite well. Shoved workbench.lib in the extended rom and its as custom as it gets . Works well too and can boot any wb without worrying about looking for os39 wb. Still only useful(or not as the case may be) for uae though.

i did try to put in the 040/060 libs , but setpatch didnt seem to like that and just crashed the system.
Mad-Matt is offline  
Old 02 October 2007, 11:39   #23
Stokey
Registered User
 
Join Date: Sep 2007
Location: Jedi Temple, Coruscant
Posts: 82
Quote:
Originally Posted by PeterK View Post
Sorry, but I've never seen "RemLibrary" yet, neither in "C:" nor in the
startup-sequence of OS 3.9.

Anyway, the icon.library can indeed successfully loaded resident from the
ROM if you simply remove it from the Libs: drawer first. Tested it last year!
RemLibrary was definitely installed by OS3.5, I assumed it was in 3.9 also.
Stokey is offline  
Old 02 October 2007, 22:44   #24
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,735
Quote:
Originally Posted by Mad-Matt View Post
I built a custom rom sometime back for uae use (since im not gonna be burning to real chips). All os39 updates applied and all updates since including iconbefast which works quite well..... .
Yeah, that's exactly what I did on my WinUAE system, too. The custom
ROM was booting reliable until I tried to update from WinUAE 1.340 to 1.4*.
It seems that I have to rebuild my custom ROM file with the latest Remus,
because under WinUAE 1.4* I get "Software Failure" under Windows, which
does not happen with the original Kickstart files.
PeterK is offline  
Old 02 October 2007, 22:49   #25
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,735
Quote:
Originally Posted by Stokey View Post
RemLibrary was definitely installed by OS3.5, I assumed it was in 3.9 also.
Maybe, I've just deleted RemLibrary, but I can't remember it.
The compression algorithm in my brain works with lossy compression
PeterK is offline  
Old 02 October 2007, 22:59   #26
Mad-Matt
Longplayer

Mad-Matt's Avatar
 
Join Date: Jan 2005
Location: Lincoln / UK
Age: 38
Posts: 1,580
Send a message via ICQ to Mad-Matt Send a message via MSN to Mad-Matt
im 100% Remlibrary isnt installed under normal OS35/39. removing the resident wb/icon lib was the job of updated setpatch. thats not to say the command doesnt exist as it is on the cd.

I think ive seen it used on the OS35 boot floppy but thats about it.

Last edited by Mad-Matt; 02 October 2007 at 23:10.
Mad-Matt is offline  
Old 02 October 2007, 23:52   #27
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 1,735
I found a remark about "RemLibrary" in the OS 3.9 FAQ, undocumented....
Click image for larger version

Name:	fromOS39FAQ.png
Views:	159
Size:	14.9 KB
ID:	14888

So, it seems there really was a command once around, but it's the job of
SetPatch now and can be done with the option DISABLEROMMODULES/K.
PeterK is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
[Found: Wicked] you controlled this red devil flying into a moon with a face lost_lemming Looking for a game name ? 4 11 September 2009 04:09
[Found: Car-Vup] Little car / devil game stainy Looking for a game name ? 4 22 April 2008 14:44
CD32 kickstart rom & extended rom ben111g Amiga scene 1 24 February 2007 14:56
kick.rom & rom.key Mazik New to Emulation or Amiga scene 4 27 March 2004 14:58

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:13.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.17986 seconds with 12 queries