English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 30 December 2004, 11:08   #1
Scatter
Super Cars II Freak
Scatter's Avatar
 
Join Date: Dec 2004
Location: Australia
Age: 42
Posts: 22
Angry Workbench 1.2 CLI probs

Hey Peeps,

I have a problem that is driving me to distraction. AE won't talk to my mig (A500 with extra half meg, KS 1.2), yet ADFSender will, despite me not changing the setup whatsoever. Weird. So I decided I'd transfer the AE setup myself through ADFS, and then just run AE, and hope it works.

The problem is, that I can't end the CLI process, and therefore can't copy or use the data on the RAM disk. I know what I am supposed to be doing (I think) it just doesn't appear to be working. It might be easier if I just run through what I am actually doing, and hope someone will pick out the obvious, but fatal flaw that is sending me to an early grave.

Open up a CLI Window and use the type command before starting transfer, my CLI window looks like:

1> Type SER: to RAM:Setup

Then send the AE setup files from the PC using ADFSender. Once the transfer of all the files is complete I press Ctrl+C on the mig, but get no response. I have tried a range of variations including breaking the connection in ADFSender before pressing Ctrl+C, but no matter what, the CLI Window doesn't respond.

I am guessing when it works, I should get a new prompt in the CLI Window to make it look like:

1> Type SER: to RAM:Setup
1>

At which point I would just type in Copy RAM:Setup to Df0:c to move the contents from the RAM disk to my WB disk.

I tried just opening a new CLI window, but it told me the RAM Disk was in use (obviously) and couldn't be accessed.

Plz help
Scatter is offline  
AdSense AdSense  
Old 30 December 2004, 14:43   #2
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,526
The problem is that the PC does neither send an EOF signal nor flush its buffers at the end. So the only way to go is to press Ctrl-C on the Amiga and send the file again from the PC. Now you will get a response but the resulting file may or may not be complete or too big.

IIRC this is the way suggested by the AE docs, too, so it might work nevertheless.
thomas is offline  
Old 30 December 2004, 14:49   #3
Scatter
Super Cars II Freak
Scatter's Avatar
 
Join Date: Dec 2004
Location: Australia
Age: 42
Posts: 22
So, I just press Ctrl+C on mig - even though I get no reaction from it - and then send the same file again???

What should happen then?
Scatter is offline  
Old 30 December 2004, 17:31   #4
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,526

1> Type SER: to RAM:Setup
*** Break
1>
thomas is offline  
Old 30 December 2004, 17:50   #5
Scatter
Super Cars II Freak
Scatter's Avatar
 
Join Date: Dec 2004
Location: Australia
Age: 42
Posts: 22
sweet.

thanks for your help. although it won't do me much good as the 's' key on my mig has stopped working...
Scatter is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
for..each statement in CLI pieter1976 support.Other 4 21 August 2011 02:23
CLI help DeafDaz request.Other 3 10 August 2011 01:16
Probs creating a CLI> Disk! D4Ni3L3 New to Emulation or Amiga scene 2 29 September 2008 22:14
A1200 Workbench Problems/Hardware Probs? blade002 support.Apps 3 19 February 2007 17:08

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 07:48.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.15697 seconds with 11 queries