English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 25 April 2004, 00:47   #1
Enverex
Fantasy Man!

Enverex's Avatar
 
Join Date: Apr 2002
Location: UK
Posts: 1,310
Unhappy ToolsDaemon

For some odd reason, whenever I try and start a program from the ToolsDaemon menu, the machine will just partially freeze. I can still move the mouse, move windows and bring up the menu, but I can't close windows, click icons or start programs and have to restart (soft) to get control back.

It does this with anything on the menu (other than ToolsPrefs) and does it 9/10 making it pretty useless.

Has anyone else heard of this problem before?
Enverex is offline  
AdSense AdSense  
Old 25 April 2004, 01:01   #2
ant512
Registered User
 
Join Date: Dec 2002
Location: California
Posts: 942
It sounds like the programs are running as foreground processes, which will cause Workbench to hang until they exit - Workbench isn't multithreaded. To fix it, you need to put the "run" command before the program you want to execute, so the command to launch IconEdit (for example) would change from:

SYS:Tools/IconEdit

to:

C:Run <NIL: >NIL: SYS:Tools/IconEdit

Instead of running IconEdit and waiting for it to exit, the system now runs "run", which launches IconEdit as a background process and exits immediately, allowing Workbench to continue normally.

I think that's the problem, anyway.
ant512 is offline  
Old 25 April 2004, 01:23   #3
Bloodwych
Moderator

Bloodwych's Avatar
 
Join Date: Jun 2001
Location: I'm behind you!
Posts: 3,763
I use toolsdaemon combined with the older and less trouble prone magicmenu which Akira kindly gave me, but only in the ClassicWB LITE.

In the full and above, a Scalos/popupmenu combo is used.

Can't understand why your having issues - worked fine for me. Try running it without any other startup programs. Also try having the WB part selected, although some programs like NewZap have to be run using the CLI string - see below. These functions are explained in the readme.
Attached Thumbnails
Click image for larger version

Name:	Image2.png
Views:	246
Size:	5.3 KB
ID:	6700  
Bloodwych is offline  
Old 25 April 2004, 01:33   #4
Enverex
Fantasy Man!

Enverex's Avatar
 
Join Date: Apr 2002
Location: UK
Posts: 1,310
Doesn't matter if they are set to WB or Cli mode. You may also want to have a look at ToolsPrefs2 which is nice to customise TD with.
Enverex is offline  
Old 25 April 2004, 01:44   #5
Bloodwych
Moderator

Bloodwych's Avatar
 
Join Date: Jun 2001
Location: I'm behind you!
Posts: 3,763
Thanks, I'll take a look. What WB version are you trying to install this on BTW?
Bloodwych is offline  
Old 25 April 2004, 17:44   #6
Bloodwych
Moderator

Bloodwych's Avatar
 
Join Date: Jun 2001
Location: I'm behind you!
Posts: 3,763
The reason I asked about WB version is if it's something newer like 3.9 (going by your virusz thread), the toolsdaemon readme mentions you could encounter problems.
Bloodwych is offline  
Old 27 April 2004, 06:40   #7
DrBong
HOL / AMR Team Member

DrBong's Avatar
 
Join Date: Dec 2001
Location: Australia
Posts: 2,192
Quote:
Originally Posted by Bloodwych
The reason I asked about WB version is if it's something newer like 3.9 (going by your virusz thread), the toolsdaemon readme mentions you could encounter problems.
Yep, there's a ToolsDaemon patch on Aminet for use under OS 3.x. Installing the latest BoingBag may also help things.
DrBong is offline  
Old 27 April 2004, 09:38   #8
Enverex
Fantasy Man!

Enverex's Avatar
 
Join Date: Apr 2002
Location: UK
Posts: 1,310
Yeah, I am using BB2, but I wasn't aware of a patch, cheers DB.
Enverex is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Toolsdaemon crash on cwb 3.9BB4 lolof support.Apps 0 12 October 2012 23:57
Toolsdaemon Jimbo support.Apps 14 27 August 2010 09:46
Toolsdaemon question fc.studio support.Apps 4 11 December 2009 17:04
ToolsDaemon Help Smiley support.Apps 3 11 September 2007 10:17

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:23.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.19203 seconds with 12 queries