English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 18 July 2003, 22:36   #1
Leo42
Senior Member
Leo42's Avatar
 
Join Date: Jan 2003
Location: Paris
Posts: 122
Why does CD32-Extended-ROM make UAE CRASH ??

Hi,


I'm trying to emulate a CD32 with UAE...

I have the CD32 Rom3.1 and the Extended Rom.

Whenever I select my extended rom and begin the emulation: BOOM ! UAE Crashes...

I think my UAE configuration is OK (AGA, 68EC020, 2Mb Chip, No floppy).

What's wrong ?

(I tried different configs and different UAE versions from 0.8.22 R4 through 0.8.22 R8 and I always got the same result: CRASH)

Please help !

(I'm using WinXP Home with no SP installed)
Leo42 is offline  
AdSense AdSense  
Old 18 July 2003, 23:05   #2
Leo42
Senior Member
Leo42's Avatar
 
Join Date: Jan 2003
Location: Paris
Posts: 122
I can add that it crashes before displaying anything... (I only
have a black window and BOOM, crash...)

Hope thid will help...
Leo42 is offline  
Old 19 July 2003, 11:37   #3
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,663
Are you sure your extended ROM is not corrupt?

Check this: http://eab.abime.net/showthread.php?threadid=10142
Toni Wilen is offline  
Old 19 July 2003, 14:34   #4
Leo42
Senior Member
Leo42's Avatar
 
Join Date: Jan 2003
Location: Paris
Posts: 122
I have installed the latest ASPI libs from Adaptec and it no longer crashes...

Leo.
Leo42 is offline  
Old 19 July 2003, 14:48   #5
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,663
Quote:
I'm using WinXP Home
and

Quote:
I have installed the latest ASPI libs from Adaptec and it no longer crashes
I thought you didn't have ASPI installed because XP (or Windows 2000) does not come with preinstalled ASPI.

WinUAE does not need ASPI under Windows 2000 or XP. Try unticking the ASPI checkbox.
Toni Wilen is offline  
Old 19 July 2003, 15:17   #6
Leo42
Senior Member
Leo42's Avatar
 
Join Date: Jan 2003
Location: Paris
Posts: 122
That's true: I did not have ASPI installed... And the ASPI was NOT checked in the misc tab. (I still haven't checked it...)

Léo.
Leo42 is offline  
Old 19 July 2003, 16:29   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,663
Bug found... WinUAE CD32 mode crashed if no CDROM support was found (no ASPI or SPTI) Apparantly XP Home does not support SPTI.
Toni Wilen is offline  
Old 19 July 2003, 16:31   #8
Konrad
Registered User
Konrad's Avatar
 
Join Date: Apr 2002
Location: Germany
Age: 36
Posts: 563
Happened to me when I didn't check the UAEscsi.device option. Look for it in the misc tab.
Konrad is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
CD32 ROM (KS + extended) REAL DUMP pucci support.WinUAE 14 25 October 2011 19:36
CD32 kickstart rom & extended rom ben111g Amiga scene 1 24 February 2007 13:56
Extended CD32 Rom Lecarnus New to Emulation or Amiga scene 1 30 December 2002 01:54
Ripping the CDTV extended rom Ian support.Hardware 2 21 June 2002 22:01

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:35.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.18987 seconds with 11 queries