English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 28 October 2021, 13:26   #1001
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 1,640
On a Windows 10 machine, using 7zip to extract winuae_4900b38.7z is OK, but extracting winuae64_4900b38.7z throws an error:

Quote:
Operation did not complete successfully because the file contains a virus or potentially unwanted software
Does anybody else have this issue?
solarmon is offline  
Old 28 October 2021, 13:35   #1002
Zarnal
Registered User

 
Join Date: Feb 2018
Location: France
Posts: 371
False positive as usual.
Zarnal is offline  
Old 28 October 2021, 13:44   #1003
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 1,640
Apologies if this already a known/common issue. Is there a workaround other than disabling AV?
solarmon is offline  
Old 28 October 2021, 13:56   #1004
Mclane
Old retro god.

Mclane's Avatar
 
Join Date: Apr 2002
Location: Northolt, West London
Age: 60
Posts: 734
Never disable AV, just add the file to the AV's exclusion / Whitelist..

This false positive happens along the way with Winuae... When it's coming from the author or his site then the file is fine, if it's from a different site then always double check on here..
Mclane is offline  
Old 28 October 2021, 14:13   #1005
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 1,640
Quote:
Originally Posted by Mclane View Post
Never disable AV, just add the file to the AV's exclusion / Whitelist..

This false positive happens along the way with Winuae... When it's coming from the author or his site then the file is fine, if it's from a different site then always double check on here..
I meant disabling AV just to do the extraction for this particular ZIP file. I can't find a whitelist option on the AV on my machine.
solarmon is offline  
Old 28 October 2021, 14:18   #1006
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 1,640
I figured out that it was Windows Security that is giving this false positive, not another AV solution that was running on my machine.

I was able to temporarily disable "Real-time protection" in "Virus & threat protection settings", do the extraction and enable it again.
solarmon is offline  
Old 28 October 2021, 14:46   #1007
Mclane
Old retro god.

Mclane's Avatar
 
Join Date: Apr 2002
Location: Northolt, West London
Age: 60
Posts: 734
Great to hear, tis just one of those little hurdles in the software world..
Mclane is offline  
Old 28 October 2021, 16:32   #1008
mcbpete
Zone Friend
mcbpete's Avatar
 
Join Date: Oct 2004
Location: London, England
Age: 39
Posts: 225
Send a message via MSN to mcbpete Send a message via Yahoo to mcbpete
Quote:
Originally Posted by solarmon View Post
I figured out that it was Windows Security that is giving this false positive, not another AV solution that was running on my machine.

I was able to temporarily disable "Real-time protection" in "Virus & threat protection settings", do the extraction and enable it again.
I've just forwarded the false positive .zip to Microsoft av file submission: https://www.microsoft.com/en-us/wdsi/filesubmission

If you have anything similar in future I recommend doing the same, the response time is usually pretty speedy (usually sorted by the signature update a day or two later)

EDIT: Windows Defender signatures now updated and false positive removed

Last edited by mcbpete; 28 October 2021 at 22:27.
mcbpete is offline  
Old 30 October 2021, 17:22   #1009
DiabloV
Registered User
 
Join Date: Jan 2021
Location: FRANCE
Posts: 16
one thing I can't solve: the list of roms only shows me the base ones, the roms I added (e.g. 3.2) don't show up in the selector, I have to load them manually (obviously I did the ROM SCAN several times)
DiabloV is offline  
Old 30 October 2021, 19:08   #1010
coldacid
WinUAE 4000/40, V4SA
coldacid's Avatar
 
Join Date: Apr 2020
Location: Candinavia
Posts: 434
@DiabloV: that is by design. Toni's been on record about this before back when 3.1.4 came out as well.
coldacid is offline  
Old 31 October 2021, 19:28   #1011
DiabloV
Registered User
 
Join Date: Jan 2021
Location: FRANCE
Posts: 16
Quote:
Originally Posted by coldacid View Post
@DiabloV: that is by design. Toni's been on record about this before back when 3.1.4 came out as well.

ok but i dont understand why just not scan the *.ROM ? and voila !
DiabloV is offline  
Old 01 November 2021, 18:46   #1012
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,246
I don't want to have anything to do with with 3.1.4+ ROM versions (reasons should be quite obvious). If someone generates required rommgr.cpp lines for _all_ 3.1.4+ ROMs, I can add it.
Toni Wilen is offline  
Old 07 November 2021, 15:35   #1013
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,246
https://download.abime.net/winuae/fi...uae_4900b39.7z
https://download.abime.net/winuae/fi...e64_4900b39.7z

This hopefully is last beta before few release candidates..

Beta 39:

- Executable as a disk image mounting now supports FFS and HD disks. Uses DD+OFS if selected file fits (like previously), then DD+FFS, finally HD+FFS (if drive is HD).
- Fixed empty formatted standard HD ADF creation, broken in 4.3.0 (bitmap block used DD size)
- If A1200 config had PCMCIA emulation and 4M or larger Z2 RAM enabled, end of Z2 RAM didn't have "safety barrier" which caused long or word access that crosses end of RAM to crash the emulator.
- Some audio debugging was accidentally left enabled in b38
- Adjusted UAE Boot ROM variable locations, freeing more space for ROM code.
- UAE Boot ROM level 2 interrupt server priority changed to -1 if KS 1.x, workaround for old SoundTracker (and clones) broken keyboard handling that breaks completely if KS ROM level 2 interrupt server isn't first in chain.
- Fixed last line of bitmap missing or flickering if very tall interlace mode and interlace artifact removal was enabled.
- Blitter line mode didn't clear BLTZERO if line pixel was skipped because of onedot mode. (vAmiga test case)
- Blitter line mode didn't update global state of shift values and SIGN bit. (vAmiga test case where next blit is started without updating BLTCON0/1)
- Yet another small interrupt timing adjustment.
- Chipset emulation could get confused in non-ce configurations when BPL1DAT was modified with a copper.
- Reinitialize all selected FloppyBridges when exiting FloppyBridge UI.
- Change to memory card (CF/SD/etc) added as a harddrive: if you wanted to use same config with Amiga formatted cards and FAT formatted cards and Windows/driver allowed direct access even when FAT formatted card (without partition table) was inserted (oddly enough Windows 10 and older didn't allow it on my PC but after updating to Windows 11, direct access is possible), FAT card wasn't anymore mounted as a directory drive after re-insert because direct access has priority and it did succeed. Now direct harddrive mode is only used if drive does not have any PC partitions (no drive letter) or if Lock option is ticked.
- Experimental HDR support added. (This is not going to be fully implemented in next official release, it is only side project)

HDR mode details:
- Requirements: HDR capable monitor. Windows HDR mode enabled. Direct 3D 11.
- New Graphics API option: "Direct3D 11 HDR".
- Original 8-bit RGB values are converted to HDR color space using shaders.
- Brightness/contrast adjustments are now done in shader code which prevents usual SDR black crush or white clipping. (Work more like CRT). Gamma adjustment is not yet supported.
- "Blacker than black" option behavior is also changed, because HDR by design support blacker than SDR black, it does not need to affect normal color range like in SDR mode. It is also always enabled in HDR mode.
Toni Wilen is offline  
Old 07 November 2021, 18:57   #1014
Viceroy
Registered User
 
Join Date: Jul 2006
Location: Sunderland
Posts: 880
Thank you ;-)
Viceroy is offline  
Old 08 November 2021, 02:14   #1015
utukku
Registered User

 
Join Date: Jan 2020
Location: UK
Posts: 101
Hi, trying to use the grease weasel in latest Winuae, I have downloaded the floppybridge0.10.zip file, it says to copy the .dll files into Wi uae's PLUGINS folder. BUt I can't find this folder withing the winuae installed directory. So where exactly do I need to make this dir?

Cheers
utukku is offline  
Old 08 November 2021, 03:01   #1016
coldacid
WinUAE 4000/40, V4SA
coldacid's Avatar
 
Join Date: Apr 2020
Location: Candinavia
Posts: 434
The "plugins" directory should be in the same directory as winuae.exe (or winuae64.exe) itself.
coldacid is offline  
Old 08 November 2021, 11:19   #1017
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 1,640
On my Windows 10 setup, I had to put them in:

C:\Users\Public\Documents\Amiga Files\WinUAE\plugins\
solarmon is offline  
Old 08 November 2021, 13:20   #1018
utukku
Registered User

 
Join Date: Jan 2020
Location: UK
Posts: 101
well, I have made a "plugins" folder in both the C:\Users\Public\Documents\Amiga Files\WinUAE/ and in the same folder as the .exe file, and still no greasweasel listed. Done a reboot and run as admin. still nothing. Just confirming that the floppybridge0.10.zip just contains 2 .dll files plus license & readme.txt file?
utukku is offline  
Old 08 November 2021, 13:25   #1019
solarmon
Registered User

solarmon's Avatar
 
Join Date: Dec 2018
Location: UK
Posts: 1,640
You need to go to Hardware->Floppy drives and select "Configure Floppybridge" from the drop down options list for each drive.

This has changed/moved from the unofficial preview build.
solarmon is offline  
Old 14 November 2021, 13:51   #1020
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 46
Posts: 25,246
https://download.abime.net/winuae/fi...uae_4900b40.7z
https://download.abime.net/winuae/fi...e64_4900b40.7z

Beta 40 (RC1):

- A2065 emulation quit/reset crash fix, A2065 RAM was freed too early, when it was still possible to receive new ethernet frames.
- Blitter final D write does not happen if D channel gets disabled, line mode gets enabled or new blit starts before pending D write has finished. This mainly affects copper blitter wait bug behavior, if new blit is setup before blitter gets its last cycle, last D write never happens which can prevent the glitch from happening. (Last write getting skipped might not cause any visible glitches) Fixes Andy & Blondie / Finity second to last part's glitch. Note that final part has many glitches, happens also on real A500 if system does not have any real Fast RAM.
- Log warning message if BLTDPTx is written to while blitter final D write is still pending.
- Removed wrong INTENA write optimization. Fixes Expiration / Mayhem cube corruption. (Problem wasn't directly blitter related)
- If programmed mode was in use that didn't require configured VSSTRT/VSSTOP registers, display was blank. (Contactro / Illusion)
- Screen mode with even horizontal cycle length (programmed and normal NTSC mode) copper timing fix. Copper can use cycle 0 (previously incorrectly calculated as cycle $e0) if previous line's last cycle was odd cycle (even total length). (Contactro / Illusion)
- Programmed mode registers are again zeroed at startup (was all ones) because JtxRules / Illusion only sets VBSTOP and HBSTOP and expects zeroed HBSTRT and VBSTRT. (Programmed mode comparators don't have reset line connected but they still power up with zeroed contents. At least usually..)

This update fixes remaining chipset related issues in my "should be fixed before official release" list.
Toni Wilen is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WinUAE 4.0.1 beta series Toni Wilen support.WinUAE 64 15 July 2018 13:03
WinUAE 3.6.1 beta series Toni Wilen support.WinUAE 166 07 March 2018 23:48
WinUAE 3.2.0 beta series Toni Wilen support.WinUAE 385 09 November 2015 00:06
WinUAE 2.5.1 beta series Toni Wilen support.WinUAE 69 22 December 2012 11:22
WinUAE 2.2.0 beta series Toni Wilen support.WinUAE 119 28 June 2010 03:35

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 07:21.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Page generated in 0.12726 seconds with 13 queries