English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 28 June 2003, 12:55   #1
Simon S
 
Posts: n/a
Question Control config problems

Well, the new keyboard fix got most of the problems, but there seem to be a few oddities.

For the keyboard, all the defaults seem to be one off space on the config menu (ie. ESC is blank, 1 is mapped to ESC, 2 is mapper to 1 and so on..)

however most of the keys are in the regular place when you actually launch and use the emulator.

However no amount of messing about seems to activate the cursor keys, it ignores them regardless of what I map to them.

Also my joystick configures to the mouse port , but never seems to work when emulated to the joystick port.

It's all strange stuff. On studying it, I have 3 joysticks installed. It regards one as a digital pad (though it's a dual analog) and one as keyboard with keys mapped to all kinds of insane configs. Again, this seems to have no effect within the emulator. It still ignores the cursors, which I badly need to use Dpaint.

Any ideas?
 
AdSense AdSense  
Old 28 June 2003, 13:09   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,672
Post your winuaebootlog.txt, thanks.
Toni Wilen is online now  
Old 06 July 2003, 21:26   #3
Quader
Registered User
Quader's Avatar
 
Join Date: Oct 2002
Location: Heidelberg/Germany
Age: 40
Posts: 49
Send a message via ICQ to Quader
I don't want to start a new thread, but here are also keyboard-problems with newest Winuae-Version:

Starting and Playing is no Problem, everything works fine, but when want to exit, alt + F4 or with F12-menu -> "misc" and then "quit" doesn't work because F12 doesn't work anymore.
No changes have been made to the configuration (i hope), also downloaded new version of winuae again but same problem with fresh one.

Searched the forum but nothing fits my problem.

As attachment the winuaebootlog.txt
Attached Files
File Type: zip winuaebootlog.zip (1.7 KB, 93 views)
Quader is offline  
Old 07 July 2003, 16:13   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,672
Quote:
Starting and Playing is no Problem, everything works fine, but when want to exit, alt + F4 or with F12-menu -> "misc" and then "quit" doesn't work because F12 doesn't work anymore.
Do you mean keyboard works in emulated Amiga (for example WB1.3 CLI-window) but F12 or ALT+F4 are ignored or all keys are completely disabled?

Does removing all lines beginning with "input." from your config file help?
Toni Wilen is online now  
Old 19 July 2003, 22:29   #5
Simon S
 
Posts: n/a
Big grin

Excellent! The latest release fixes all the control issues for me, and I can't believe how well it runs compared to the last version that worked for me. (ooh about 6 releases ago)

Great work, Thank you and a big manly handshake to the whole WinUAE team.
 
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with CD32 control mapping since upgrading to latest WINUAE :( Heavy Stylus support.WinUAE 5 18 May 2010 10:36
Optimum Swiv control config? Predabot support.Games 10 13 May 2009 17:39
Cannon Fodder 2 - control problems laffer support.Games 0 09 May 2009 22:01
Sound problems with AGA config plasmatron support.WinUAE 2 03 October 2008 16:43
CD 32 Control problems Fred the Fop support.WinUAE 5 30 December 2002 15:07

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:55.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.11611 seconds with 12 queries