English Amiga Board


Go Back   English Amiga Board > Support > support.Amiga Forever

 
 
Thread Tools
Old 02 July 2018, 18:49   #1
Yoji
Registered User

 
Join Date: May 2015
Location: newcastle-under-lyme
Posts: 38
Did they mess up Amiga forever update?

Quick Q.. I am pretty sure (99.99%) that Amiga Forever was updated to use the new WinUAE 4.0 via an update delivered by Software Director etc...
So mine updated... and I had a terrible trouble with the mouse responsiveness.... it was unusable..
So I waited.. assumed they messed up and would provide a fix.. I waited.. and waited.. and nothing..
Then I had a C drive crash and so reinstalled WIndows.. and Amiga forever, but this time - when Software director checked for updates.. the update was to 7 R2 etcc.. but only to WinUAE 3.6.1... and I have no issues with mouse responsiveness..


Did I dream it all? only me?
Cheers
Yoji is offline  
Old 02 July 2018, 20:43   #2
Matt_H
Registered User
Matt_H's Avatar
 
Join Date: Jul 2008
Location: Boston, MA
Posts: 162
Granted, I'm a few versions behind on Amiga Forever myself, but in my experience Amiga Forever usually lags a few versions behind the latest WinUAE. Given that WinUAE 4 was just released, I think it's unlikely that Software Director offered an update to WinUAE 4. I suspect it may have been your imagination.
Matt_H is offline  
Old 03 July 2018, 05:58   #3
squirminator2k
Dream17 / PortsCenter guy
squirminator2k's Avatar
 
Join Date: Aug 2004
Location: Los Angeles
Age: 32
Posts: 225
I'm having similar issues - I have the latest version which recently updated, and once I launch an emulated system the entire thing is incredibly unresponsive.
squirminator2k is offline  
Old 03 July 2018, 21:43   #4
Yoji
Registered User

 
Join Date: May 2015
Location: newcastle-under-lyme
Posts: 38
Quote:
Originally Posted by squirminator2k View Post
I'm having similar issues - I have the latest version which recently updated, and once I launch an emulated system the entire thing is incredibly unresponsive.

Can you check? easiest way is to open Amiga forever .. go to help tab, "about Amiga format", "WinUAE plugin" tab and check version.
What does it say?


Cheers
Yoji is offline  
Old 03 July 2018, 21:50   #5
squirminator2k
Dream17 / PortsCenter guy
squirminator2k's Avatar
 
Join Date: Aug 2004
Location: Los Angeles
Age: 32
Posts: 225
Plugin version: 7.2.11.0

WinUAE version: 4.0.0
squirminator2k is offline  
Old 03 July 2018, 22:32   #6
Yoji
Registered User

 
Join Date: May 2015
Location: newcastle-under-lyme
Posts: 38
Quote:
Originally Posted by squirminator2k View Post
Plugin version: 7.2.11.0

WinUAE version: 4.0.0

THANK YOU... I am not going mad


Anyone on who can speak for Cloanto/Amiga Forever able to comment?


I don't know how you can roll it back May be just putting the older WinUAE version back would fix. Of may be best do what I did and reinstall and let it update again (when I suspect it will only go to 3.6.1 like mine did)


Good luck - It was very frustrating for me to have an unusable copy.


Cheers
Yoji is offline  
Old 04 July 2018, 19:57   #7
honx
Registered User

honx's Avatar
 
Join Date: Oct 2014
Location: Klagenfurt / Austria
Posts: 1,091
having same issues with extreme mouse lag since update. also latest version 7.2.11.0, winuae 4.0.0 installed.
as encountered so far: the lag (unusable mouse movement) happens in windowed mode of any configuration.
if i switch to fullscreen mode, for me this extreme mouse lag is gone and emulation is usable as it used to be.
but fullscreen is no solution for me, because 4:3 screens look ugly on my monitor. so i need windowed mode.
already did some tests for cloanto, like disconnecting g15 keyboard, g9x mouse, using standard hardware, ...
as far i can tell, g15 keyboard and g9x mouse are not the culprit. same problems with hp keyboard/mouse.

and i only have these issues in emulation using amiga forever in windowed mode. as i said, not in fullscreen.
and if i run external winuae installation, which has nothing to do with amiga forever, also no problems at all.
this mouse lag only occurs, if i run amiga forever in windowed mode.

Last edited by honx; 04 July 2018 at 20:05.
honx is offline  
Old 04 July 2018, 21:16   #8
Yoji
Registered User

 
Join Date: May 2015
Location: newcastle-under-lyme
Posts: 38
Thanks..
When no fix from Cloanto, I assumed it just me.. and wondered about it being mouse. I tried it with Razer Naga (2014) and now with Microsoft Classic intellimouse.. both exhibited the problem. For keyboard - I using a Razer Blackwidow ultimate (2014).. all just in raw USB mode..with whatever Win 10 driver thinks appropriate... not got Razer software installed.
Like you - I tried it with the raw WinUAE 4.0.0. and did not have any lag issues.... only within AForever.
Did not try it in full screen mode.. and now I back with WinUAE 3.6.1 and it all working fine.. I not inclined to try go back to 4.0.0 to test.


But my main concern.. is that it seems to happened to a few of us.. and if Cloanto knew about it such that they reverted back to 3.6.1... they should have pushed the fix to get people unfortunate enough to get the update before they realised... back to stable.
That's pretty bad service


Cheers
Yoji is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amiga Forever now offering OS4.1 final download as an addon to amiga Forever sturme support.Amiga Forever 17 13 February 2017 11:30
Interesting read on the Amiga Inc. legal mess Leffmann Amiga scene 10 23 February 2010 01:27
Amiga Forever and C64 Forever Live Video Meetup mcb News 1 30 May 2009 20:09
Mess for Amiga 68k MazinKaesar request.Apps 2 19 February 2008 10:06
MESS v.112 Sune Salminen News 2 08 February 2007 15:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:04.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.07820 seconds with 15 queries