English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 29 June 2012, 15:32   #1
plasmatron
Zone Friend
plasmatron's Avatar
 
Join Date: May 2003
Location: Germany
Age: 44
Posts: 958
Sound crackling

Hi folkz,

Since I didnt use winuae for some months, I noticed some sound problems.
Strange thing is that it starts when winuae is allready running for more that 10 minutes. But than there is some crackling over the sound. This happens on a 1 second interval. So when I count 1,2,3 I always hear a crackle on every second.
I tried the direct sound and wasapi outputs. Filter are on but I also tried without em. I first thought it has something to do with some interpolation settings, coz I switshed em off and everything sounded good for a few minutes, but it is there again.
Sound buffer settings also make no difference.
Maybe some driver issues but everything else is sounding fine on my mashine
plasmatron is offline  
Old 29 June 2012, 17:27   #2
cosmicfrog
The 1 who ribbits
cosmicfrog's Avatar
 
Join Date: Apr 2006
Location: leek, Staffs, UK
Age: 52
Posts: 3,556
Send a message via MSN to cosmicfrog
try increasing ya sound buffer size a little
cosmicfrog is offline  
Old 29 June 2012, 17:42   #3
TCD
Registered User

TCD's Avatar
 
Join Date: Sep 2006
Location: Germany
Age: 42
Posts: 24,012
What does the 'SND' display on the WinUAE window read when the 'crackling' happens?
TCD is offline  
Old 29 June 2012, 17:53   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 23,808
Hardware specs would be nice to know, also include winuaebootlog.txt.

It is not WinUAE problem if sound buffer size has no effect to sound glitches.
Toni Wilen is online now  
Old 29 June 2012, 18:55   #5
plasmatron
Zone Friend
plasmatron's Avatar
 
Join Date: May 2003
Location: Germany
Age: 44
Posts: 958
@TCD
What is the snd display again please?

@Toni
Sadly there is no bootlog.txt in the winuae dir. If I remember right, I deleted it by accidett some tinme ago.
Is there a way to recover it?
plasmatron is offline  
Old 29 June 2012, 18:58   #6
TCD
Registered User

TCD's Avatar
 
Join Date: Sep 2006
Location: Germany
Age: 42
Posts: 24,012
If you run in windowed mode or if you have 'on-screen display' enabled in the Miscellaneous panel it's the leftmost display.
TCD is offline  
Old 29 June 2012, 20:14   #7
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 23,808
Quote:
Originally Posted by plasmatron View Post
Sadly there is no bootlog.txt in the winuae dir. If I remember right, I deleted it by accidett some tinme ago.
Is there a way to recover it?
Run winuae with -log command line parameter to see full winuaebootlog.txt path. (you most likely don't have write access to this directory if file is still missing)
Toni Wilen is online now  
Old 29 June 2012, 20:29   #8
plasmatron
Zone Friend
plasmatron's Avatar
 
Join Date: May 2003
Location: Germany
Age: 44
Posts: 958
Ok here is the log file but it seems it stoped logging some time ago???
But its enabled
I also put the buffer size to 1 and than sound is playing better but still crackling.
On the very left onscreen led the values are going mad from blue to red(90).
When I use a sound buffer of 10 its constandly in the reds.
Mmh? Anyway here is the logfile:

WinUAE 2.4.1 (Public Beta Beta 6, 2012.04.18) (6.1 Service Pack 1 [2]) 64-bit 9.F.6B02 2
(c) 1995-2001 Bernd Schmidt - Core UAE concept and implementation.
(c) 1998-2012 Toni Wilen - Win32 port, core code updates.
(c) 1996-2001 Brian King - Win32 port, Picasso96 RTG, and GUI.
(c) 1996-1999 Mathias Ortmann - Win32 port and bsdsocket support.
(c) 2000-2001 Bernd Meyer - JIT engine.
(c) 2000-2005 Bernd Roesch - MIDI input, many fixes.
Press F12 to show the Settings Dialog (GUI), Alt-F4 to quit.
End+F1 changes floppy 0, End+F2 changes floppy 1, etc.
'F:\EMULATION\AMIGA\winuae.exe'
EXE: 'F:\EMULATION\AMIGA\', DATA: 'C:\Users\Public\Documents\Amiga Files\WinUAE\', PLUGIN: 'F:\EMULATION\AMIGA\plugins\'
CLOCKFREQ: QPF 14.32MHz (7.16MHz, DIV=2)
ROM KEY 'F:\EMULATION\AMIGA\rom\rom.key' 750 bytes loaded
Enumerating display devices..
Sorting devices and modes..
Desktop: W=1024 H=768 B=32. CXVS=1024 CYVS=768
NVIDIA GeForce 9500 GT [\\.\DISPLAY1]
-: PnP-Monitor (Standard) (1024*768) *
0: 640x480, 16-bit (59,60,75)
1: 640x480, 32-bit (59,60,75)
2: 720x480, 16-bit (!29,!30,59,60,75)
3: 720x480, 32-bit (!29,!30,59,60,75)
4: 720x576, 16-bit (!25,50,60,75)
5: 720x576, 32-bit (!25,50,60,75)
6: 800x600, 16-bit (60,75)
7: 800x600, 32-bit (60,75)
8: 1024x768, 16-bit (60,75)
9: 1024x768, 32-bit (60,75)
10: 1152x720, 16-bit (60)
11: 1152x720, 32-bit (60)
12: 1152x864, 16-bit (60)
13: 1152x864, 32-bit (60)
14: 1280x720, 16-bit (50,59,60)
15: 1280x720, 32-bit (50,59,60)
16: 1280x768, 16-bit (60)
17: 1280x768, 32-bit (60)
18: 1280x800, 16-bit (60)
19: 1280x800, 32-bit (60)
20: 1280x960, 16-bit (60)
21: 1280x960, 32-bit (60)
22: 1280x1024, 16-bit (60,75)
23: 1280x1024, 32-bit (60,75)
24: 1360x768, 16-bit (60)
25: 1360x768, 32-bit (60)
26: 1366x768, 16-bit (60)
27: 1366x768, 32-bit (60)
28: 1440x900, 16-bit (60)
29: 1440x900, 32-bit (60)
30: 1600x900, 16-bit (60)
31: 1600x900, 32-bit (60)
32: 1600x1000, 16-bit (60)
33: 1600x1000, 32-bit (60)
34: 1600x1024, 16-bit (59,60)
35: 1600x1024, 32-bit (59,60)
36: 1680x1050, 16-bit (59,60)
37: 1680x1050, 32-bit (59,60)
38: !1920x1080i, 16-bit (!25,!29,!30,!50,!59,!60)
39: !1920x1080i, 32-bit (!25,!29,!30,!50,!59,!60)
40 display modes.
Display buffer mode = 1
Enumerating DirectSound devices..
Enumerating WASAPI devices...
Enumeration end
0:WA: Default Audio Device
1:WA: Lautsprecher (2- USB Audio CODEC )
2:WA: Lautsprecher (Realtek High Definition Audio)
3:WX: Default Audio Device
4:WX: Lautsprecher (2- USB Audio CODEC )
5:WX: Lautsprecher (Realtek High Definition Audio)
6S: Primärer Soundtreiber
7S: Lautsprecher (Realtek High Definition Audio)
8S: Lautsprecher (2- USB Audio CODEC )
Enumerating recording devices:
0S: Primärer Soundaufnahmetreiber
1S: Stereomix (Realtek High Definition Audio)
2S: Mikrofon (2- USB Audio CODEC )
done
Filesystem charset (ACP=1252,FSCP=28605):
00: 0000 01: 0001 02: 0002 03: 0003
04: 0004 05: 0005 06: 0006 07: 0007
08: 0008 09: 0009 0A: 000A 0B: 000B
0C: 000C 0D: 000D 0E: 000E 0F: 000F
10: 0010 11: 0011 12: 0012 13: 0013
14: 0014 15: 0015 16: 0016 17: 0017
18: 0018 19: 0019 1A: 001A 1B: 001B
1C: 001C 1D: 001D 1E: 001E 1F: 001F
20: 0020 21: 0021 22: 0022 23: 0023
24: 0024 25: 0025 26: 0026 27: 0027
28: 0028 29: 0029 2A: 002A 2B: 002B
2C: 002C 2D: 002D 2E: 002E 2F: 002F
30: 0030 31: 0031 32: 0032 33: 0033
34: 0034 35: 0035 36: 0036 37: 0037
38: 0038 39: 0039 3A: 003A 3B: 003B
3C: 003C 3D: 003D 3E: 003E 3F: 003F
40: 0040 41: 0041 42: 0042 43: 0043
44: 0044 45: 0045 46: 0046 47: 0047
48: 0048 49: 0049 4A: 004A 4B: 004B
4C: 004C 4D: 004D 4E: 004E 4F: 004F
50: 0050 51: 0051 52: 0052 53: 0053
54: 0054 55: 0055 56: 0056 57: 0057
58: 0058 59: 0059 5A: 005A 5B: 005B
5C: 005C 5D: 005D 5E: 005E 5F: 005F
60: 0060 61: 0061 62: 0062 63: 0063
64: 0064 65: 0065 66: 0066 67: 0067
68: 0068 69: 0069 6A: 006A 6B: 006B
6C: 006C 6D: 006D 6E: 006E 6F: 006F
70: 0070 71: 0071 72: 0072 73: 0073
74: 0074 75: 0075 76: 0076 77: 0077
78: 0078 79: 0079 7A: 007A 7B: 007B
7C: 007C 7D: 007D 7E: 007E 7F: 007F
80: 20AC (0080) 81: 0081 82: 201A (0082) 83: 0192 (0083)
84: 201E (0084) 85: 2026 (0085) 86: 2020 (0086) 87: 2021 (0087)
88: 02C6 (0088) 89: 2030 (0089) 8A: 0160 (008A) 8B: 2039 (008B)
8C: 0152 (008C) 8D: 008D 8E: 017D (008E) 8F: 008F
90: 0090 91: 2018 (0091) 92: 2019 (0092) 93: 201C (0093)
94: 201D (0094) 95: 2022 (0095) 96: 2013 (0096) 97: 2014 (0097)
98: 02DC (0098) 99: 2122 (0099) 9A: 0161 (009A) 9B: 203A (009B)
9C: 0153 (009C) 9D: 009D 9E: 017E (009E) 9F: 0178 (009F)
A0: 00A0 A1: 00A1 A2: 00A2 A3: 00A3
A4: 00A4 (20AC) A5: 00A5 A6: 00A6 (0160) A7: 00A7
A8: 00A8 (0161) A9: 00A9 AA: 00AA AB: 00AB
AC: 00AC AD: 00AD AE: 00AE AF: 00AF
B0: 00B0 B1: 00B1 B2: 00B2 B3: 00B3
B4: 00B4 (017D) B5: 00B5 B6: 00B6 B7: 00B7
B8: 00B8 (017E) B9: 00B9 BA: 00BA BB: 00BB
BC: 00BC (0152) BD: 00BD (0153) BE: 00BE (0178) BF: 00BF
C0: 00C0 C1: 00C1 C2: 00C2 C3: 00C3
C4: 00C4 C5: 00C5 C6: 00C6 C7: 00C7
C8: 00C8 C9: 00C9 CA: 00CA CB: 00CB
CC: 00CC CD: 00CD CE: 00CE CF: 00CF
D0: 00D0 D1: 00D1 D2: 00D2 D3: 00D3
D4: 00D4 D5: 00D5 D6: 00D6 D7: 00D7
D8: 00D8 D9: 00D9 DA: 00DA DB: 00DB
DC: 00DC DD: 00DD DE: 00DE DF: 00DF
E0: 00E0 E1: 00E1 E2: 00E2 E3: 00E3
E4: 00E4 E5: 00E5 E6: 00E6 E7: 00E7
E8: 00E8 E9: 00E9 EA: 00EA EB: 00EB
EC: 00EC ED: 00ED EE: 00EE EF: 00EF
F0: 00F0 F1: 00F1 F2: 00F2 F3: 00F3
F4: 00F4 F5: 00F5 F6: 00F6 F7: 00F7
F8: 00F8 F9: 00F9 FA: 00FA FB: 00FB
FC: 00FC FD: 00FD FE: 00FE FF: 00FF
End
CW: No Catweasel detected
PARAPORT: no ParaPort.dll, direct parallel port emulation disabled
IPC: Named Pipe '\\.\pipe\WinUAE' open
IPC: Named Pipe '\\.\pipe\WinUAE_COM' open
Serial port enumeration..
SERPORT: 'Kommunikationsanschluss (COM1)' = 'COM1' = '\\?\acpi#pnp0501#1#{86e0d1e0-8089-11d0-9ce4-08003e301f73}'
Parallel port enumeration..
PARPORT: 'Druckeranschluss (LPT1)' = 'LPT1' = '\\?\acpi#pnp0400#1#{97f76ef0-f883-11d0-af1f-0000f800845c}'
Port enumeration end
MIDI port enumeration..
MIDI OUT: -1:'Microsoft MIDI Mapper' (1/1)
MIDI OUT: 0:'Microsoft GS Wavetable Synth' (1/27)
MIDI port enumeration end
RawInput enumeration..
RAWINPUT: found 6 devices
00010047 hid: '\\?\HID#VID_8282&PID_3201#6&305fd9f0&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}'
000B003D keyboard: '\\?\ACPI#PNP0303#3&2b8e0b4b&0#{884b96c3-56ef-11d1-bc8c-00a0c91405dd}'
type=7 sub=0 mode=1 fkeys=12 indicators=3 tkeys=101
000B0039 mouse: '\\?\HID#VID_046D&PID_C01B#6&2d8c24ad&0&0000#{378de44c-56ef-11d1-bc8c-00a0c91405dd}'
id=256 buttons=6 hw=0 rate=0
'Logitech HID-compliant MX310 Optical Mouse' ('\\?\HID#VID_046D&PID_C01B#6&2d8c24ad&0&0000#{378de44c-56ef-11d1-bc8c-00a0c91405dd}')
'Standardtastatur (PS/2)' ('\\?\ACPI#PNP0303#3&2b8e0b4b&0#{884b96c3-56ef-11d1-bc8c-00a0c91405dd}')
Logitech HID-compliant MX310 Optical Mouse: (046D/C01B)
00 000 'X Axis' (0, [0 - 0, 0 - 0, 0 0 0])
01 001 'Y Axis' (1, [0 - 0, 0 - 0, 0 0 0])
02 002 'Wheel' (2, [0 - 0, 0 - 0, 0 0 0])
03 003 'HWheel' (3, [0 - 0, 0 - 0, 0 0 0])
00 000 'Button 1' (0)
01 001 'Button 2' (1)
02 002 'Button 3' (2)
03 003 'Button 4' (3)
04 004 'Button 5' (4)
05 005 'Button 6' (5)
02 002 'Wheel [-]' (1004)
02 002 'Wheel [+]' (1005)
03 003 'HWheel [-]' (1006)
03 003 'HWheel [+]' (1007)
Retro Adapter: (8282/3201)
30 048 'X Axis' (96, [-127 - 127, 0 - 0, 8 0 0])
31 049 'Y Axis' (98, [-127 - 127, 0 - 0, 8 0 0])
33 051 'X Rotation' (102, [-127 - 127, 0 - 0, 8 0 0])
34 052 'Y Rotation' (104, [-127 - 127, 0 - 0, 8 0 0])
39 057 'Hat Switch (X)' (114, [0 - 7, 0 - 0, 5 0 0])
39 057 'Hat Switch (Y)' (115, [0 - 7, 0 - 0, 5 0 0])
01 001 'Button 1' (2)
02 002 'Button 2' (4)
03 003 'Button 3' (6)
04 004 'Button 4' (8)
05 005 'Button 5' (10)
06 006 'Button 6' (12)
07 007 'Button 7' (14)
08 008 'Button 8' (16)
09 009 'Button 9' (18)
0A 010 'Button 10' (20)
0B 011 'Button 11' (22)
0C 012 'Button 12' (24)
0D 013 'Button 13' (26)
0E 014 'Button 14' (28)
0F 015 'Button 15' (30)
10 016 'Button 16' (32)
30 048 'X Axis [-]' (1096)
30 048 'X Axis [+]' (1097)
31 049 'Y Axis [-]' (1098)
31 049 'Y Axis [+]' (1099)
33 051 'X Rotation [-]' (1102)
33 051 'X Rotation [+]' (1103)
34 052 'Y Rotation [-]' (1104)
34 052 'Y Rotation [+]' (1105)
39 057 'Hat Switch (X) [-]' (1116)
39 057 'Hat Switch (X) [+]' (1117)
39 057 'Hat Switch (Y) [-]' (1118)
39 057 'Hat Switch (Y) [+]' (1119)
RAWINPUT test ok, usage=2
RAWINPUT test ok, usage=6
DirectInput enumeration.. Game controllers..
Windowsmouse initialization..
Catweasel joymouse initialization..
wintab tablet initialization..
Tablet: no wintab32.dll
end
Max Z3FastRAM 2048M. Total physical RAM 2046M
load config 'F:\EMULATION\AMIGA\Configurations\default.uae':0
load failed
failed to load config 'F:\EMULATION\AMIGA\Configurations\default.uae'
LCD: Logitech LCD system not detected
'F:\EMULATION\AMIGA\Configurations\configuration.cache' loaded successfully
Entering GUI idle loop
load config 'F:\EMULATION\AMIGA\Configurations\Host\Fullscreen (800x600).uae':2
load config 'F:\EMULATION\AMIGA\Configurations\Proton2.UAE':0
Log (disabled): 'C:\Users\Public\Documents\Amiga Files\WinUAE\winuaelog.txt'

Last edited by prowler; 29 June 2012 at 22:12. Reason: Forget it.
plasmatron is offline  
Old 29 June 2012, 20:52   #9
plasmatron
Zone Friend
plasmatron's Avatar
 
Join Date: May 2003
Location: Germany
Age: 44
Posts: 958
oh here is a new logfile now. I forgot to save the configfile.

WinUAE 2.4.1 (2012.05.09) (6.1 Service Pack 1 [2]) 64-bit 9.F.6B02 2 12:07
(c) 1995-2001 Bernd Schmidt - Core UAE concept and implementation.
(c) 1998-2012 Toni Wilen - Win32 port, core code updates.
(c) 1996-2001 Brian King - Win32 port, Picasso96 RTG, and GUI.
(c) 1996-1999 Mathias Ortmann - Win32 port and bsdsocket support.
(c) 2000-2001 Bernd Meyer - JIT engine.
(c) 2000-2005 Bernd Roesch - MIDI input, many fixes.
Press F12 to show the Settings Dialog (GUI), Alt-F4 to quit.
End+F1 changes floppy 0, End+F2 changes floppy 1, etc.
'F:\EMULATION\AMIGA\winuae.exe'
EXE: 'F:\EMULATION\AMIGA\', DATA: 'C:\Users\Public\Documents\Amiga Files\WinUAE\', PLUGIN: 'F:\EMULATION\AMIGA\plugins\'
CLOCKFREQ: QPF 14.32MHz (7.16MHz, DIV=2)
ROM KEY 'F:\EMULATION\AMIGA\rom\rom.key' 750 bytes loaded
Enumerating display devices..
Sorting devices and modes..
Desktop: W=1024 H=768 B=32. CXVS=1024 CYVS=768
NVIDIA GeForce 9500 GT [\\.\DISPLAY1]
-: PnP-Monitor (Standard) (1024*768) *
0: 640x480, 16-bit (59,60,75)
1: 640x480, 32-bit (59,60,75)
2: 720x480, 16-bit (!29,!30,59,60,75)
3: 720x480, 32-bit (!29,!30,59,60,75)
4: 720x576, 16-bit (!25,50,60,75)
5: 720x576, 32-bit (!25,50,60,75)
6: 800x600, 16-bit (60,75)
7: 800x600, 32-bit (60,75)
8: 1024x768, 16-bit (60,75)
9: 1024x768, 32-bit (60,75)
10: 1152x720, 16-bit (60)
11: 1152x720, 32-bit (60)
12: 1152x864, 16-bit (60)
13: 1152x864, 32-bit (60)
14: 1280x720, 16-bit (50,59,60)
15: 1280x720, 32-bit (50,59,60)
16: 1280x768, 16-bit (60)
17: 1280x768, 32-bit (60)
18: 1280x800, 16-bit (60)
19: 1280x800, 32-bit (60)
20: 1280x960, 16-bit (60)
21: 1280x960, 32-bit (60)
22: 1280x1024, 16-bit (60,75)
23: 1280x1024, 32-bit (60,75)
24: 1360x768, 16-bit (60)
25: 1360x768, 32-bit (60)
26: 1366x768, 16-bit (60)
27: 1366x768, 32-bit (60)
28: 1440x900, 16-bit (60)
29: 1440x900, 32-bit (60)
30: 1600x900, 16-bit (60)
31: 1600x900, 32-bit (60)
32: 1600x1000, 16-bit (60)
33: 1600x1000, 32-bit (60)
34: 1600x1024, 16-bit (59,60)
35: 1600x1024, 32-bit (59,60)
36: 1680x1050, 16-bit (59,60)
37: 1680x1050, 32-bit (59,60)
38: !1920x1080i, 16-bit (!25,!29,!30,!50,!59,!60)
39: !1920x1080i, 32-bit (!25,!29,!30,!50,!59,!60)
40 display modes.
Display buffer mode = 1
Enumerating DirectSound devices..
Enumerating WASAPI devices...
Enumeration end
0S: Primärer Soundtreiber
1S: Lautsprecher (Realtek High Definition Audio)
2S: Lautsprecher (2- USB Audio CODEC )
3:WA: Default Audio Device
4:WA: Lautsprecher (2- USB Audio CODEC )
5:WA: Lautsprecher (Realtek High Definition Audio)
6:WX: Default Audio Device
7:WX: Lautsprecher (2- USB Audio CODEC )
8:WX: Lautsprecher (Realtek High Definition Audio)
Enumerating recording devices:
0S: Primärer Soundaufnahmetreiber
1S: Stereomix (Realtek High Definition Audio)
2S: Mikrofon (2- USB Audio CODEC )
done
Filesystem charset (ACP=1252,FSCP=28605):
00: 0000 01: 0001 02: 0002 03: 0003
04: 0004 05: 0005 06: 0006 07: 0007
08: 0008 09: 0009 0A: 000A 0B: 000B
0C: 000C 0D: 000D 0E: 000E 0F: 000F
10: 0010 11: 0011 12: 0012 13: 0013
14: 0014 15: 0015 16: 0016 17: 0017
18: 0018 19: 0019 1A: 001A 1B: 001B
1C: 001C 1D: 001D 1E: 001E 1F: 001F
20: 0020 21: 0021 22: 0022 23: 0023
24: 0024 25: 0025 26: 0026 27: 0027
28: 0028 29: 0029 2A: 002A 2B: 002B
2C: 002C 2D: 002D 2E: 002E 2F: 002F
30: 0030 31: 0031 32: 0032 33: 0033
34: 0034 35: 0035 36: 0036 37: 0037
38: 0038 39: 0039 3A: 003A 3B: 003B
3C: 003C 3D: 003D 3E: 003E 3F: 003F
40: 0040 41: 0041 42: 0042 43: 0043
44: 0044 45: 0045 46: 0046 47: 0047
48: 0048 49: 0049 4A: 004A 4B: 004B
4C: 004C 4D: 004D 4E: 004E 4F: 004F
50: 0050 51: 0051 52: 0052 53: 0053
54: 0054 55: 0055 56: 0056 57: 0057
58: 0058 59: 0059 5A: 005A 5B: 005B
5C: 005C 5D: 005D 5E: 005E 5F: 005F
60: 0060 61: 0061 62: 0062 63: 0063
64: 0064 65: 0065 66: 0066 67: 0067
68: 0068 69: 0069 6A: 006A 6B: 006B
6C: 006C 6D: 006D 6E: 006E 6F: 006F
70: 0070 71: 0071 72: 0072 73: 0073
74: 0074 75: 0075 76: 0076 77: 0077
78: 0078 79: 0079 7A: 007A 7B: 007B
7C: 007C 7D: 007D 7E: 007E 7F: 007F
80: 20AC (0080) 81: 0081 82: 201A (0082) 83: 0192 (0083)
84: 201E (0084) 85: 2026 (0085) 86: 2020 (0086) 87: 2021 (0087)
88: 02C6 (0088) 89: 2030 (0089) 8A: 0160 (008A) 8B: 2039 (008B)
8C: 0152 (008C) 8D: 008D 8E: 017D (008E) 8F: 008F
90: 0090 91: 2018 (0091) 92: 2019 (0092) 93: 201C (0093)
94: 201D (0094) 95: 2022 (0095) 96: 2013 (0096) 97: 2014 (0097)
98: 02DC (0098) 99: 2122 (0099) 9A: 0161 (009A) 9B: 203A (009B)
9C: 0153 (009C) 9D: 009D 9E: 017E (009E) 9F: 0178 (009F)
A0: 00A0 A1: 00A1 A2: 00A2 A3: 00A3
A4: 00A4 (20AC) A5: 00A5 A6: 00A6 (0160) A7: 00A7
A8: 00A8 (0161) A9: 00A9 AA: 00AA AB: 00AB
AC: 00AC AD: 00AD AE: 00AE AF: 00AF
B0: 00B0 B1: 00B1 B2: 00B2 B3: 00B3
B4: 00B4 (017D) B5: 00B5 B6: 00B6 B7: 00B7
B8: 00B8 (017E) B9: 00B9 BA: 00BA BB: 00BB
BC: 00BC (0152) BD: 00BD (0153) BE: 00BE (0178) BF: 00BF
C0: 00C0 C1: 00C1 C2: 00C2 C3: 00C3
C4: 00C4 C5: 00C5 C6: 00C6 C7: 00C7
C8: 00C8 C9: 00C9 CA: 00CA CB: 00CB
CC: 00CC CD: 00CD CE: 00CE CF: 00CF
D0: 00D0 D1: 00D1 D2: 00D2 D3: 00D3
D4: 00D4 D5: 00D5 D6: 00D6 D7: 00D7
D8: 00D8 D9: 00D9 DA: 00DA DB: 00DB
DC: 00DC DD: 00DD DE: 00DE DF: 00DF
E0: 00E0 E1: 00E1 E2: 00E2 E3: 00E3
E4: 00E4 E5: 00E5 E6: 00E6 E7: 00E7
E8: 00E8 E9: 00E9 EA: 00EA EB: 00EB
EC: 00EC ED: 00ED EE: 00EE EF: 00EF
F0: 00F0 F1: 00F1 F2: 00F2 F3: 00F3
F4: 00F4 F5: 00F5 F6: 00F6 F7: 00F7
F8: 00F8 F9: 00F9 FA: 00FA FB: 00FB
FC: 00FC FD: 00FD FE: 00FE FF: 00FF
End
CW: No Catweasel detected
PARAPORT: no ParaPort.dll, direct parallel port emulation disabled
IPC: Named Pipe '\\.\pipe\WinUAE' open
IPC: Named Pipe '\\.\pipe\WinUAE_COM' open
Serial port enumeration..
SERPORT: 'Kommunikationsanschluss (COM1)' = 'COM1' = '\\?\acpi#pnp0501#1#{86e0d1e0-8089-11d0-9ce4-08003e301f73}'
Parallel port enumeration..
PARPORT: 'Druckeranschluss (LPT1)' = 'LPT1' = '\\?\acpi#pnp0400#1#{97f76ef0-f883-11d0-af1f-0000f800845c}'
Port enumeration end
MIDI port enumeration..
MIDI OUT: -1:'Microsoft MIDI Mapper' (1/1)
MIDI OUT: 0:'Microsoft GS Wavetable Synth' (1/27)
MIDI port enumeration end
RawInput enumeration..
RAWINPUT: found 6 devices
014F013F hid: '\\?\HID#VID_8282&PID_3201#6&305fd9f0&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}'

******** USB HID: 'Retro Adapter'
Usage: 0004
UsagePage: 0001
InputReportByteLength: 8
OutputReportByteLength: 0
FeatureReportByteLength: 0
NumberLinkCollectionNodes: 2
NumberInputButtonCaps: 1
NumberInputValueCaps: 5
NumberInputDataIndices: 21
NumberOutputButtonCaps: 0
NumberOutputValueCaps: 0
NumberOutputDataIndices: 0
NumberFeatureButtonCaps: 0
NumberFeatureValueCaps: 0
NumberFeatureDataIndices: 0
******** BUTTON_CAPS: 0 ********
UsagePage: 9
ReportID: 1
IsAlias: 0
BitField: 2
LinkCollection: 1
LinkUsage: 1
LinkUsagePage: 1
IsRange: 1
IsStringRange: 0
IsDesignatorRange: 0
IsAbsolute: 1
UsageMin: 1
UsageMax: 16
StringMin: 0
StringMax: 0
DesignatorMin: 0
DesignatorMax: 0
DataIndexMin: 5
DataIndexMax: 20
******** VALUE_CAPS: 0 ********
UsagePage: 1
ReportID: 1
IsAlias: 0
BitField: 2
LinkCollection: 1
LinkUsage: 1
LinkUsagePage: 1
IsRange: 0
IsStringRange: 0
IsDesignatorRange: 0
IsAbsolute: 1
HasNull: 0
BitSize: 8
ReportCount: 1
UnitsExp: 0
Units: 0
LogicalMin: 4294967169
LogicalMax: 127
PhysicalMin: 0
PhysicalMax: 0
Usage: 49
StringIndex: 0
DesignatorIndex: 0
DataIndex: 0
******** VALUE_CAPS: 1 ********
UsagePage: 1
ReportID: 1
IsAlias: 0
BitField: 2
LinkCollection: 1
LinkUsage: 1
LinkUsagePage: 1
IsRange: 0
IsStringRange: 0
IsDesignatorRange: 0
IsAbsolute: 1
HasNull: 0
BitSize: 8
ReportCount: 1
UnitsExp: 0
Units: 0
LogicalMin: 4294967169
LogicalMax: 127
PhysicalMin: 0
PhysicalMax: 0
Usage: 48
StringIndex: 0
DesignatorIndex: 0
DataIndex: 1
******** VALUE_CAPS: 2 ********
UsagePage: 1
ReportID: 1
IsAlias: 0
BitField: 2
LinkCollection: 1
LinkUsage: 1
LinkUsagePage: 1
IsRange: 0
IsStringRange: 0
IsDesignatorRange: 0
IsAbsolute: 1
HasNull: 0
BitSize: 8
ReportCount: 1
UnitsExp: 0
Units: 0
LogicalMin: 4294967169
LogicalMax: 127
PhysicalMin: 0
PhysicalMax: 0
Usage: 52
StringIndex: 0
DesignatorIndex: 0
DataIndex: 2
******** VALUE_CAPS: 3 ********
UsagePage: 1
ReportID: 1
IsAlias: 0
BitField: 2
LinkCollection: 1
LinkUsage: 1
LinkUsagePage: 1
IsRange: 0
IsStringRange: 0
IsDesignatorRange: 0
IsAbsolute: 1
HasNull: 0
BitSize: 8
ReportCount: 1
UnitsExp: 0
Units: 0
LogicalMin: 4294967169
LogicalMax: 127
PhysicalMin: 0
PhysicalMax: 0
Usage: 51
StringIndex: 0
DesignatorIndex: 0
DataIndex: 3
******** VALUE_CAPS: 4 ********
UsagePage: 1
ReportID: 1
IsAlias: 0
BitField: 3
LinkCollection: 1
LinkUsage: 1
LinkUsagePage: 1
IsRange: 0
IsStringRange: 0
IsDesignatorRange: 0
IsAbsolute: 1
HasNull: 0
BitSize: 5
ReportCount: 1
UnitsExp: 0
Units: 0
LogicalMin: 0
LogicalMax: 7
PhysicalMin: 0
PhysicalMax: 0
Usage: 57
StringIndex: 0
DesignatorIndex: 0
DataIndex: 4
000B003D keyboard: '\\?\ACPI#PNP0303#3&2b8e0b4b&0#{884b96c3-56ef-11d1-bc8c-00a0c91405dd}'
type=7 sub=0 mode=1 fkeys=12 indicators=3 tkeys=101
000B0039 mouse: '\\?\HID#VID_046D&PID_C01B#6&2d8c24ad&0&0000#{378de44c-56ef-11d1-bc8c-00a0c91405dd}'
id=256 buttons=6 hw=0 rate=0
'Logitech HID-compliant MX310 Optical Mouse' ('\\?\HID#VID_046D&PID_C01B#6&2d8c24ad&0&0000#{378de44c-56ef-11d1-bc8c-00a0c91405dd}')
'Standardtastatur (PS/2)' ('\\?\ACPI#PNP0303#3&2b8e0b4b&0#{884b96c3-56ef-11d1-bc8c-00a0c91405dd}')
Logitech HID-compliant MX310 Optical Mouse: (046D/C01B)
00 000 'X Axis' (0, [0 - 0, 0 - 0, 0 0 0])
01 001 'Y Axis' (1, [0 - 0, 0 - 0, 0 0 0])
02 002 'Wheel' (2, [0 - 0, 0 - 0, 0 0 0])
03 003 'HWheel' (3, [0 - 0, 0 - 0, 0 0 0])
00 000 'Button 1' (0)
01 001 'Button 2' (1)
02 002 'Button 3' (2)
03 003 'Button 4' (3)
04 004 'Button 5' (4)
05 005 'Button 6' (5)
02 002 'Wheel [-]' (1004)
02 002 'Wheel [+]' (1005)
03 003 'HWheel [-]' (1006)
03 003 'HWheel [+]' (1007)
Retro Adapter: (8282/3201)
30 048 'X Axis' (96, [-127 - 127, 0 - 0, 8 0 0])
31 049 'Y Axis' (98, [-127 - 127, 0 - 0, 8 0 0])
33 051 'X Rotation' (102, [-127 - 127, 0 - 0, 8 0 0])
34 052 'Y Rotation' (104, [-127 - 127, 0 - 0, 8 0 0])
39 057 'Hat Switch (X)' (114, [0 - 7, 0 - 0, 5 0 0])
39 057 'Hat Switch (Y)' (115, [0 - 7, 0 - 0, 5 0 0])
01 001 'Button 1' (2)
02 002 'Button 2' (4)
03 003 'Button 3' (6)
04 004 'Button 4' (8)
05 005 'Button 5' (10)
06 006 'Button 6' (12)
07 007 'Button 7' (14)
08 008 'Button 8' (16)
09 009 'Button 9' (18)
0A 010 'Button 10' (20)
0B 011 'Button 11' (22)
0C 012 'Button 12' (24)
0D 013 'Button 13' (26)
0E 014 'Button 14' (28)
0F 015 'Button 15' (30)
10 016 'Button 16' (32)
30 048 'X Axis [-]' (1096)
30 048 'X Axis [+]' (1097)
31 049 'Y Axis [-]' (1098)
31 049 'Y Axis [+]' (1099)
33 051 'X Rotation [-]' (1102)
33 051 'X Rotation [+]' (1103)
34 052 'Y Rotation [-]' (1104)
34 052 'Y Rotation [+]' (1105)
39 057 'Hat Switch (X) [-]' (1116)
39 057 'Hat Switch (X) [+]' (1117)
39 057 'Hat Switch (Y) [-]' (1118)
39 057 'Hat Switch (Y) [+]' (1119)
RAWINPUT test ok, usage=2
RAWINPUT test ok, usage=6
DirectInput enumeration.. Game controllers..
Windowsmouse initialization..
Catweasel joymouse initialization..
wintab tablet initialization..
Tablet: no wintab32.dll
end
Max Z3FastRAM 2048M. Total physical RAM 2046M
load config 'F:\EMULATION\AMIGA\Configurations\default.uae':0
load failed
failed to load config 'F:\EMULATION\AMIGA\Configurations\default.uae'
LCD: Logitech LCD system not detected
'F:\EMULATION\AMIGA\Configurations\configuration.cache' loaded successfully
Entering GUI idle loop
load config 'F:\EMULATION\AMIGA\Configurations\Host\Fullscreen (800x600).uae':2
load config 'F:\EMULATION\AMIGA\Configurations\Proton2.UAE':0
Log (enabled): 'C:\Users\Public\Documents\Amiga Files\WinUAE\winuaelog.txt'

Last edited by plasmatron; 30 June 2012 at 15:58.
plasmatron is offline  
Old 29 June 2012, 20:53   #10
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 23,808
Do you really use obsolete beta version?
Toni Wilen is online now  
Old 30 June 2012, 14:11   #11
plasmatron
Zone Friend
plasmatron's Avatar
 
Join Date: May 2003
Location: Germany
Age: 44
Posts: 958
What Oh shit I really thought I use 2,4,1, coz I copied the latest zipm archive into my exsisting winuae folder. But it seems it was still running beta 6 OK I deleted the exe and extracted the latest zip and now I`m running the latest version.
Testing now.................
plasmatron is offline  
Old 30 June 2012, 15:58   #12
plasmatron
Zone Friend
plasmatron's Avatar
 
Join Date: May 2003
Location: Germany
Age: 44
Posts: 958
Ok tested with latest version (2,4,1). Sadly its almost the same.
Strange thing is, when I have the crackling sound and I switsh between diferent drivers )wasapi to dsound), everything running fine again for some time (20min). But than it starts to go into yellows and reds again
I also noticed that when I use dsound its not that bad sounding as when I use wasapi drivers. But it still crackles and really not a pleasure to listen to

@Toni
I have pasted an updated bootlog in my previous bootlog post.
I hope you can fix it for me, or give me some other tips to solve this
plasmatron is offline  
Old 30 June 2012, 19:47   #13
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 23,808
Sound drivers updated?

Does both sound "cards" have same problem? (Realtek and whatever that USB Audio Codec is)
Toni Wilen is online now  
Old 02 July 2012, 18:14   #14
plasmatron
Zone Friend
plasmatron's Avatar
 
Join Date: May 2003
Location: Germany
Age: 44
Posts: 958
Quote:
Originally Posted by Toni Wilen View Post
Sound drivers updated?

Does both sound "cards" have same problem? (Realtek and whatever that USB Audio Codec is)
Also with latest realtek drivers its still the same.
Yes the usb soundcars also produces the crackling.
plasmatron is offline  
Old 06 July 2012, 01:38   #15
plasmatron
Zone Friend
plasmatron's Avatar
 
Join Date: May 2003
Location: Germany
Age: 44
Posts: 958
Please Toni dont leave me alone:-)
The only thing that causes sound bugs on my system is only winuae atm.
So I cant see a driver issue here???
plasmatron is offline  
Old 06 July 2012, 08:12   #16
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 23,808
Quote:
Originally Posted by plasmatron View Post
Please Toni dont leave me alone:-)
The only thing that causes sound bugs on my system is only winuae atm.
So I cant see a driver issue here???
Not necessarily. Generating sound on the fly in very short pieces vs most other programs playing pre-generated samples is totally different.

Probably yet another power saving weirdness if the problem is always exactly same, winuae sound settings having no effect.

Does it happen both in standard a500 emulation mode and fast amiga setup mode?

btw, answer also SND% or buffer size questions, thanks.
Toni Wilen is online now  
Old 05 September 2012, 15:47   #17
plasmatron
Zone Friend
plasmatron's Avatar
 
Join Date: May 2003
Location: Germany
Age: 44
Posts: 958
Quote:
Originally Posted by Toni Wilen View Post
Not necessarily. Generating sound on the fly in very short pieces vs most other programs playing pre-generated samples is totally different.

Probably yet another power saving weirdness if the problem is always exactly same, winuae sound settings having no effect.

Does it happen both in standard a500 emulation mode and fast amiga setup mode?

btw, answer also SND% or buffer size questions, thanks.
Yes Toni its the same on all amiga types.
All sound problems seem to start when winuae is running for about 10 minutes.
after that, the SND% is constandly in the reds. Cant read the numbers realy, coz it is changing in nanoseconds:-)
plasmatron is offline  
Old 05 September 2012, 19:12   #18
lesta_smsc
Registered User

lesta_smsc's Avatar
 
Join Date: Feb 2012
Location: United Kingdom
Posts: 2,179
Try choosing different option e.g. direct sound rather than your existing set up.
lesta_smsc is online now  
Old 05 September 2012, 20:27   #19
plasmatron
Zone Friend
plasmatron's Avatar
 
Join Date: May 2003
Location: Germany
Age: 44
Posts: 958
Quote:
Originally Posted by lesta_smsc View Post
Try choosing different option e.g. direct sound rather than your existing set up.

I tried all available options/drivers Toni. All with the same result.
Also all other emus I run, sare sounding great.
CCS64, MAME, bsnes, Magic Engine, Speculator, etc etc.
So why does it only occur on winuae?
plasmatron is offline  
Old 05 September 2012, 22:09   #20
lesta_smsc
Registered User

lesta_smsc's Avatar
 
Join Date: Feb 2012
Location: United Kingdom
Posts: 2,179
Any possibility this is due the Windows version you're using... e.g. tried running under compatibility mode. Also, I'm not sure if this is the same with WinUAE, but very occasionally there are problems arising from multi-core CPUs. Would be worth trying to go to MSCONFIG (then inside go to Boot > Advanced options > number of processors = 1) or similar and try again - this was the case for me with another piece of software where I had similar issues, but not saying this will work but worth trying.
lesta_smsc is online now  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Floppy drive sound vs sound emulation mark_k support.WinUAE 4 14 November 2016 11:36
Crackling sounds :( Edwooger New to Emulation or Amiga scene 3 23 July 2013 18:53
Sound is muffled after boot until change of settings - sound filter emulation issue? rsn8887 support.WinUAE 1 30 May 2010 20:44
sound buffer does it delay the sound? Vars191 support.WinUAE 2 07 December 2008 12:03
Crackling sound on my A4000T... who does repairs ?? Kristian95 support.Hardware 2 13 May 2008 02:50

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:46.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.15492 seconds with 16 queries