English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 16 March 2006, 08:24   #1
Olecranon
Registered User
 
Join Date: Feb 2006
Location: Wisconsin - USA
Age: 52
Posts: 86
Softkicking KS 3.1 V40.63

Not sure if this is the best forum for this question, but since I'm not emulating it seemed the best option.

I have a kickstart V3.1 rom chip, but I would rather softkick the ROM than tear my machine apart and install the chip. I have more than enough ram, so I might as well use it. This would also give me the flexibility of using the onboard KS when booting off a floppy. I used Zkick for years and it was great for compatibility.

My system is an A2000 with an IVS Vector 030 accellerator. This card has the full 68030 w/MMU. It also loads the kickstart on the motherboard into 32 bit memory via hardware (no command in the startup-sequence is needed).

I have obtained a KS 3.1 V40.63 rom file and have tried to use the setcpu kickrom command to load the file. When I do this my screen turns gray and my power light flashed, then the machine locks.

I checked the docs for Skick345 but it appears that it only works with non MMU based systems. I'm pretty sure Zkick will only work with KS 2.04?

Finally, could the ROM file itself be in the wrong format? I think it came from the Amiga forever package but I'm not sure. Does anyone have any suggestions besides installing the chip

I've thought about installing the chip and using a program to dump the kickstart to a disk, but at that point I might as well leave it in there.

Thanks
Olecranon is offline  
Old 16 March 2006, 08:31   #2
AMIGAZ
Amiga-Mad
AMIGAZ's Avatar
 
Join Date: Oct 2004
Location: Sweden
Age: 43
Posts: 1,286
Send a message via ICQ to AMIGAZ
Quote:
Originally Posted by Olecranon
Not sure if this is the best forum for this question, but since I'm not emulating it seemed the best option.

I have a kickstart V3.1 rom chip, but I would rather softkick the ROM than tear my machine apart and install the chip. I have more than enough ram, so I might as well use it. This would also give me the flexibility of using the onboard KS when booting off a floppy. I used Zkick for years and it was great for compatibility.

My system is an A2000 with an IVS Vector 030 accellerator. This card has the full 68030 w/MMU. It also loads the kickstart on the motherboard into 32 bit memory via hardware (no command in the startup-sequence is needed).

I have obtained a KS 3.1 V40.63 rom file and have tried to use the setcpu kickrom command to load the file. When I do this my screen turns gray and my power light flashed, then the machine locks.

I checked the docs for Skick345 but it appears that it only works with non MMU based systems. I'm pretty sure Zkick will only work with KS 2.04?

Finally, could the ROM file itself be in the wrong format? I think it came from the Amiga forever package but I'm not sure. Does anyone have any suggestions besides installing the chip

I've thought about installing the chip and using a program to dump the kickstart to a disk, but at that point I might as well leave it in there.

Thanks
Each Amiga model has it's on Kickstart version, for example the kickstart in Amiga 500 & 2000 is the same so maybe your kickstart rom file is from an A1200 or A4000, think the kickstart file from A500/A2000 should be 256k since it's only one chip
AMIGAZ is offline  
Old 16 March 2006, 08:41   #3
Olecranon
Registered User
 
Join Date: Feb 2006
Location: Wisconsin - USA
Age: 52
Posts: 86
According to my understanding, the A500/A2000 version of 3.1 is V40.63. Its a 512K Rom, but its 16bit so there is only one chip. My friend who gave it to me was sure it was the right version. He knew that V40.68 (the A1200 version of KS3.1) wouldn't work.
Olecranon is offline  
Old 16 March 2006, 10:41   #4
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 6,031
Quote:
It also loads the kickstart on the motherboard into 32 bit memory via hardware (no command in the startup-sequence is needed).
You first have to disable the hardware maprom function (so that a command in the startup-sequence is needed). You cannot use both at the same time.
thomas is offline  
Old 17 March 2006, 17:47   #5
Olecranon
Registered User
 
Join Date: Feb 2006
Location: Wisconsin - USA
Age: 52
Posts: 86
There is a jumper on the 030 card that was supposed to disable the hardware maprom option, but the manual states that it is not implemented at this time. I can disable the option through the Vectors boot menu, but I would have to do this everytime I cold boot the machine. This isn't a problem though. I simply want to try it to see if I like it before ripping my machine apart.

Even after turning off the maprom function, I am still unable to get it to work. I've tried softboot, and setcpu. Mkick wont work because I have a 2.04 rom installed and it only works under 1.X

Any other suggestions?
Olecranon is offline  
Old 30 August 2013, 18:07   #6
sayasupacrew
Registered User
sayasupacrew's Avatar
 
Join Date: Jul 2009
Location: noirmoutier france
Age: 50
Posts: 41
you need the tools converter rom zkf2kf image that works well zkick

it is available in the archive on the site ykick aminet
sayasupacrew is offline  
Old 30 August 2013, 18:11   #7
demolition
Unregistered User
demolition's Avatar
 
Join Date: Sep 2012
Location: Copenhagen / DK
Age: 40
Posts: 4,071
Olecranon hasn't been active since November 2007, so I don't think he'll see your answer.. Besides I couldn't really make sense of what you wrote?
demolition is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kick 3.1 v40.63 green screen in WinUAE Photon support.WinUAE 14 19 October 2009 11:09
Softkicking 3.1 on GVP 030 MagerValp support.Hardware 7 21 August 2008 10:16
help with softkicking on startup Lips2k8 support.Other 12 06 May 2008 17:58
Softkicking 3.1 on a A600 kickstart 2.04 machine Smiley support.Hardware 16 11 February 2007 16:05
Kickstart 3.1 v40.70 Stig support.WinUAE 5 26 March 2005 18:31

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:57.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.08049 seconds with 15 queries