English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 22 July 2018, 13:05   #41
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 23,908
Quote:
Originally Posted by Torkio View Post
Hi, I've got another question about the new beamracing v-sync.
As far as I understood , the beamracing v-sync works only with full screen and full size picture so if you use fullscreen but you want to reduce the picture ( I do so to practice Kick Off 2 in the original 1084S size to not lose the habit, the moment you play on real hardware) you are going to see tearing.
Perhaps is there e plan to have beamracing working also in scaled size?
Thanks
Vertical adjustment should not anymore cause tearing (at least when it isn't excessive). Check it with END+F9 debug colors, positions should change with display size.
Toni Wilen is online now  
Old 23 July 2018, 12:07   #42
Torkio
Registered User
 
Join Date: Jan 2007
Location: Italy
Posts: 51
Quote:
Originally Posted by Toni Wilen View Post
Vertical adjustment should not anymore cause tearing (at least when it isn't excessive). Check it with END+F9 debug colors, positions should change with display size.
Very interesting this debug option! thanks to let me know!

I attacked a couple of picture of the screen that show the tear in the last slice. It is not a total rip as I see many times v-sync is able to pull the tear on sync but the tear happens though . I see many times the colours of the 4th slice to disappear.

Last edited by Torkio; 28 August 2018 at 14:36.
Torkio is offline  
Old 14 June 2020, 19:06   #43
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 48
Posts: 11,992
I didn't want to start a new thread for this:


I finally got a 144Hz monitor. I get app. 40-45% CPU usage emulating an A1200 in 50Hz with Beam Racing = 4 Slices (DX11). But with the same config in 100Hz it's app. 75-80% usage. Is it supposed to happen? Seems a bit high for a Ryzen 5 3600.

Last edited by Retro-Nerd; 16 June 2020 at 17:13.
Retro-Nerd is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
My game, Gravity Beam for A500 MrD project.Amiga Game Factory 43 20 November 2016 16:04
Were there any Amiga games that were "racing the beam" the Atari2600 way? Dr.Venom Nostalgia & memories 7 04 November 2016 12:36
All Terrain Racing - Error starting from Fullscreen Vsync cybermat support.WinUAE 6 10 January 2008 00:18
Xtreme Racing question macce2 support.Games 3 05 July 2007 18:03
Quick Vsync question.. Christian support.WinUAE 11 16 August 2004 20:33

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:01.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.06693 seconds with 14 queries