English Amiga Board


Go Back   English Amiga Board > Requests > request.Other

 
 
Thread Tools
Old 04 January 2012, 19:13   #1
fuzzylogic
Registered User
 
Join Date: Jan 2010
Location: Germany
Posts: 59
Amiga Viruses

Hi dudes,

We are running a website for preservation and analysis of amiga viruses: "The Amiga Virus Encyclopedia" at http://www.teyko.com.

We still miss some viruses. If you ever stumble across a virus we do not have (viruses missing are marked with a red icon) please send it over to us.

tia & thanks for your support.
fuzzylogic is offline  
Old 08 January 2012, 16:44   #2
mai
Registered User
 
Join Date: Feb 2008
Location: Federativnaya Respublika Germaniya
Posts: 4,895
At least SystemZ 5.1, SystemZ 5.3, and SystemZ 6.5 are contained in current TOSEC collection.

One question: Are those rare viruses, which you are looking for, recognized by any Anti virus program?
I am asking, because i have checked thousands disks in the past and my Anti virus program never found those viruses.
mai is online now  
Old 09 January 2012, 05:22   #3
fuzzylogic
Registered User
 
Join Date: Jan 2010
Location: Germany
Posts: 59
We have most bootblock viruses. The ones you mention are very old (in fact not really) bootblock-viruses.

Currently we are looking for link/file-viruses like BEOL or Hitch-Hicker which have been made maybe around 1996 to 1999 (I would guess).

They should be found by good AV ware (some of the above a using polymorphic techniques which means not every average AV is able to find them).

This means primary target are archives (lha/lzx etc) which were uploaded to BBS systems around 96-99 rather than dms/adf files included in TOSEC.

In BBS systems these days there were alot of .txt-files with warnings of infected stuff which has been uploaded, sadly (at least for us ) most of this archives were nuked afterwards.
fuzzylogic is offline  
Old 09 January 2012, 09:43   #4
Minuous
Coder/webmaster/gamer
Minuous's Avatar
 
Join Date: Oct 2001
Location: Canberra/Australia
Posts: 2,034
There seems to be a problem with that site; whenever I try to get to another page (eg. the 2nd page) I get the following:

Serverfehler in der Anwendung /.
Fehler bei der Validierung von ViewState-MAC. Wenn diese Anwendung von einer Webfarm oder einem Cluster gehostet wird, stellen Sie sicher, dass die <machineKey>-Konfiguration den gleichen validationKey und Validierungsalgorithmus angibt. AutoGenerate kann in einem Cluster nicht verwendet werden.
Beschreibung: Unbehandelte Ausnahme beim Ausführen der aktuellen Webanforderung. Überprüfen Sie die Stapelüberwachung, um weitere Informationen über diesen Fehler anzuzeigen und festzustellen, wo der Fehler im Code verursacht wurde.

Ausnahmedetails: System.Web.HttpException: Fehler bei der Validierung von ViewState-MAC. Wenn diese Anwendung von einer Webfarm oder einem Cluster gehostet wird, stellen Sie sicher, dass die <machineKey>-Konfiguration den gleichen validationKey und Validierungsalgorithmus angibt. AutoGenerate kann in einem Cluster nicht verwendet werden.

Quellfehler:

[Keine relevanten Quellzeilen]


Quelldatei: c:\windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\f3272b19\a57b750f\App_Web_asckz3oo.1.cs Zeile: 0

Stapelüberwachung:

[ViewStateException: Ungültiger ViewState.
Client IP: 120.18.137.9
Port: 1441
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
ViewState: /wEPDwUKMTgxODQ2NDkyOQ9kFgJmD2QWAgIDD2QWBAIDD2QWBAILDzwrAAcBAA8WAh4OXyFVc2VWaWV3U3RhdGVnZBYCZg9kFgJmD2QWAgIBD2QWAmYPZBYCZg9kFgRmD2QWAmYPZBYEAgEPFgIeC18hSXRlbUNvdW50AhRkAgMPPCsABwEADxYCHwBnZGQCAQ9kFgJmD2QWAgIDDxYCHgRUZXh0BZ4BQ3VycmVudGx5ICgwOS4wMS4yMDEyIDA5OjMzKSB0aGVyZSBhcmUgNTQzIHZpcnVzZXMgaW4gdGhlIEEuVi5FLiBkYXRhYmFzZSwgd2hlcmUgMTY5IGFyZSBtaXNzaW5nIGFuZCAxOTMgaGF2ZSBiZWVuIGZ1bGx5IGFuYWx5emVkIChhbmFseXphdGlvbi1yYXRlID0gMzUsNTQlKS5kAg0PD2QPEBYEZgIBAgICAxYEFgIeDlBhcmFtZXRlclZhbHVlZBYCHwNkFgIfA2QWAh8DZBYEAgUCBQIFAgVkZAIFDxYCHwIFBTEuMC42ZBgCBR5fX0NvbnRyb2xzUmVxdWlyZVBvc3RCYWNrS2V5X18WAQUXY3RsMDAkY3BBdmVNYWluJHBnSW5kZXgFJGN0bDAwJGNwQXZlTWFpbiRwZ0luZGV4JHBnVmlydXNJbmRleA8UKwAEZGYCnwRmZF9qMPQiWHGWzu8fegC3uvCT1Rhd
Referer: http://www.teyko.com/
Path: /Index.aspx]

[HttpException (0x80004005): Fehler bei der Validierung von ViewState-MAC. Wenn diese Anwendung von einer Webfarm oder einem Cluster gehostet wird, stellen Sie sicher, dass die <machineKey>-Konfiguration den gleichen validationKey und Validierungsalgorithmus angibt. AutoGenerate kann in einem Cluster nicht verwendet werden.]
System.Web.UI.ViewStateException.ThrowError(Exception inner, String persistedState, String errorPageMessage, Boolean macValidationError) +106
System.Web.UI.ViewStateException.ThrowMacValidationError(Exception inner, String persistedState) +14
System.Web.UI.ObjectStateFormatter.Deserialize(String inputString) +237
System.Web.UI.ObjectStateFormatter.System.Web.UI.IStateFormatter.Deserialize(String serializedState) +4
System.Web.UI.Util.DeserializeWithAssert(IStateFormatter formatter, String serializedState) +37
System.Web.UI.HiddenFieldPageStatePersister.Load() +207
System.Web.UI.Page.LoadPageStateFromPersistenceMedium() +105
System.Web.UI.Page.LoadAllState() +43
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +6785
System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +242
System.Web.UI.Page.ProcessRequest() +80
System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context) +21
System.Web.UI.Page.ProcessRequest(HttpContext context) +49
ASP.index_aspx.ProcessRequest(HttpContext context) in c:\windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\f3272b19\a57b750f\App_Web_asckz3oo.1.cs:0
System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +181
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +75

Versionsinformationen: Microsoft .NET Framework-Version:2.0.50727.5448; ASP.NET-Version:2.0.50727.5420
Minuous is online now  
Old 09 January 2012, 17:12   #5
MrCheese
Registered User
 
Join Date: Dec 2011
Location: Manchester
Posts: 91
Going to http://www.teyko.com/ and clicking on a virus name gives me a new page about the virus no problem.

Reading this thread makes me wonder if there is a good anti-virus package that can be installed. I'm going to be using classic wb on an a1200.
MrCheese is offline  
Old 09 January 2012, 17:34   #6
Bamiga2002
BlizzardPPC'less

Bamiga2002's Avatar
 
Join Date: May 2004
Location: Finland
Age: 42
Posts: 3,210
Send a message via MSN to Bamiga2002
VirusZ III http://www.dstoecker.eu/antivirus.html is propably still the best one.
Bamiga2002 is offline  
Old 09 January 2012, 19:30   #7
fuzzylogic
Registered User
 
Join Date: Jan 2010
Location: Germany
Posts: 59
Quote:
Originally Posted by Minuous View Post
There seems to be a problem with that site; whenever I try to get to another page (eg. the 2nd page) I get the following:
yeah we already told this the page coder but he is busy atm and cant fix this issue :-/ (sometimes this error occurs)
fuzzylogic is offline  
Old 09 January 2012, 19:38   #8
fuzzylogic
Registered User
 
Join Date: Jan 2010
Location: Germany
Posts: 59
Quote:
Originally Posted by MrCheese View Post
Going to http://www.teyko.com/ and clicking on a virus name gives me a new page about the virus no problem.

Reading this thread makes me wonder if there is a good anti-virus package that can be installed. I'm going to be using classic wb on an a1200.
Well the best AV ware is/was VT made by Heiner Schneegold (R.I.P.) - the problem is that it is only in german.

Other good AV ware was VirusWorkshop by Flake/TRSi although now outdated.

Well, I don't think there are any of the problematic viruses in the wild anymore but well yes there are viruses which cannot be found that easily because of polymorphic routines.

For example
http://www.teyko.com/View.aspx?id=43...Neurotic+Death

Or

http://www.teyko.com/View.aspx?id=487&name=Liquid+Acid
fuzzylogic is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need some help regarding Amiga viruses. ElectroBlaster Amiga scene 9 19 March 2013 23:33
Viruses question chunky_tesco support.WinUAE 5 09 September 2004 09:51
Checking WinUAE/Real Amiga files for viruses. Bloodwych support.WinUAE 6 12 January 2002 09:34

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:08.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.10907 seconds with 13 queries