English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 28 October 2016, 03:10   #1
MrD
Registered User
MrD's Avatar
 
Join Date: May 2009
Location: UK
Posts: 58
A1200 can't reset from Ctrl+A+A, keyboard problem?

My A1200 no longer responds to the Ctrl+A+A reset sequence. All the rest of the keys on the keyboard seem to be functioning though.

Is this a keyboard issue, maybe? (Or something more scary like one of the other chips?) Should I open the case and try reseating or cleaning the keyboard ribbon?
MrD is offline  
AdSense AdSense  
Old 28 October 2016, 03:47   #2
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
there was another thread with the issue, no solution from what i see,
but something to read.
a test disk, with a keyboard test, i've put into the zone: A1200-Diag.dms
boot the disk, it will show a "showconfig" output and after some seconds a requester comes up,
choose "Standard" and a test program will start, "click mouse" on first screen, next is a keyboard test.
here you should be able to see, if the keys in question gives answer.
push one key after the other and look if they get highlighted on the screen.
emufan is offline  
Old 28 October 2016, 04:11   #3
MrD
Registered User
MrD's Avatar
 
Join Date: May 2009
Location: UK
Posts: 58
Thanks! I've got the A1200 out so I'll try this asap.
MrD is offline  
Old 28 October 2016, 04:49   #4
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
Quote:
Originally Posted by MrD View Post
Thanks! I've got the A1200 out so I'll try this asap.
np, maybe someone can make some conclusion from the results.
emufan is offline  
Old 28 October 2016, 05:25   #5
MrD
Registered User
MrD's Avatar
 
Join Date: May 2009
Location: UK
Posts: 58
According to the diag, the bottom-leftmost keys Ctrl, Left Shift, Left Alt and Left Amiga are all non-responsive. Guess it's a broken trace in the membrane over there.
MrD is offline  
Old 28 October 2016, 12:39   #6
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
Quote:
Originally Posted by MrD View Post
According to the diag, the bottom-leftmost keys Ctrl, Left Shift, Left Alt and Left Amiga are all non-responsive. Guess it's a broken trace in the membrane over there.
this is possible, but wait until someone more skilled will confirm- before you start fixing.
if you are going to inspect the keyboard cable, ensure you lift the white cage of the
keyboard ribbon connector, before you pull the ribbon.
just create some photos of the ribbon, may happen we can see some cracks in a closeup.

#1) currently out of stock, but amigakit lists those a1200 keyboard membranes.
emufan is offline  
Old 28 October 2016, 14:12   #7
MrD
Registered User
MrD's Avatar
 
Join Date: May 2009
Location: UK
Posts: 58
Quote:
Originally Posted by emufan View Post
this is possible, but wait until someone more skilled will confirm- before you start fixing.
if you are going to inspect the keyboard cable, ensure you lift the white cage of the
keyboard ribbon connector, before you pull the ribbon.
just create some photos of the ribbon, may happen we can see some cracks in a closeup.
Indeed zif connectors are a nightmare. I had one in a laptop which I had to remove whenever I changed the BIOS battery.

Thanks for the advice about checking for subtle cracks, I'll take a picture when I can.
MrD is offline  
Old 28 October 2016, 17:16   #8
dirkies
Zone Friend

dirkies's Avatar
 
Join Date: Aug 2002
Location: Belgium
Age: 45
Posts: 1,195
or check with a multimeter the trace of the membrane from start to where it goes to the connector. If it does not beep, check the path for cracks. Had this on an A4000 membrane.
dirkies is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
A1200 Keyboard Problem - common causes? CDTV1991 support.Hardware 7 05 December 2012 15:11
A500 keyboard, reset problem orange support.Hardware 10 04 November 2010 19:51
A600 will not do a warm reset - Ctrl-Amiga - Amiga kipper2k support.Hardware 24 29 September 2009 13:02
A1200 keyboard problem gizmomelb support.Hardware 2 17 January 2007 11:35
A1200 Keyboard problem Peanutuk support.Hardware 8 26 January 2004 09:46

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:25.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06888 seconds with 15 queries