English Amiga Board


Go Back   English Amiga Board > Main > Amiga scene

 
 
Thread Tools
Old 12 February 2018, 13:44   #101
spudje
Registered User

 
Join Date: Dec 2014
Location: Netherlands
Posts: 995
Super, that sounds like something even I can manage Thanks!!!
spudje is offline  
Old 14 February 2018, 15:28   #102
Steril707
Tigerskunk!

Steril707's Avatar
 
Join Date: Sep 2016
Location: Amiga Island
Posts: 1,089
Thanks dudes, this thread is super inspiring for me for building a 3.x system again..

Last edited by Steril707; 15 February 2018 at 09:19.
Steril707 is offline  
Old 02 April 2018, 17:26   #103
TuKo
Apollo Team

TuKo's Avatar
 
Join Date: May 2014
Location: not far
Posts: 270
Just toying around this weekend, any one got the TRANSPARENT tooltype of WBStartup++ to work ? I am on OS3.9bb4
TuKo is offline  
Old 02 April 2018, 18:13   #104
Viceroy
Registered User
 
Join Date: Jul 2006
Location: Sunderland
Posts: 562
Quote:
Originally Posted by cmsj View Post
I'm also interested in doing this, and have made a start with the easy bit - icons. I've never played with things like Birdie before, so I guess that's next



Some quick playing with Birdie/VisualPrefs and the Ken-OS4/Ken-OS4-Lite themes are starting to bear some fruit:



Last post for now. This is coming along quite nicely:

Stunning!
Viceroy is offline  
Old 30 April 2018, 17:25   #105
celco
Registered User

 
Join Date: May 2017
Location: Belgium
Posts: 24
Hello.
I'm still not able to install this nice Afa_oS 4.8 in WinUAE + OS3.9.
Installed OS3.9, All Boing Bags, Picasso, MUI. Used the AFA OS installer. No errors receievd.
Modified the startup-sequence with morelibspace and Afa_OS_Loader at correct places in the file.
Rebooted (warm and cold) and no change to the Workbench at all. Still same icons, backdrop...

Can somebody guide me in the correct way or tell me what I'm doing wrong?

Thanks in advance.

Last edited by celco; 18 June 2018 at 01:48.
celco is offline  
Old 15 October 2018, 23:27   #106
hUMUNGUs
Registered User

 
Join Date: Apr 2016
Location: T√łnsberg / Norway
Posts: 41
celco: too bad no one can help. i have the same problem.
hUMUNGUs is offline  
Old 17 October 2018, 15:54   #107
indigolemon
Bit Copying Bard

indigolemon's Avatar
 
Join Date: Jan 2017
Location: Kelty, Fife, Scotland
Age: 37
Posts: 741
I have never used AFA, I just did it myself. The two apps that make all the difference are:

1 - VisualPrefs - http://aminet.net/package/util/wb/VisualPrefs
This Allows you to change the look of window borders, buttons, gadgets etc

2 - Birdie - http://aminet.net/package/util/wb/birdie2000
Adds pictures to window borders - needed to get the look correct

Finally, you can find suitable configs for these programs in this file:
3 - os4theme - http://aminet.net/package/pix/theme/os4theme
indigolemon is offline  
Old 11 November 2018, 12:09   #108
Madk71
Registered User

 
Join Date: Aug 2017
Location: Essex
Posts: 44
Quote:
Originally Posted by indigolemon View Post
I have never used AFA, I just did it myself. The two apps that make all the difference are:

1 - VisualPrefs - http://aminet.net/package/util/wb/VisualPrefs
This Allows you to change the look of window borders, buttons, gadgets etc

2 - Birdie - http://aminet.net/package/util/wb/birdie2000
Adds pictures to window borders - needed to get the look correct

Finally, you can find suitable configs for these programs in this file:
3 - os4theme - http://aminet.net/package/pix/theme/os4theme

Hi, any chance to have a little help to install all of them. I can't find any advice, at least not clear for me, specially how to use the os4theme.
Thanks

Last edited by Madk71; 11 November 2018 at 16:26.
Madk71 is offline  
Old 11 November 2018, 16:27   #109
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,562
Quote:
Originally Posted by celco View Post
Installed OS3.9, All Boing Bags, Picasso, MUI. Used the AFA OS installer. No errors receievd. Modified the startup-sequence with morelibspace and Afa_OS_Loader at correct places in the file. Rebooted (warm and cold) and no change to the Workbench at all. Still same icons, backdrop....
hUMUNGUs
Quote:
i have the same problem.
Strange expectations that you have. Why should AfA change any icons or the backgrounds? You need to do that manually.

To see whether AfA_OS is really running you can simply start AfA_Prefs. If it opens without complains everything is ok. Otherwise it will tell you that "AfA_OS is not avctive". Or you can use Scout or similar tools and check the task list:
Attached Thumbnails
Click image for larger version

Name:	AfA_tasks.png
Views:	67
Size:	1.8 KB
ID:	60786  
PeterK is offline  
Old 11 November 2018, 18:23   #110
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,246
Quote:
Originally Posted by hUMUNGUs View Post
celco: too bad no one can help. i have the same problem.
Possible that it is so difficult, the only extension AfA-OS you can also install it in OS 3.9 BB4 standard, you only need to insert 2 commands in the WbStartup, copy in the system the Libs folder, Prefs and the folder "AfA_OS_Libs", on restart run AfA- Prefs, choose the skin and save.

To run an AfA-OS system, a 040/060 CPU and an FPU are required.


Here is a 5-minute AfA-OS on a standard OS3.9 bb4, note quality icons and windows (look first screenshot)

Sullo screenshot il mio AfA-OS icon.library with by Peter installed



Last edited by AMIGASYSTEM; 13 January 2019 at 20:10.
AMIGASYSTEM is offline  
Old 02 November 2019, 18:45   #111
Weaselrama
Registered User

 
Join Date: Oct 2019
Location: Neunkirchen aP, DE
Posts: 38
Good Evening from Southern Germany!

Great thread here, if a bit dated. I'd like to see if I can resurrect it somewhat and get some new participation.

First, I never had an interest in making my Bench a 4.1 clone. I simply liked the Mason Merz and similar icon sets and had an interest in integrating TTFonts into my OS 3.9 setup (FS-UAE, A4000, 68040-NOMMU). I've been tweaking it since the beginning of Summer, 2019.

Some call-outs:

1. I was never a fan of the Afa "OS."

2. Some of the WBStart replacements look like they were more trouble than they were worth even back when this thread was new.

3. AMPlifier 2.35 isn't mentioned in the Boing Bags references. It's in the "unofficial" #4 and is well worth the download and installation if you're on a 020/040. You can kiss all that stutter and forced mono you get from AmigaAMP goodbye.

4. LimpidClock: I know my TTF setup is sound. I use the TTFManager Prefs tool. Perhaps it's based on management provided by TTEManager? It's something I'm considering digging into. I've confirmed I have the fonts listed in ToolTypes.

5. I'm reasonably certain MacLikeDock is no longer available.

6. Is chasing transparency in a tool dock that important? Perhaps some may find it to be a nice to have. You can follow in the thread the trouble experienced trying to accomplish this ideal.

I'm interested in ANY updates anyone has and screenies!

Have a great evening wherever you may be!
Weaselrama is offline  
Old 02 November 2019, 18:54   #112
Weaselrama
Registered User

 
Join Date: Oct 2019
Location: Neunkirchen aP, DE
Posts: 38
Apologies - forgot the screenie.
Attached Thumbnails
Click image for larger version

Name:	Submit.jpg
Views:	128
Size:	774.8 KB
ID:	65065  
Weaselrama is offline  
Old 03 November 2019, 08:06   #113
Unkown
The Old Fart!

Unkown's Avatar
 
Join Date: Oct 2019
Location: Last Seen In Purgatory!
Age: 53
Posts: 92
Stunning! Hell yeah i very much like the look, made me smile.
Unkown is offline  
Old 03 November 2019, 10:24   #114
Weaselrama
Registered User

 
Join Date: Oct 2019
Location: Neunkirchen aP, DE
Posts: 38
Just some more thoughts:

What I wrote above is pure personal preference. I want to keep my Bench looking like a 68k Bench and not a 4.1 clone. I think the Merz icons are a perfectly reasonable icon upgrade from what came with OS 3.9 stock.

VisualPrefs allows the windows and window gadgets to come into the 21st century somewhat but I was never interested in those sort of window decorations that reek of Linux window managers so I never incorporated Afa or Birdie into my setup. What YOU do is your business and I'll help if I can.

I'm *always* tweaking. After I took the screenshot above I switched out the HTML fonts in iBrowse 2.5.1. to TT sans serif fonts since that's what the modern Web uses for the most part.

I'd be interested to know what you use for your TTF manager. TTFManager? TTEManager? Some other app? TTFs work pretty well in my configuration.

One last thing: Some of the earlier screenies posted reveal that there should be a complete set of Merz Prefs icons which match OS 3.9. prefs tools. As you can see, I have 95% of them but I'm missing a few and I'm reasonably sure I have all available Merz icon sets.

That's it - I hope we can bring this thread back to life. Cheers!
Weaselrama is offline  
Old 03 November 2019, 10:28   #115
Weaselrama
Registered User

 
Join Date: Oct 2019
Location: Neunkirchen aP, DE
Posts: 38
Smile

Quote:
Originally Posted by Unkown View Post
Stunning! Hell yeah i very much like the look, made me smile.
I'm honored! I'm glad you liked it.
Weaselrama is offline  
Old 03 November 2019, 10:46   #116
Unkown
The Old Fart!

Unkown's Avatar
 
Join Date: Oct 2019
Location: Last Seen In Purgatory!
Age: 53
Posts: 92
Quote:
Originally Posted by Weaselrama View Post
I'm honored! I'm glad you liked it.



Your Very Welcome Sir!.
Unkown is offline  
Old 03 November 2019, 13:43   #117
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,562
Quote:
Originally Posted by Weaselrama View Post
One last thing: Some of the earlier screenies posted reveal that there should be a complete set of Merz Prefs icons which match OS 3.9. prefs tools. As you can see, I have 95% of them but I'm missing a few and I'm reasonably sure I have all available Merz icon sets.
There are lots of OS 4.x icons designed in the Merz style made by other artists like IconDesigner or Cha05e90 for example at OS4Depot:

http://www.os4depot.net/?function=br...date&order=asc

and at AmigaLook:

http://www.amiga-look.org/category/os4
PeterK is offline  
Old 04 November 2019, 14:06   #118
Weaselrama
Registered User

 
Join Date: Oct 2019
Location: Neunkirchen aP, DE
Posts: 38
Quote:
Originally Posted by PeterK View Post
There are lots of OS 4.x icons designed in the Merz style made by other artists like IconDesigner or Cha05e90 for example at OS4Depot:

http://www.os4depot.net/?function=br...date&order=asc

and at AmigaLook:

http://www.amiga-look.org/category/os4
Thanks - I have every last one of them searching for those little boogers! It's possible I missed them. I have all of Ralph's, Ken's, Cha05e90's, and Mason's. I just need to go through all of them again and see if I can locate them. Thanks!
Weaselrama is offline  
Old 04 November 2019, 14:46   #119
Gorf
Registered User

 
Join Date: May 2017
Location: Munich/Bavaria
Posts: 869
Is there a way to get rid of the right and bottom gauges, if they are at 100%?

I would like to have a "cleaner" look. The gauges are telling the user, how much of the contend is displayed in the actual window - but at 100% they are redundant and only add visual noise to the picture.

The "easy" way would be to just not draw the gauges in that case ... but that would leave you with rather thick empty border - the more advanced way would be slim borders (like the one on the left side) for that scenario, that would need to jump to a thicker version a soon as the gouges are needed again....

How would one accomplish that?
Gorf is offline  
Old 18 November 2019, 12:36   #120
Weaselrama
Registered User

 
Join Date: Oct 2019
Location: Neunkirchen aP, DE
Posts: 38
Workbench mod process. I finally located all of the missing 32-bit icons needed to complete moddng-out the Workbench system drawers, including Prefs, thanks to acquiring a full set of system icons from the OS 4.1 install media which I own.

I should note that whenever I used SGrab to take a PNG screenie, resources shoot to 100% in that instant. What is shown in Scout is NOT a reflection of actual resource use. My current FS-UAE Workbench, based on a 68060, is very kind to me. It's fast and efficient in normal use. However, it becomes more and more clear that FS-UAE is not WinUAE. It is a work-in-progress. "Fastest Possible" mode is broken according to Frode but we may see some relief in the upcoming Dev series which promises to incorporate large chunks of new WinUAE code.

I have tested - and eliminated - add-ons which affect my current speed. AfAOS, which I wanted for anti-aliasing and the ability to resize 32-bit icons isn't friendly to the 68060.library. It just slows me down and I've tried the MMULibs version of the 68060.library and it simply further erodes the speed. I don't believe they are the culprits, however - this is an issue with FS-UAE itself. As-is, SysInfo and ShowConfig report my 68060-NOMMU as having an MMU. However, when I install MMULibs, both report the 68060 as having no MMU, which is correct, but which rather defeats the purpose of installing MMU tools in the first place. ?

True, I could go back to using the 68040.library which would likely eliminate these conflicts but I get too many dividends from using a 68060. I'm tickled pink being able to run AMPlifier in stereo mode at 1/2 sample rate. iBrowse is much faster. I've given Netsurf every chance I could give it but alas, it just isn't worth the time. It's just too darn slow to be practical.

I am happy to answer any questions I can. Happy modding!
Attached Thumbnails
Click image for larger version

Name:	EABWB.png
Views:	25
Size:	335.9 KB
ID:	65196  
Weaselrama is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
ECS. Make OS3.1 look like OS3.9 without loosing speed. lukassid support.Apps 21 19 February 2013 01:13
AmiDock in Amiga OS3.9 Location spanner support.Apps 1 19 August 2012 23:26
Amiga OS3.9 Manuals petemaxi Amiga scene 14 05 February 2011 11:28
WANTED Amiga OS3.5 CD Vars191 MarketPlace 2 01 February 2009 08:41
Wanted Amiga OS3.9 Stormrider MarketPlace 2 07 March 2006 08:27

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:23.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.09341 seconds with 14 queries