English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 26 March 2015, 20:13   #1
Minuous
Coder/webmaster/gamer
Minuous's Avatar
 
Join Date: Oct 2001
Location: Canberra/Australia
Posts: 1,834
Screenshots are off by one frame

I have been making a lot of screenshots with WinUAE 3.0.0 and I noticed that the generated screenshots don't actually correspond to what is shown on the screen: they are one frame earlier or later, at least as far as the palette is concerned.

(This causes problems with eg. Druid 2 game when using "Deathland" powerup, which changes the palette every few frames. It is impossible to tell from looking at the WinUAE screen which palette has been saved in the screenshot, necessitating taking a whole series of screenshots in rapid succession and then loading them into a paint program to check whether any of them have the desired palette.)

My apologies if this bug has already been reported: I did a search and noticed that "RTG mode screenshots in 16-bit host color depth mode had wrong colors" has been fixed, but this appears to be a different bug (as the game uses OCS not RTG).
Minuous is offline  
Old 29 March 2015, 18:30   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,109
It is not a bug, at least not if you use "before filtering" option. Screenshot comes from internal buffer, not what you see and depending on display settings (number of backbuffers), delay may be up to 4 frames.

Some kind of burst screenshot option probably is better solution (takes 10 or so screenshot frames automatically).
Toni Wilen is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
F1 grand prix frame rate universale support.Games 18 13 July 2015 22:45
Interlace Basics (Frame Indentification) Plum Coders. General 1 13 May 2013 09:18
Amiga native frame rates mark_k support.WinUAE 6 25 January 2013 15:56
RGB in digital photo frame protek Hardware mods 13 14 August 2009 22:19
Frame Machine ...manual wanted...please? knapster support.Hardware 3 14 March 2002 20:41

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:38.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.32418 seconds with 15 queries