English Amiga Board


Go Back   English Amiga Board > Coders > Coders. System

 
 
Thread Tools
Old 14 February 2020, 16:21   #3221
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,382
Ciao PeterK, Don't call me a pain in the ass

Found anomaly of your icon.library on AfA OS, see full small video

https://drive.google.com/open?id=1a_...NFYn5MTmhmG1Kd
AMIGASYSTEM is offline  
Old 14 February 2020, 17:28   #3222
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,595
Quote:
Don't call me a pain in the ass
What? Where did I do that or why should I say such nonsense?

No Carlo, that's an anomaly of AfA's icon_lib.exe which has no support for the Workbench preferences settings "No ColorIcon" or "No NewIcon" and just ignores these switches. My library and the AmigaOS icon.library are correctly displaying the planar images as intended by this WB option.

Last edited by PeterK; 14 February 2020 at 17:54.
PeterK is offline  
Old 14 February 2020, 17:44   #3223
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,382
Quote:
Originally Posted by PeterK View Post
What? Where did I do that or why should I say such nonsence?
.


it's an Italian expression (spero di non rompere le scatole) when a person thinks he's annoying!


Yes but with the icon.library everything works well
AMIGASYSTEM is offline  
Old 14 February 2020, 18:00   #3224
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,595
Ok, keep your (non)sense of humor. It's not annoying!
PeterK is offline  
Old 16 February 2020, 16:54   #3225
CMTX
Registered User

 
Join Date: Apr 2014
Location: Mallorca es Funki
Posts: 40
Hello thread! I'm sure this has already been discused but hard to tell between 162 pages I'm using the tc_020 version of your library (46.4) with opus5.91 and it eats memory badly. I guess it's a compatability problem with dopus because workbench works fine. Has anyone experienced the same behaviour as me, is there a workaround? Maybe another version of the library or dopus 5.82 works fine, i have to test it yet!

Cheers

Edit: I've tried with the icon.library that comes with os3.1.4 and it shows the same behaviour. Definitely there is something broken on dopus 5.91, i'm gonna try 5.82 hoping everything will be fine

Last edited by CMTX; 16 February 2020 at 17:20.
CMTX is offline  
Old 16 February 2020, 17:40   #3226
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,469
In DOpus 5 preferences you can set several icon related settings that might be worth a check.
daxb is offline  
Old 16 February 2020, 19:50   #3227
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,595
No, it's the sad truth, but DOpus5 has several bugs causing memory losses, no matter whether you use v5.8 or v5.9. The latter has fixed some old bugs and introduced new ones instead. I would not recommend 5.9.

DOpus5 has a small FastMem leak when you open and close windows with icons, but it also has a huge leak when you just drag icons around on the screen, which causes really heavy memory losses.

Sorry, but I don't want to fix these bugs in DOpus5. PCs have enough memory nowadays to live with it for some hours.

In any case, I prefer to use the Workbench or Windows. At least on Aros 68k DOpus5 is still a better choice than Wanderer.

Last edited by PeterK; 16 February 2020 at 20:00.
PeterK is offline  
Old 16 February 2020, 21:45   #3228
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,595
Update to icon.library 46.4.522:

Upgraded the HAM6 and HAM8 versions to v51 in order to display the Eastern picture preview icons in full HAM quality instead of dithered images. Of course, I know that a HAM-WB is more a tech demo than something useful, but picture files are the best to demonstrate that. You can compare the results with the v46 versions and tell me what you'd like to have in future.

The "Alpha" version has been renamed to "Aros" now and I've added some more support for Wanderer, which is treated like a replacement for the Workbench task. With this trick Wanderer can also avoid the color reduction and delay the color mapping of the second image in the same way as the Workbench. The usage of FastMem is now enabled by default on Aros. Nevertheless, Wanderer is still slower than DOpus5 on the same system and much slower than WB on AmigaOS 3.x.

The other target versions have no functional changes, as I hope.
PeterK is offline  
Old 16 February 2020, 23:02   #3229
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,382
Quote:
Originally Posted by PeterK View Post
In any case, I prefer to use the Workbench or Windows. At least on Aros 68k DOpus5 is still a better choice than Wanderer.

I wouldn't so much agree



https://drive.google.com/file/d/1ogE...J4x7wdi6P/view


https://drive.google.com/file/d/15kS...WU5ncHRAN/view
AMIGASYSTEM is offline  
Old 16 February 2020, 23:24   #3230
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,595
Quote:
Originally Posted by AMIGASYSTEM View Post
I wouldn't so much agree
Well, I'm already happy if you would agree a little bit ...

Btw, how fast is your PC? Maybe an i9 with 5 GHz?
Or is your Wanderer running in a data processing center in the cloud?
PeterK is offline  
Old 16 February 2020, 23:37   #3231
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,382
Old PC

Pentium (R) Dual-Core CPU E6300 2.80 GHz
RAM 4 GB
OS Win7 32 Bit
Video Card ATI Radeon HD 5450

In the video your Library was used

Last edited by AMIGASYSTEM; 16 February 2020 at 23:42.
AMIGASYSTEM is offline  
Old 16 February 2020, 23:57   #3232
CMTX
Registered User

 
Join Date: Apr 2014
Location: Mallorca es Funki
Posts: 40
Quote:
Originally Posted by PeterK View Post
No, it's the sad truth, but DOpus5 has several bugs causing memory losses, no matter whether you use v5.8 or v5.9. The latter has fixed some old bugs and introduced new ones instead. I would not recommend 5.9.

DOpus5 has a small FastMem leak when you open and close windows with icons, but it also has a huge leak when you just drag icons around on the screen, which causes really heavy memory losses.

Sorry, but I don't want to fix these bugs in DOpus5. PCs have enough memory nowadays to live with it for some hours.

In any case, I prefer to use the Workbench or Windows. At least on Aros 68k DOpus5 is still a better choice than Wanderer.
Too bad, going back to Dopus4 then

BTW thank you for your work on this!! It makes my amigan life much easier
CMTX is offline  
Old 19 February 2020, 22:38   #3233
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,595
Update to icon.library 46.4.523:

Another small optimization in the color reduction code for OS4 and PNG icons, especially for icons with more than 223 colors like for many WHDLoad games. I've also fixed some rare "holes in the cheese" when no matching color could be found or allocated. Now in such a case only pixels on the left border are made transparent, but all others are getting the color of the previous pixel.
PeterK is offline  
Old 20 February 2020, 10:59   #3234
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,382
Thanks Peter

I released my AROS One x86 (what do you think), I must say that the Icon.library of this OS is very good, it's a pity that on AROS x86 there are no tools to change Icon and change Icon Type

Always fast on mine PC Dual-Core

Tutorial Video: AROS One x86 - VMWare

Tutorial Video: AROS One x6 - VirtualBox
AMIGASYSTEM is offline  
Old 20 February 2020, 13:51   #3235
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,595
Very impressive demos of your Aros One x86 distros, but much too long for watching all of it. I think you made a good job, the only problem is that I'm the wrong customer for Aros.

Atm, I have problems to update Aros 68k with the lastest nightly builds. The new Roms are not working with my old version from December (commands in C: can't be executed) and the Installer copies just nothing from the ISO image to my existing WinUAE Aros drawer as it always did before with previous updates.

(Btw, I could make my Aros 68k a lot faster now after moving the WinUAE CPU Idle slider to the left side like in all my other configs. Don't know how that mistake could happen in the Aros settings.)

Last edited by PeterK; 20 February 2020 at 13:57.
PeterK is offline  
Old 20 February 2020, 13:57   #3236
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,382
If you want to test my Config UAE (replaced)
Attached Files
File Type: uae Aros 68k.uae (11.4 KB, 3 views)
AMIGASYSTEM is offline  
Old 20 February 2020, 14:00   #3237
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,595
Thanks Carlo, but my Aros 68k config usually works. But I'll check your config out.
PeterK is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
ClassicWB Full and icon.library 46.4 Retroplay project.ClassicWB 8 05 August 2018 14:57
WB library conflict/versions Akira support.Apps 3 22 July 2010 19:47
PNG Icon to Color Icon Converter? Leandro Jardim request.Apps 1 24 May 2010 05:39
What's the latest version of icon.library for OS3.9? NovaCoder support.Apps 3 30 June 2009 16:43
Requesting icon.library v44+... nikvest request.Other 2 16 September 2007 02:58

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 09:42.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.24748 seconds with 15 queries