English Amiga Board


Go Back   English Amiga Board > abime.net - Hall Of Light > HOL data problems

 
 
Thread Tools
Old 10 May 2008, 00:49   #1
Groundhog
Registered User
 
Join Date: Apr 2008
Location: Belgium
Posts: 93
Warlords v2.04

I just discovered that the game with the TOSEC name "Warlords v2.00 (1990)(SSG)" is in fact the v2.04. You can check that in the "about" menu of the game.

That explains why the other versions aren't really HD installable. They are older.

So the last known release for Warlords is v2.04, not v2.03.
Groundhog is offline  
Old 11 May 2008, 05:24   #2
Slayer
Amiga Member
Slayer's Avatar
 
Join Date: Aug 2003
Location: New Zealand
Age: 51
Posts: 695
I maybe wrong but I think remember this issue from years ago... wasn't 2.04 a mere hex edit?

easily done...

btw the earlier versions are ok to install just not many people had the proper installation instructions... I own 3 copies of this game and the instructions are quite specific
Slayer is offline  
Old 11 May 2008, 12:56   #3
Groundhog
Registered User
 
Join Date: Apr 2008
Location: Belgium
Posts: 93
I don't know if it was a "mere hex edit" (by the author or not) but the release seems official. See Moby Games.

And you can't follow the same procedure to install the older versions on HD. It doesn't work. The executable has been modified. It was hard coded, so assigns weren't enough.

At least that's what I experienced with v2.03, so I suppose the older versions had the same prob...

Last edited by Groundhog; 11 May 2008 at 13:02.
Groundhog is offline  
Old 11 May 2008, 13:39   #4
Belgarath
HOL Team Member

Belgarath's Avatar
 
Join Date: Dec 2001
Location: Manchester
Posts: 2,392
MobyGames is a far from reliable source.
Belgarath is offline  
Old 11 May 2008, 14:37   #5
Groundhog
Registered User
 
Join Date: Apr 2008
Location: Belgium
Posts: 93
That's why I said "seems"...
Groundhog is offline  
Old 11 May 2008, 14:56   #6
Slayer
Amiga Member
Slayer's Avatar
 
Join Date: Aug 2003
Location: New Zealand
Age: 51
Posts: 695
Yes more than assigns were needed an actual file needed to exist in the s: directory otherwise it asks for the datadisk... but hey it hardly matters now

I called the developer in Aussie once and asked him to make warlords II for the Amiga... he simply said to give him $50,000 and he would... lol
Slayer is offline  
Old 11 May 2008, 16:39   #7
Groundhog
Registered User
 
Join Date: Apr 2008
Location: Belgium
Posts: 93
Didn't know it was an australian game. Here in Belgium, it was relatively well spread, at least within my group of friends.

You should have asked him which was the last revision he made.
Groundhog is offline  
Old 12 May 2008, 09:03   #8
Slayer
Amiga Member
Slayer's Avatar
 
Join Date: Aug 2003
Location: New Zealand
Age: 51
Posts: 695
I'm quite sure I did but I can't remember with out reasonable doubt if it was infact 2.03 despite how much I'd like too
Slayer is offline  
Old 03 November 2018, 11:37   #9
AMike
Registered User
AMike's Avatar
 
Join Date: Jan 2007
Location: near Vienna/Austria
Posts: 131
I've bought last week an original Warlords 2.04 - according to the manual it's an "enhanced" version. You can find the ADFs in the TheZone.
http://eab.abime.net/showthread.php?...96#post1282196
Attached Thumbnails
Click image for larger version

Name:	IMG_20181103_101343__01.jpg
Views:	37
Size:	499.5 KB
ID:	60575   Click image for larger version

Name:	IMG_20181103_101353__02.jpg
Views:	34
Size:	489.6 KB
ID:	60576   Click image for larger version

Name:	IMG_20181103_101400__01.jpg
Views:	29
Size:	475.6 KB
ID:	60577   Click image for larger version

Name:	IMG_20181103_101410__01.jpg
Views:	31
Size:	486.6 KB
ID:	60578  
AMike is offline  
Old 03 November 2018, 16:09   #10
Epo
Registered User

 
Join Date: Aug 2018
Location: Country
Posts: 37
This is what you can read about the 2.04 change (found on here):
Quote:
Die Steuerung ist sehr einfach und leicht zu erlernen. Das Spiel
wurde konsequent weiterentwickelt. Die letzte Version von
Warlords ist 2.04. Erst bei Version 2.04 ist ein
Installationsskript für die Festplatte dabei. Bei älteren
Versionen muß das Spiel von Hand installiert werden. Und das ist
ohne Referenzkarte fast unmöglich. Auch mit, wenn man den
Druckfehler auf der Karte nicht erkennt. Ab Version 2.0 ist ein
zusätzliches Menue dazugekommen, das viele Dinge wesentlich
erleichtert und übersichtlicher macht.
In other words the only change in 2.04 is the introduction to the installation script (the versions before had to be done manually).
Epo is offline  
Old 03 November 2018, 16:39   #11
AMike
Registered User
AMike's Avatar
 
Join Date: Jan 2007
Location: near Vienna/Austria
Posts: 131
Thanks for the link. Check the screenshots above - according to the Amiga manual (Point 7) there are more improvements. I've also the manual of the 2.0 version where you can't find these informations.
Attached Thumbnails
Click image for larger version

Name:	IMG_20181103_101505__01.jpg
Views:	23
Size:	458.1 KB
ID:	60582   Click image for larger version

Name:	IMG_20181103_101500__01.jpg
Views:	24
Size:	474.4 KB
ID:	60583  
AMike is offline  
Old 03 November 2018, 18:02   #12
Epo
Registered User

 
Join Date: Aug 2018
Location: Country
Posts: 37
Quote:
Originally Posted by AMike View Post
Thanks for the link. Check the screenshots above - according to the Amiga manual (Point 7) there are more improvements. I've also the manual of the 2.0 version where you can't find these informations.
Yes, but it doesn't say if the changes are made in in 2.04. It just says Enhanced version but regarding to what version? However it does say that saves are incompatible from 1.x. So one could conclude that 'Enhanced' refers to 2.x in general. Unless I did not see what I should in this manual.

Anyway it's fantastic game. Although I always suck at it. My friend, for the other hand, was sooo good at Worlods. I had always enjoyed watching him play it.
Epo is offline  
Old 03 November 2018, 19:08   #13
AMike
Registered User
AMike's Avatar
 
Join Date: Jan 2007
Location: near Vienna/Austria
Posts: 131
Quote:
Originally Posted by Epo View Post
Yes, but it doesn't say if the changes are made in in 2.04. It just says Enhanced version but regarding to what version?

Yeap, that's the question - the first manual was from version 2.0, so the improvements have to come in a version above 2.0.
AMike is offline  
Old 03 November 2018, 19:45   #14
Epo
Registered User

 
Join Date: Aug 2018
Location: Country
Posts: 37
Quote:
Originally Posted by AMike View Post
Yeap, that's the question - the first manual was from version 2.0, so the improvements have to come in a version above 2.0.
Ah, alright, that sheds more light.
One thing I wish existed in old times was a detailed log for games. I haven't seen any info about Wing Commander but I did a research and I gathered all (I think) versions and made one archive which contains:
  • WING_v6.81E
  • Wing_v6.83E
  • Wing_v6.86G
  • Wing_vCD1.16E

All in one directory, no need to change anything - just start the version you like.
Epo is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WarLords Shoonay Games images which need to be WHDified 25 04 November 2018 10:55
Warlords mai HOL data problems 8 20 February 2009 11:02
Highway 42 - Warlords NOB HOL data problems 1 27 August 2005 21:23
WarLords working from HD? Shoonay support.Games 2 29 June 2005 10:52
Warlords / King's Bounty spoUP support.Games 2 22 July 2004 17:19

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:01.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.07772 seconds with 15 queries