English Amiga Board


Go Back   English Amiga Board > Coders > Coders. General > Coders. Releases

 
 
Thread Tools
Old 30 July 2019, 10:26   #101
BULI
Registered User

 
Join Date: Dec 2017
Location: Rzeszów
Posts: 243
For best results, start dosbox from Workbench 16bit screen, and from icon as workbench application (not shell/cli script).
Ofcourse works also many others games like:
Frontier (Textures), F1GP, Prince of Persia, Need For Speed (speed enough in low resolutions but looks very ugly, in high resolution little to slow with sound- I must find best config for best performance).

Quote:
Originally Posted by grelbfarlk View Post
Ok that's at least two people who have been able to use it, so here it is. Version bump to ONE POINT OOOOOH. This is the same version as _mgl9 so nothing new for current testers.

Last edited by BULI; 30 July 2019 at 13:12.
BULI is offline  
Old 01 August 2019, 05:01   #102
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,951
If anyone has a notion, try running Daggerfall, I haven't been able to get the versions I found working.

Stuff that's running well enough with sound at somewhere between 3000-4500 cycles:
Dark Sun 1
Archon
Zorro
This stuff needs more cycles, say 5000-12000.
Betrayal at Krondor
Space Quest 6
Crusader:No Remorse
Ultima Underworld

This is all with Ragnarok. Rapture@600MHz is a bit slower and Sonnet quite a bit slower . Apocalypse seems to run most of the above well enough, full framerate with SB1 music and sound. Monkey Island 1 at about 12000 cycles seems good, Doom at 9000 cycles and some later Sierra stuff at about 5500 cycles.

Though Sonnet will run a lot of stuff at 3000 cycles, this seems to be the floor where below that games just don't have enough CPU cycles or if the CPU can't keep up with the sound, it's not an enjoyable experience.

Last edited by grelbfarlk; 09 November 2019 at 05:25.
grelbfarlk is offline  
Old 20 August 2019, 00:19   #103
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,951
Quote:
Originally Posted by anotherlife View Post
ScummvmBEsmallwos

When i play the dig

And I get this Scummvm Fsnode::createreadstream scummvm is a direcrory

This is looking for either the ScummVM: assign, to the directory where the executable is located. Or possibly for an env variable "scumm" that you would also set to the same directory where the executable is located. Like setenv env:scumm=games:scummvm/
grelbfarlk is offline  
Old 20 August 2019, 07:59   #104
anotherlife
Registered User

 
Join Date: Oct 2015
Location: Sweden
Posts: 55
Thanks!

Quote:
Originally Posted by grelbfarlk View Post
This is looking for either the ScummVM: assign, to the directory where the executable is located. Or possibly for an env variable "scumm" that you would also set to the same directory where the executable is located. Like setenv env:scumm=games:scummvm/

Last edited by anotherlife; 20 August 2019 at 08:37.
anotherlife is offline  
Old 20 August 2019, 13:27   #105
anotherlife
Registered User

 
Join Date: Oct 2015
Location: Sweden
Posts: 55
I get this error Graphicswidget has size 10x10, but a surfa e with 160x100 is to be set
anotherlife is offline  
Old 20 August 2019, 14:07   #106
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,951
Quote:
Originally Posted by anotherlife View Post
I get this error Graphicswidget has size 10x10, but a surfa e with 160x100 is to be set

Don't know about that one, do you have aspect ratio correction on? Are you using filters or scalers?
grelbfarlk is offline  
Old 20 August 2019, 18:21   #107
anotherlife
Registered User

 
Join Date: Oct 2015
Location: Sweden
Posts: 55
Quote:
Originally Posted by grelbfarlk View Post
Don't know about that one, do you have aspect ratio correction on? Are you using filters or scalers?
Nope
anotherlife is offline  
Old 20 August 2019, 22:20   #108
anotherlife
Registered User

 
Join Date: Oct 2015
Location: Sweden
Posts: 55
The problem I have now is that the game (the dig) keeps pausing
anotherlife is offline  
Old 20 August 2019, 23:19   #109
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,951
Quote:
Originally Posted by anotherlife View Post
The problem I have now is that the game (the dig) keeps pausing

Without knowing more, I will guess that it is the uncompressed audio. The Dig has heavy use of digitized audio, people talking, music etc. Try compressing to Ogg with the ScummVM tools on Windows, Linux, etc. This sounds like what we were complaining about with COMI before Hedeon figured this out.
grelbfarlk is offline  
Old 21 August 2019, 12:50   #110
anotherlife
Registered User

 
Join Date: Oct 2015
Location: Sweden
Posts: 55
Thanks for all the help. I have compressed to ogg and it runs perfekt now
anotherlife is offline  
Old 22 August 2019, 02:32   #111
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,951
Quote:
Originally Posted by anotherlife View Post
Thanks for all the help. I have compressed to ogg and it runs perfekt now

Just keep in mind MT-32 emulation takes a lot more CPU power than you've got. It's ok on a Ragnarok but you're better off finding versions of the soundtracks that are a recording of the MT-32 output compressed to either MP3 or OGG. Which should sound very nearly identical to a real MT-32 (though through Paula, so not really). Maybe if your AHI unit 0 is on a Zorro or PCI sound card but that can be a little dicey.

Last edited by grelbfarlk; 22 August 2019 at 02:38.
grelbfarlk is offline  
Old 22 August 2019, 14:57   #112
anotherlife
Registered User

 
Join Date: Oct 2015
Location: Sweden
Posts: 55
Quote:
Originally Posted by grelbfarlk View Post
Just keep in mind MT-32 emulation takes a lot more CPU power than you've got. It's ok on a Ragnarok but you're better off finding versions of the soundtracks that are a recording of the MT-32 output compressed to either MP3 or OGG. Which should sound very nearly identical to a real MT-32 (though through Paula, so not really). Maybe if your AHI unit 0 is on a Zorro or PCI sound card but that can be a little dicey.
Tried comi and as you say compressed ogg is to much for my cpu. Where can I find recording of the MT-32 output?
anotherlife is offline  
Old 22 August 2019, 15:59   #113
trixster
Guru Meditating

 
Join Date: Jun 2014
Location: England
Posts: 1,496
Google?
trixster is offline  
Old 22 August 2019, 16:26   #114
anotherlife
Registered User

 
Join Date: Oct 2015
Location: Sweden
Posts: 55
Quote:
Originally Posted by trixster View Post
Google?
Have tried but don't know what to look for

Last edited by anotherlife; 22 August 2019 at 16:35.
anotherlife is offline  
Old 23 August 2019, 00:30   #115
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,951
Quote:
Originally Posted by anotherlife View Post
Tried comi and as you say compressed ogg is to much for my cpu. Where can I find recording of the MT-32 output?

I'm pretty sure that it uses digitized audio for everything, not MT-32 or MIDI. So this isn't going to help you really, I meant for older older stuff like Monkey Island 1/2 or the Sierra games which do use MT-32. You might try reducing your mixing rate in the ScummVM options, make sure that mixes whatever rate the OGG audio is using, or possibly compress the OGG to a lower quality. Other than that there's not much I can really suggest.
grelbfarlk is offline  
Old 26 August 2019, 03:32   #116
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,951
On Dosbox, Ultima Underworld runs pretty much fine on Ragnarok at about 9000 cycles.
grelbfarlk is offline  
Old 19 November 2019, 10:10   #117
BULI
Registered User

 
Join Date: Dec 2017
Location: Rzeszów
Posts: 243
Quote:
Originally Posted by grelbfarlk View Post
Ok that's at least two people who have been able to use it, so here it is. Version bump to ONE POINT OOOOOH. This is the same version as _mgl9 so nothing new for current testers.

Thanks for this
BULI is offline  
Old 27 November 2019, 03:00   #118
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,733
Hi,

You might want to use my cut-down simple core, it's had all error checking removed so it runs slightly quicker but it's now less compatible as a result.
Attached Files
File Type: zip core_simple_no_error_checking.zip (17.6 KB, 12 views)
NovaCoder is offline  
Old 28 November 2019, 02:07   #119
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,951
Quote:
Originally Posted by NovaCoder View Post
Hi,

You might want to use my cut-down simple core, it's had all error checking removed so it runs slightly quicker but it's now less compatible as a result.
Thanks Nova, I'll give it a try integrating it.

By the way did you get the joysticks working correctly?
grelbfarlk is offline  
Old 28 November 2019, 03:02   #120
NovaCoder
Registered User
NovaCoder's Avatar
 
Join Date: Sep 2007
Location: Melbourne/Australia
Posts: 3,733
Quote:
Originally Posted by grelbfarlk View Post
Thanks Nova, I'll give it a try integrating it.

By the way did you get the joysticks working correctly?
I've got no idea about correctly but I managed to play commander keen. Maybe give my 68K RTG port a play using winuae and see if it works.
NovaCoder is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
GemRB for Classic Amiga WarpOS grelbfarlk Coders. Releases 13 22 September 2019 03:11
DGen for Classic Amiga WarpOS grelbfarlk Coders. Releases 14 11 July 2019 02:53
PrBoom (Doom Engine) for Classic Amiga WarpOS grelbfarlk Coders. Releases 14 06 June 2019 04:21
ScummVM WarpOS PPC drluking support.Apps 6 30 September 2018 00:29
Dosbox for WarpOS or WOS grelbfarlk request.Apps 0 06 May 2017 00:26

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:13.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.09233 seconds with 14 queries