English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 21 February 2016, 20:50   #1
retrocomputer22
 
Posts: n/a
Amiga 1200 PRoblem - HELP!

I have an Amiga 1200 that I've owned for a long time. It one of the originals manufactured by Commodore. In the past week I've been using it quite a bit playing ProjectX and Disposable Heroes, 2 of my favorite shoot'em'ups of all-time. I also discovered a game I didn't know about called powder which is also a cool game as well. Anyway, I loaded powder and lft my Amiga alone while doing something else and the screen went blank. I was still able to do a soft reboot using the keyboard. I tried to reboot but nothing came on the screen. Even though I was able to do a soft reboot, the HD and floppy weren't working either.

I have a scaldy VGA modification and my first though was maybe it was overheating causing me this problem. So I opened the Amiga and removed the scaldy. Afterwards I tried booting the system again. It worked. Therefore I figured my scaldy was just dead. I loaded a game and it wasn't long before the Amiga screen black again.

This was making me sick to my stomach. I left mt Amiga along for a while.
After about 1/2 and hour, I tried to boot the Amiga and once again it came up fine.

Therefore I have an Amiga 1200 that shuts down after using it for a short time. I tried a new power supply and it made no difference. Does anyone have a clue what may be going on? I really want to get it working again since the A1200 is the only "FUN" computer I own.

Thanks in advance for any help.

Jeffrey
 
AdSense AdSense  
Old 21 February 2016, 23:13   #2
Steve
Kickstarter Addict!
Steve's Avatar
 
Join Date: Jul 2001
Location: UK
Age: 39
Posts: 2,123
If it works from cold every time but only for a short time then clearly something is overheating your machine. Something inside is getting too hot though it could be anything. There are temperature readers you can buy that test the temperature of computer chips so you can see which one is overheating.
Steve is offline  
Old 21 February 2016, 23:14   #3
crazyc
Registered User
 
Join Date: May 2012
Location: Gravesend - UK
Posts: 408
Whilst I am no expert and can't say if this is the issue, if you want to keep your a1200 functional, and it has not yet been recapped, then I would deffo get that done.
crazyc is offline  
Old 22 February 2016, 01:41   #4
retrocomputer22
 
Posts: n/a
Is recapping just redoing the solder points?
 
Old 22 February 2016, 02:13   #5
voyager
The show must go on.
voyager's Avatar
 
Join Date: Dec 2010
Location: Alkmaar Nederland
Posts: 237
Send a message via MSN to voyager
No its replacing the capacitors. They go bad.
voyager is offline  
Old 22 February 2016, 10:51   #6
Daedalus
Registered User

Daedalus's Avatar
 
Join Date: Jun 2009
Location: Dublin, then Glasgow
Posts: 2,335
Indeed, I would replace the capacitors and then run the machine for a while without a top cover to see if you can tell which chip is overheating (if any). They get warm to touch normally, but never so hot that they should need heatsinks for example.
Daedalus is offline  
Old 22 February 2016, 20:35   #7
retrocomputer22
 
Posts: n/a
Thanks, I'll look into a recap. Maybe I can find someone local who can do it. There is a vintage game console shop near me and they claim to do stuff like this.

Jeffrey

P.s. Is there anyplace in the US that still sells A1200 motherboards? Amigakit doesn't seem to have any. I know I can watch on eBay.
 
Old 23 February 2016, 15:44   #8
Daedalus
Registered User

Daedalus's Avatar
 
Join Date: Jun 2009
Location: Dublin, then Glasgow
Posts: 2,335
Yep, bad capacitors is a relatively common thing across many consoles of a similar age, so if you have someone local that does repairs like that, that's great. Just make sure they replace like with like, as in they use surface mount to replace surface mount. Some people replace surface mount with through hole and it risks causing problems further down the line.
Daedalus is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
my amiga 1200 problem herakleus Hardware mods 8 25 January 2013 16:32
Amiga 1200 graphics problem Tallrot support.Hardware 2 12 November 2010 15:02
Amiga 1200 Problem LazerBall support.Hardware 6 06 October 2006 21:52
problem with an amiga 1200 motherboard whitebird support.Hardware 17 04 June 2006 13:06
Amiga 1200 keyboard problem wlcina support.Hardware 6 13 February 2005 15:09

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 22:20.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.14187 seconds with 14 queries